Debugging missing DLL (Sibelius 2018.7)

Questions about Wine on Linux
Post Reply
dried
Level 2
Level 2
Posts: 11
Joined: Tue Oct 23, 2018 8:35 pm

Debugging missing DLL (Sibelius 2018.7)

Post by dried » Tue Oct 23, 2018 8:57 pm

Hi friends,

Sibelius 2018.7, the current release from Avid, installs on wine successfully, but running the application fails. On the development version of wine, the Avid application manager runs fine and the installer installs some fonts, but the application still fails. Installing winbind removed one error, but the remaining one (which occurs when running the application after installation succeeds, and apart from several dozen fixmes) is

Code: Select all

Loading AvidRemoteObjects364.dll
LoadLibrary failed:  Check your system32 or SysWOW64 directory for AvidRemoteObjects364.dll
It looks like some critical DLL fails to install. Using the winetricks verbs which have worked with previous Sibelius versions don't change the behavior. Does anyone have any suggestions on how to proceed?

ldkraemer
Level 1
Level 1
Posts: 6
Joined: Sat Oct 20, 2018 12:19 pm

Re: Debugging missing DLL (Sibelius 2018.7)

Post by ldkraemer » Wed Oct 24, 2018 8:21 am

Sure, you likely have this same software installed on a Windows machine. Just copy the file(s)
that are missing from a Windows Install to your wine subdirectory as it's telling you.


Larry

dried
Level 2
Level 2
Posts: 11
Joined: Tue Oct 23, 2018 8:35 pm

Re: Debugging missing DLL (Sibelius 2018.7)

Post by dried » Wed Oct 24, 2018 2:24 pm

ldkraemer wrote:Sure, you likely have this same software installed on a Windows machine. Just copy the file(s)
that are missing from a Windows Install to your wine subdirectory as it's telling you.
I thought I'd try that approach so I installed the software on a win10 VM to look for the DLL -- no luck, at least not in system32, syswow64, or any registry keys. I also didn't find any mention of it in the registry of the wine install.

So I'm grasping at straws. My next plan is to use dependency walker on both installs to find the differences. (Unfortunately my VM is very slow so this is currently "in progress".)

edit: dependency walker doesn't mention AvidRemoteObjects or variants like ARO*, RO*, RemoteObjects. Maybe this is a red herring?

User avatar
DarkShadow44
Level 7
Level 7
Posts: 943
Joined: Tue Nov 22, 2016 5:39 pm

Re: Debugging missing DLL (Sibelius 2018.7)

Post by DarkShadow44 » Mon Nov 05, 2018 11:08 am

The DLL is probably a part of the program. Is there a free version to test with? A full log would be good, too.

User avatar
Bob Wya
Level 12
Level 12
Posts: 2777
Joined: Sat Oct 16, 2010 7:40 pm
Location: Cambridge
Contact:

Re: Debugging missing DLL (Sibelius 2018.7)

Post by Bob Wya » Mon Nov 05, 2018 11:45 am

@ dried

Are you running the application correctly? See: Wine User's Guide: 3.1 How to install and run Windows programs.

Windows uses the present working directory as part of the PATH search for executable files, which is distinct from the Unix/Linux default.
This includes searching for dynamic link libraries.

Bob

dried
Level 2
Level 2
Posts: 11
Joined: Tue Oct 23, 2018 8:35 pm

Re: Debugging missing DLL (Sibelius 2018.7)

Post by dried » Fri May 03, 2019 11:52 pm

Sorry for the delay -- I think I missed your replies.

Yes, I have been starting from the application's directory (drive_c/Program Files/Avid/Sibelius); and I also tried running with wine start -- same results. Thanks for the info though.

As for logs, the only output I'm getting now is the missing DLL:

Code: Select all

Loading AvidRemoteObjects364.dll
LoadLibrary failed:  Check your system32 or SysWOW64 directory for AvidRemoteObjects364.dll
Here's the log from the installation (I've edited it to remove duplicate logs; most statements were logged between 4 and about 40 times):

Code: Select all

002a:err:mscoree:LoadLibraryShim error reading registry key for installroot
002a:err:richedit:ReadColorTbl malformed entry
002a:err:richedit:ReadStyleSheet skipping optional destination
003f:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
004a:err:richedit:ReadColorTbl malformed entry
004a:err:richedit:ReadStyleSheet skipping optional destination
0042:err:mscoree:LoadLibraryShim error reading registry key for installroot
0051:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
0052:err:mscoree:LoadLibraryShim error reading registry key for installroot
0052:err:ole:COMPOBJ_DllList_Add couldn't load in-process dll L"C:\\windows\\system32\\msxml3.dll"
0052:err:ole:CoGetClassObject no class object {f6d90f11-9c73-11d3-b32e-00c04f990bb4} could be created for context 0x1
0052:err:msi:msi_install_assembly Failed to install assembly L"C:\\users\\dried\\Temp\\msi1.tmp\\amd64_Microsoft.VC90.ATL_1fc8b3b9a1e18e3b_9.0.30729.4148_x-ww_673f7fa2.manifest" (0x80070005)
0052:err:msi:ACTION_InstallFiles Failed to install assembly
0052:err:msi:execute_script Execution of script 0 halted; action L"InstallFiles" returned 1603
0052:err:msi:ITERATE_Actions Execution halted, action L"InstallFinalize" returned 1603
0052:err:ole:COMPOBJ_DllList_Add couldn't load in-process dll L"C:\\windows\\system32\\msxml3.dll"
0052:err:ole:CoGetClassObject no class object {f6d90f11-9c73-11d3-b32e-00c04f990bb4} could be created for context 0x1
0057:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
0059:err:mscoree:LoadLibraryShim error reading registry key for installroot
0088:err:richedit:ReadColorTbl malformed entry
0088:err:richedit:ReadStyleSheet skipping optional destination
0080:err:mscoree:LoadLibraryShim error reading registry key for installroot
00a3:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
00a5:err:mscoree:LoadLibraryShim error reading registry key for installroot
00e0:err:richedit:ReadColorTbl malformed entry
00e0:err:richedit:ReadStyleSheet skipping optional destination
00d8:err:mscoree:LoadLibraryShim error reading registry key for installroot
0104:err:richedit:ReadStyleSheet skipping optional destination
00fc:err:mscoree:LoadLibraryShim error reading registry key for installroot
0140:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
014b:err:mscoree:LoadLibraryShim error reading registry key for installroot
0167:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
I've also just replaced all of Program Files/Avid with the VM's copy and I'm still getting the same results. I've also since installed winbind. I'm suspicious it might have affected the installation process, but the Sibelius.exe binary was the same size as on the VM and the complementary apps (Avid Link and Avid Application Manager) also installed and seem to work. Next step is to install in a clean prefix to see if winbind made a difference.

lahmbi5678
Level 7
Level 7
Posts: 823
Joined: Thu Aug 27, 2009 6:23 am

Re: Debugging missing DLL (Sibelius 2018.7)

Post by lahmbi5678 » Sun May 05, 2019 12:40 am

Does Sibelius require a certain .NET version?

dried
Level 2
Level 2
Posts: 11
Joined: Tue Oct 23, 2018 8:35 pm

Re: Debugging missing DLL (Sibelius 2018.7)

Post by dried » Sat May 11, 2019 9:53 pm

lahmbi5678 wrote:Does Sibelius require a certain .NET version?
I'm not sure. I just (re)installed .NET 4.7.2 with winetricks to be sure, same result.

dried
Level 2
Level 2
Posts: 11
Joined: Tue Oct 23, 2018 8:35 pm

Re: Debugging missing DLL (Sibelius 2018.7)

Post by dried » Sat May 11, 2019 10:04 pm

DarkShadow44 wrote:Is there a free version to test with?
Forgot to address this. The software does have a free tier and a free trial of the full tier. Download here: https://www.avid.com/sibelius (nb - you need to supply an email address for the download).

User avatar
DarkShadow44
Level 7
Level 7
Posts: 943
Joined: Tue Nov 22, 2016 5:39 pm

Re: Debugging missing DLL (Sibelius 2018.7)

Post by DarkShadow44 » Sun May 12, 2019 8:58 am

I can confirm the issue and opened a bugreport: https://bugs.winehq.org/show_bug.cgi?id=47174

dried
Level 2
Level 2
Posts: 11
Joined: Tue Oct 23, 2018 8:35 pm

Re: Debugging missing DLL (Sibelius 2018.7)

Post by dried » Sun May 12, 2019 9:33 am

DarkShadow44 wrote:I can confirm the issue and opened a bugreport: https://bugs.winehq.org/show_bug.cgi?id=47174
Thank you! Please let me know how I can help / test. Sibelius on wine would be huge for me.

User avatar
DarkShadow44
Level 7
Level 7
Posts: 943
Joined: Tue Nov 22, 2016 5:39 pm

Re: Debugging missing DLL (Sibelius 2018.7)

Post by DarkShadow44 » Sun May 12, 2019 9:38 am

I currently can't think of a way to help, the link is already one of the best things you could have provided. But make sure you subscribe to the bug, so you get notified of updates.

dried
Level 2
Level 2
Posts: 11
Joined: Tue Oct 23, 2018 8:35 pm

Re: Debugging missing DLL (Sibelius 2018.7)

Post by dried » Wed Aug 28, 2019 9:24 am

Bob Wya wrote:@ dried

Are you running the application correctly? See: Wine User's Guide: 3.1 How to install and run Windows programs.

Windows uses the present working directory as part of the PATH search for executable files, which is distinct from the Unix/Linux default.
This includes searching for dynamic link libraries.

Bob
So it turns out Bob was right and I didn't try hard enough. Installing the program with 'wine start' and running it that way seem to have fixed the missing DLL issue. However, the program still won't run:

Code: Select all

0009:fixme:exec:SHELL_execute flags ignored: 0x00000100
002b:fixme:wer:WerRegisterFile (L"C:\\users\\dried\\Application Data\\Avid\\Logs\\startup.log", 2, 2) stub!
002b:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x23f110 1 C) semi-stub
002b:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x23eb80 1 C) semi-stub
002b:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x23eb90 1 C) semi-stub
002b:fixme:process:RegisterApplicationRestart (L"/restart",0)
002b:fixme:file:FindFirstFileExW flags not implemented 0x00000002
002b:fixme:win:EnumDisplayDevicesW ((null),0,0x23e6a0,0x00000000), stub!
002b:fixme:wgl:X11DRV_wglGetPixelFormatAttribivARB unsupported 2008 WGL Attribute
002b:fixme:file:FindFirstFileExW flags not implemented 0x00000002
002b:fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
002b:fixme:toolhelp:Heap32ListFirst : stub
0017:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 74080 (device=7 access=1 func=20 method=0)
0017:fixme:mountmgr:query_property Faking StorageDeviceProperty data
002b:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x23e7a0 1 C) semi-stub
002b:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x23e8a0 1 C) semi-stub
002b:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x23e670 1 C) semi-stub
002b:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x23e0d0 1 C) semi-stub
0017:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 74080 (device=7 access=1 func=20 method=0)
0017:fixme:mountmgr:query_property Faking StorageDeviceProperty data
002b:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x23e0c0 1 C) semi-stub
002b:fixme:ntdll:NtQueryInformationToken QueryInformationToken( ..., TokenElevation, ...) semi-stub
002b:fixme:msvcrt:__clean_type_info_names_internal (0xd9b3c38) stub
002b:fixme:msvcrt:__clean_type_info_names_internal (0x3e6b78) stub
This is in a clean prefix using wine-4.0.2. This is a little off the stated topic, but I'd be very grateful for any leads.

I've updated that bug report as well.

edit: the +relay,+seh,+tld output is almost 3gb so it's not attached. There are a bunch of similar seh traces (other than the thread renaming exception) which look like:

Code: Select all

002a:Call ucrtbase.memcpy(18381db8,142730b20,0000000e) ret=14001413a
002a:Ret  ucrtbase.memcpy() retval=18381db8 ret=14001413a
002a:Call ucrtbase.longjmp(0023f490,00000001) ret=14000c9c7
002a:trace:seh:RtlUnwindEx code=80000026 flags=2 end_frame=0x23f450 target_ip=0x14000ca3a rip=000000007bc9d5f5
002a:trace:seh:RtlUnwindEx  info[0]=000000000023f490
002a:trace:seh:RtlUnwindEx  rax=00007fffffea8000 rbx=000000000023fe20 rcx=000000000023ebb0 rdx=000000014000ca3a
002a:trace:seh:RtlUnwindEx  rsi=000000000023ebb0 rdi=000000000023e5b0 rbp=000000000023eb70 rsp=000000000023e3e0
002a:trace:seh:RtlUnwindEx   r8=000000000023f170  r9=0000000000000001 r10=000000007bcd60ae r11=0000000000000246
002a:trace:seh:RtlUnwindEx  r12=000000000023f170 r13=0000000000000001 r14=00000000ffffffff r15=0000000005ccbbb0
002a:trace:seh:dwarf_virtual_unwind function 7bc9d5f5 base 0x7bc9d520 cie 0x7bce7dd0 len 14 id 0 version 1 aug 'zR' code_align 1 data_align -8 retaddr %rip
002a:trace:seh:execute_cfa_instructions 7bc9d520: DW_CFA_def_cfa %rsp, 8
002a:trace:seh:execute_cfa_instructions 7bc9d520: DW_CFA_offset %rip, -8
002a:trace:seh:dwarf_virtual_unwind fde 0x7bd01dd8 len 90 personality (nil) lsda (nil) code 7bc9d520-7bc9e188
...
but from all I can tell, 0x80000026 is just "Unknown Exception" so I don't know how useful or critical that is.

dried
Level 2
Level 2
Posts: 11
Joined: Tue Oct 23, 2018 8:35 pm

Re: Debugging missing DLL (Sibelius 2018.7)

Post by dried » Sat Sep 14, 2019 11:51 am

Similar results on wine-staging (4.15), except now there's a pop-up from Sibelius saying "There was an error activating the licensing engine. Your copy of Sibelius needs to be reactivated. For further help please go to www.avid.com/license-renewal-help." Following the instructions there doesn't yield new results.

This combined with the "harddisk_ioctl Unsupported ioctl 74080 (device=7 access=1 func=20 method=0)" message make me think this is an issue with some anti-debugger technique or possibly this SecureRom 5.x issue.

+mountmgr log:

Code: Select all

000b:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
000b:fixme:winediag:start_process Wine Staging 4.15 is a testing version containing experimental patches.
000b:fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq.org.
000f:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
000d:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
0012:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
0014:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
001b:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
0022:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
0024:trace:mountmgr:DriverEntry L"\\Registry\\Machine\\System\\CurrentControlSet\\Services\\MountMgr"
0024:trace:mountmgr:create_disk_device created device L"\\Device\\Harddisk0"
0024:trace:mountmgr:create_disk_device created device L"\\Device\\HarddiskVolume1"
0024:trace:mountmgr:add_mount_point created L"\\??\\Volume{00000000-0000-0000-0000-000000000043}" id (null) for L"\\Device\\HarddiskVolume1"
0024:trace:mountmgr:add_mount_point created L"\\DosDevices\\C:" id (null) for L"\\Device\\HarddiskVolume1"
0024:trace:mountmgr:create_disk_device created device L"\\Device\\HarddiskVolume2"
0024:trace:mountmgr:add_mount_point created L"\\??\\Volume{00000000-0000-0000-0000-00000000005a}" id (null) for L"\\Device\\HarddiskVolume2"
0024:trace:mountmgr:add_mount_point created L"\\DosDevices\\Z:" id (null) for L"\\Device\\HarddiskVolume2"
0024:trace:mountmgr:initialize_diskarbitration Skipping, Disk Arbitration support not compiled in
0026:trace:mountmgr:udisks2_add_device udi "/org/freedesktop/UDisks2/block_devices/loop6" device "/dev/loop6" mount point (null) uuid (null) type "" removable 0
0026:trace:mountmgr:udisks2_add_device udi "/org/freedesktop/UDisks2/block_devices/nvme0n1p3" device "/dev/nvme0n1p3" mount point (null) uuid {5e2f73f5-075a-41f1-a137-7fa1e0a76499} type "crypto_LUKS" removable 0
0026:trace:mountmgr:add_volume adding "/org/freedesktop/UDisks2/block_devices/nvme0n1p3" device "/dev/nvme0n1p3" mount (null) type 2 uuid {5e2f73f5-075a-41f1-a137-7fa1e0a76499}
0026:trace:mountmgr:create_disk_device created device L"\\Device\\HarddiskVolume3"
0026:trace:mountmgr:add_mount_point created L"\\??\\Volume{5e2f73f5-075a-41f1-a137-7fa1e0a76499}" id (null) for L"\\Device\\HarddiskVolume3"
0026:trace:mountmgr:udisks2_add_device udi "/org/freedesktop/UDisks2/block_devices/dm_2d2" device "/dev/dm-2" mount point (null) uuid {13972b07-b494-4966-b25b-813601a8192f} type "swap" removable 0
0026:trace:mountmgr:add_volume adding "/org/freedesktop/UDisks2/block_devices/dm_2d2" device "/dev/dm-2" mount (null) type 2 uuid {13972b07-b494-4966-b25b-813601a8192f}
0026:trace:mountmgr:create_disk_device created device L"\\Device\\HarddiskVolume4"
0026:trace:mountmgr:add_mount_point created L"\\??\\Volume{13972b07-b494-4966-b25b-813601a8192f}" id (null) for L"\\Device\\HarddiskVolume4"
0026:trace:mountmgr:udisks2_add_device udi "/org/freedesktop/UDisks2/block_devices/loop1" device "/dev/loop1" mount point (null) uuid (null) type "" removable 0
0026:trace:mountmgr:udisks2_add_device udi "/org/freedesktop/UDisks2/block_devices/loop4" device "/dev/loop4" mount point (null) uuid (null) type "" removable 0
0026:trace:mountmgr:udisks2_add_device udi "/org/freedesktop/UDisks2/block_devices/loop7" device "/dev/loop7" mount point (null) uuid (null) type "" removable 0
0026:trace:mountmgr:udisks2_add_device udi "/org/freedesktop/UDisks2/block_devices/nvme0n1p1" device "/dev/nvme0n1p1" mount point "/boot/efi" uuid {00000000-e5be-93ac-0000-000000000000} type "vfat" removable 0
0026:trace:mountmgr:add_volume adding "/org/freedesktop/UDisks2/block_devices/nvme0n1p1" device "/dev/nvme0n1p1" mount "/boot/efi" type 2 uuid {00000000-e5be-93ac-0000-000000000000}
0026:trace:mountmgr:create_disk_device created device L"\\Device\\HarddiskVolume5"
0026:trace:mountmgr:add_mount_point created L"\\??\\Volume{00000000-e5be-93ac-0000-000000000000}" id (null) for L"\\Device\\HarddiskVolume5"
0026:trace:mountmgr:udisks2_add_device udi "/org/freedesktop/UDisks2/block_devices/dm_2d0" device "/dev/dm-0" mount point (null) uuid (null) type "LVM2_member" removable 0
0026:trace:mountmgr:udisks2_add_device udi "/org/freedesktop/UDisks2/block_devices/nvme0n1p4" device "/dev/nvme0n1p4" mount point (null) uuid {1051898c-8dfe-4663-a1ee-814098218f8e} type "swap" removable 0
0026:trace:mountmgr:add_volume adding "/org/freedesktop/UDisks2/block_devices/nvme0n1p4" device "/dev/nvme0n1p4" mount (null) type 2 uuid {1051898c-8dfe-4663-a1ee-814098218f8e}
0026:trace:mountmgr:create_disk_device created device L"\\Device\\HarddiskVolume6"
0026:trace:mountmgr:add_mount_point created L"\\??\\Volume{1051898c-8dfe-4663-a1ee-814098218f8e}" id (null) for L"\\Device\\HarddiskVolume6"
0026:trace:mountmgr:udisks2_add_device udi "/org/freedesktop/UDisks2/block_devices/nvme0n1" device "/dev/nvme0n1" mount point (null) uuid (null) type "" removable 0
0026:trace:mountmgr:udisks2_add_device udi "/org/freedesktop/UDisks2/block_devices/loop2" device "/dev/loop2" mount point (null) uuid (null) type "" removable 0
0026:trace:mountmgr:udisks2_add_device udi "/org/freedesktop/UDisks2/block_devices/loop5" device "/dev/loop5" mount point (null) uuid (null) type "" removable 0
0026:trace:mountmgr:udisks2_add_device udi "/org/freedesktop/UDisks2/block_devices/nvme0n1p2" device "/dev/nvme0n1p2" mount point "/recovery" uuid {00000000-e5be-9521-0000-000000000000} type "vfat" removable 0
0026:trace:mountmgr:add_volume adding "/org/freedesktop/UDisks2/block_devices/nvme0n1p2" device "/dev/nvme0n1p2" mount "/recovery" type 2 uuid {00000000-e5be-9521-0000-000000000000}
0026:trace:mountmgr:create_disk_device created device L"\\Device\\HarddiskVolume7"
0026:trace:mountmgr:add_mount_point created L"\\??\\Volume{00000000-e5be-9521-0000-000000000000}" id (null) for L"\\Device\\HarddiskVolume7"
0026:trace:mountmgr:udisks2_add_device udi "/org/freedesktop/UDisks2/block_devices/dm_2d1" device "/dev/dm-1" mount point "/" uuid {187d21ea-06ce-44a9-a0e3-806a542262a8} type "ext4" removable 0
0026:trace:mountmgr:add_volume adding "/org/freedesktop/UDisks2/block_devices/dm_2d1" device "/dev/dm-1" mount "/" type 2 uuid {187d21ea-06ce-44a9-a0e3-806a542262a8}
0026:trace:mountmgr:find_matching_volume found matching volume {00000000-0000-0000-0000-00000000005a} for device "/dev/dm-1" mount "/" type 2
0026:trace:mountmgr:delete_mount_point deleting L"\\??\\Volume{00000000-0000-0000-0000-00000000005a}"
0026:trace:mountmgr:add_mount_point created L"\\??\\Volume{187d21ea-06ce-44a9-a0e3-806a542262a8}" id (null) for L"\\Device\\HarddiskVolume2"
0026:trace:mountmgr:udisks2_add_device udi "/org/freedesktop/UDisks2/block_devices/loop0" device "/dev/loop0" mount point (null) uuid (null) type "" removable 0
0026:trace:mountmgr:udisks2_add_device udi "/org/freedesktop/UDisks2/block_devices/sda" device "/dev/sda" mount point (null) uuid (null) type "" removable 1
0026:trace:mountmgr:create_disk_device created device L"\\Device\\Harddisk1"
0026:trace:mountmgr:add_mount_point created L"\\??\\Volume{00000000-0000-0000-0000-000000000044}" id (null) for L"\\Device\\Harddisk1"
0026:trace:mountmgr:add_mount_point created L"\\DosDevices\\D:" id (null) for L"\\Device\\Harddisk1"
0026:trace:mountmgr:add_dos_device added device d: udi "/org/freedesktop/UDisks2/block_devices/sda" for "/dev/sda" on (null) type 0
0026:trace:mountmgr:udisks2_add_device udi "/org/freedesktop/UDisks2/block_devices/loop3" device "/dev/loop3" mount point (null) uuid (null) type "" removable 0
0026:trace:mountmgr:udisks_filter ignoring message type=4 path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameAcquired
002b:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
002b:fixme:wer:WerRegisterFile (L"C:\\users\\dried\\Application Data\\Avid\\Logs\\startup.log", 2, 2) stub!
002b:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (000000000022F230 1 C) semi-stub
002b:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (000000000022EEA0 1 C) semi-stub
002b:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (000000000022EE80 1 C) semi-stub
002b:fixme:process:RegisterApplicationRestart (L"/restart",0)
002b:fixme:wgl:X11DRV_wglGetPixelFormatAttribivARB unsupported 2008 WGL Attribute
002d:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
002b:fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
002b:fixme:toolhelp:Heap32ListFirst : stub
0025:trace:mountmgr:harddisk_ioctl ioctl 74080 insize 0 outsize 24
0025:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 74080 (device=7 access=1 func=20 method=0)
0025:trace:mountmgr:harddisk_ioctl ioctl 2d1400 insize 12 outsize 10000
0025:fixme:mountmgr:query_property Faking StorageDeviceProperty data
0025:trace:mountmgr:harddisk_ioctl ioctl 24000 insize 0 outsize 804
002b:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (000000000022E8B0 1 C) semi-stub
002b:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (000000000022E900 1 C) semi-stub
002b:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (000000000022E7A0 1 C) semi-stub
002b:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (000000000022E3D0 1 C) semi-stub
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/Devices/3"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/Devices/3"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0025:trace:mountmgr:harddisk_ioctl ioctl 24000 insize 0 outsize 804
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/Devices/3"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/Devices/3"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/UPower/devices/battery_BAT0"
002b:fixme:msvcrt:__clean_type_info_names_internal (0xec03c38) stub
002b:fixme:msvcrt:__clean_type_info_names_internal (0x3d6b78) stub
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2etimer"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2etimer"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/job/55408"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2etimer"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2etimer"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/Devices/3"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/UPower/devices/battery_BAT1"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/UPower/devices/DisplayDevice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/Devices/3"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2etimer"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2etimer"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/job/55511"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2etimer"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2etimer"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/Devices/3"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/Devices/3"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/Devices/3"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/Devices/3"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/UPower/devices/battery_BAT0"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/Devices/3"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/UPower/devices/battery_BAT1"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/UPower/devices/DisplayDevice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2etimer"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2etimer"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/systemd_2dhostnamed_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/systemd_2dhostnamed_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/systemd_2dhostnamed_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/systemd_2dhostnamed_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/job/55614"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/job/55718"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2etimer"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2etimer"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/undervolt_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/systemd_2dhostnamed_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/systemd_2dhostnamed_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/systemd_2dhostnamed_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/systemd_2dhostnamed_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/Devices/3"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/login1"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/Devices/3"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/NetworkManager/AccessPoint/725"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/systemd_2dhostnamed_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/systemd_2dhostnamed_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/systemd_2dhostnamed_2eservice"
0026:trace:mountmgr:udisks_filter changed "/org/freedesktop/systemd1/unit/systemd_2dhostnamed_2eservice"

dried
Level 2
Level 2
Posts: 11
Joined: Tue Oct 23, 2018 8:35 pm

Re: Debugging missing DLL (Sibelius 2018.7)

Post by dried » Thu Sep 26, 2019 3:59 pm

Similar results with wine 4.16.

I've tried to take a step back a bit, so I analysed the +seh output. Looks like there are three (blocks of) errors:

1: Generic exception (?). This happens three times in the same trace:seh block, and doesn't appear to be handled.

Code: Select all

002a:trace:seh:RtlUnwindEx code=80000026 flags=2 end_frame=0x22f400 target_ip=0x14000ca3a rip=000000007bcdbde5
2: Thread rename exception.

Code: Select all

002a:trace:seh:raise_exception code=406d1388 flags=0 addr=0x7104e14d ip=7104e14d tid=002a
.
its handler returns 0:

Code: Select all

002a:trace:seh:call_handler handler at 0x140b8e6bf returned 0
3: Another generic exception.

Code: Select all

002a:trace:seh:RtlUnwindEx code=80000026 flags=2 end_frame=0x22ea80 target_ip=0x14000ca3a rip=000000007bcdbde5
.
Handled, but the handler returns non-zero:

Code: Select all

002a:trace:seh:dump_unwind_info     handler 0x140b8d494 data at 0x14304b908
002a:trace:seh:call_unwind_handler calling handler 0x140b8d494 (rec=0x22e720, frame=0x22e8e0 context=0x22e160, dispatch=0x22da70)
002a:trace:seh:call_unwind_handler handler 0x140b8d494 returned 1
Not sure what this means, but a non-zero handler at least seems like something to go on. Happy for any pointers.
Attachments
winestart+seh.log.tar.gz
(12.77 KiB) Downloaded 6 times

qwertymnb
Level 4
Level 4
Posts: 115
Joined: Sun Jan 17, 2016 4:36 pm
Location: Eindhoven de gekste!

Re: Debugging missing DLL (Sibelius 2018.7)

Post by qwertymnb » Fri Sep 27, 2019 5:35 pm

I`ve attached dumb hack that allowed me to start the program. Could you give it a try? See
https://bugs.winehq.org/show_bug.cgi?id=47174

dried
Level 2
Level 2
Posts: 11
Joined: Tue Oct 23, 2018 8:35 pm

Re: Debugging missing DLL (Sibelius 2018.7)

Post by dried » Fri Sep 27, 2019 7:23 pm

qwertymnb wrote:
Fri Sep 27, 2019 5:35 pm
I`ve attached dumb hack that allowed me to start the program. Could you give it a try? See
https://bugs.winehq.org/show_bug.cgi?id=47174
i'm very excited that you got it started! Do you know of a way to build just the patched DLL, or do I need to build all of wine to use this patch?

qwertymnb
Level 4
Level 4
Posts: 115
Joined: Sun Jan 17, 2016 4:36 pm
Location: Eindhoven de gekste!

Re: Debugging missing DLL (Sibelius 2018.7)

Post by qwertymnb » Sat Sep 28, 2019 2:56 am

For hack to try you`d need build all of wine.
Beware that it`s just ultimate dumb hack to try pinpoint where the bug is, for me the trial starts with it, but it`ll likely break other programs/make them crash, so only use to test Sibelius

dried
Level 2
Level 2
Posts: 11
Joined: Tue Oct 23, 2018 8:35 pm

Re: Debugging missing DLL (Sibelius 2018.7)

Post by dried » Sat Sep 28, 2019 5:46 am

Amazing, it works! We're on track.

Some notes:
  • it works using the newly compiled wine
  • I tried copying the wintrust.dll in system32 and syswow64 to an existing prefix and using wine-staging -- this did not work
  • yes startup is slow but the program seems to run fine otherwise
  • installation process failed to install a bunch of fonts (this might be because I used minimum effort in compiling and might be missing some components). This can be worked around by manually installing the fonts or replacements.
Thank you so much, qwertymb! Please let me know if / how I can continue helping.

Post Reply