Broken test for detecting libX11 and libXext

Questions about Wine on Linux
Locked
kromak
Level 2
Level 2
Posts: 17
Joined: Mon Dec 23, 2019 2:56 pm

Broken test for detecting libX11 and libXext

Post by kromak »

During the execution of configure, there are these two tests:

Code: Select all

checking for -lX11... not found
checking for -lXext... not found
that fails to detect the appropriate libraries. The problem is that I am passing them through

Code: Select all

LDFLAGS="-L/media/34GB/Arquivos-de-Programas-Linux-32bit/xorg/X11-1.3.6/lib/ -L/media/34GB/Arquivos-de-Programas-Linux-32bit/xorg/Xext-1.1.1/lib/"
to configure

Config.log wasn't useful:

Code: Select all

configure:7823: checking for -lX11
configure:7848: gcc -m32 -o conftest -g -O2 -I/media/34GB/Arquivos-de-Programas-Linux-32bit/Alsa-1.0.10/include/ -I/media/34GB/Arquivos-de-Programas-Linux-32bit/Fontconfig-2.8.0/include/ -I/media/34GB/Arquivos-de-Programas-Linux-32bit/xorg/X11-1.3.6/include/ -I/media/34GB/Arquivos-de-Programas-Linux/xorg/Xorgproto-2018.1/include/  -L/media/34GB/Arquivos-de-Programas-Linux-32bit/xorg/X11-1.3.6/lib/ -L/media/34GB/Arquivos-de-Programas-Linux-32bit/xorg/Xext-1.1.1/lib/ conftest.c -lX11    >&5
configure:7848: $? = 0
configure:7860: result: not found
configure:7873: checking for -lXext
configure:7898: gcc -m32 -o conftest -g -O2 -I/media/34GB/Arquivos-de-Programas-Linux-32bit/Alsa-1.0.10/include/ -I/media/34GB/Arquivos-de-Programas-Linux-32bit/Fontconfig-2.8.0/include/ -I/media/34GB/Arquivos-de-Programas-Linux-32bit/xorg/X11-1.3.6/include/ -I/media/34GB/Arquivos-de-Programas-Linux/xorg/Xorgproto-2018.1/include/  -L/media/34GB/Arquivos-de-Programas-Linux-32bit/xorg/X11-1.3.6/lib/ -L/media/34GB/Arquivos-de-Programas-Linux-32bit/xorg/Xext-1.1.1/lib/ conftest.c -lXext  -lX11   >&5
configure:7898: $? = 0
configure:7910: result: not found
Then I gave a look at configure.ac and found these two testes:

Code: Select all

    WINE_CHECK_SONAME(X11,XCreateWindow,,,[$X_LIBS $X_EXTRA_LIBS])
    WINE_CHECK_SONAME(Xext,XextCreateExtension,[XLIB="-lXext $XLIB"],,[$X_LIBS -lX11 $X_EXTRA_LIBS])
Due to their position among several xorg testes and the corresponding messages that configure provides, that made me suspect that the problem can lie there.

I checked the libraries with:

Code: Select all

readelf -s libX11.so.6.3.0  | grep XCreateWindow
   386: 0003c4e7   304 FUNC    GLOBAL DEFAULT   10 XCreateWindow
and:

Code: Select all

readelf -s libXext.so.6.4.0  | grep XextCreateExtension
    72: 0000ee60    64 FUNC    GLOBAL DEFAULT   10 XextCreateExtension
   270: 0000ee60    64 FUNC    GLOBAL DEFAULT   10 XextCreateExtension
and they seem ok. So I ask, are these tests the culprits? Or is something else? What can I do? Thanks you.
invisible kid
Level 4
Level 4
Posts: 239
Joined: Tue Dec 24, 2019 3:23 pm

Re: Broken test for detecting libX11 and libXext

Post by invisible kid »

Anytime doing 64 bit and 32 bit stuff, just triple-check that the actual libraries are there and do a "file <name>.so.x.x.x" to make sure its the right bit-ness. You've probably done this, but sometimes I'll find a typo or something. Good luck.
kromak
Level 2
Level 2
Posts: 17
Joined: Mon Dec 23, 2019 2:56 pm

Re: Broken test for detecting libX11 and libXext

Post by kromak »

invisible kid wrote: Mon Aug 15, 2022 10:53 am Anytime doing 64 bit and 32 bit stuff, just triple-check that the actual libraries are there and do a "file <name>.so.x.x.x" to make sure its the right bit-ness. You've probably done this, but sometimes I'll find a typo or something. Good luck.
Hi. Do you knows another place in Wine's website where I can post this?
Locked