Fall back to older wine?

Questions about Wine on Linux
Post Reply
fargodwe
Level 4
Level 4
Posts: 222
Joined: Mon Oct 02, 2017 7:08 am

Fall back to older wine?

Post by fargodwe » Mon Jul 27, 2020 11:29 am

Is it possible to remove my current wine and roll back to a previous version of wine? I looked at the "Downloads" page from WineHQ but didn't see a way there.

The current version "fixed" the problems I was having with one of my programs, GedStarPro for which I am very grateful.

One of my other programs, Legacy Family Tree 9, has now started displaying things a little weird. I don't know if it actually worked correctly in a previous version of wine but I would like to try if possible.

Thank you.

spoon0042
Level 5
Level 5
Posts: 361
Joined: Thu Dec 24, 2009 11:00 am

Re: Fall back to older wine?

Post by spoon0042 » Mon Jul 27, 2020 1:11 pm

A few ways, yeah. You're running Mint, right?
  • Build whatever version of wine you want from a git checkout
  • Use dpkg to install older versions if they're still in /var/cache/apt/archives
  • Use dpkg to install older versions downloaded from dl.winehq.org
  • Manually unpack debs somewhere
  • Use apt to install a specified version
If you don't have the deb files handy the last one is probably best. You can look up how to do it but in short you'll end up running a command like 'BRANCH=devel VERSION=5.7~focal ; apt install wine-$BRANCH=$VERSION wine-$BRANCH-amd64=$VERSION wine-$BRANCH-i386=$VERSION'
(Note the semicolon. I guessed at the 'focal' bit, use whatever codename is appropriate there. Also there are only versions for focal going back to 5.7, if you need something older... um. That would complicate things.)

If all that worked and you got an older version of wine installed you'll probably want to 'hold' the wine packages otherwise an 'apt upgrade' will install the current versions again. Another option at this point is if you figure out what version you need you can make a copy of the /opt/wine-$BRANCH directory then reinstall current if you need to for other things. And you could file a bug if you've verified something broke in a more recent version. Or there's wrappers or whatever like PlayOnLinux but they're kind of discouraged here.

Also just a reminder to use a new/separate wineprefix just in case something goes wrong.

(One of these days I need to look into getting this added to the faq / wiki, I think.)

Post Reply