FAudio installation errors on Debian 10 Buster

Questions about Wine on Linux
Post Reply
OrlandoMagic
Level 1
Level 1
Posts: 6
Joined: Sat Jul 04, 2020 1:35 pm

FAudio installation errors on Debian 10 Buster

Post by OrlandoMagic » Sat Jul 04, 2020 1:49 pm

Hello guys,

I am trying to install the latest version of WINE on my machine which has Debian 10 Buster. I have followed the instructions from https://wiki.winehq.org/Debian. I have issues when trying to install libfaudio. I get the error that I have unmet dependencies and as I try to install the dependencies, I get to a point where all of the dependencies are installed and yet I still can't install the package.

Here is my output log: http://paste.debian.net/1155134/

Again, I have followed all of the instructions from https://wiki.winehq.org/Debian up until the point where I have to execute

Code: Select all

sudo apt install --install-recommends winehq-stable
, which is where I downloaded libfaudio and tried to install it.

Thank you in advance!

spoon0042
Level 5
Level 5
Posts: 359
Joined: Thu Dec 24, 2009 11:00 am

Re: FAudio installation errors on Debian 10 Buster

Post by spoon0042 » Sat Jul 04, 2020 5:14 pm

You want 'dpkg -i' to install downloaded .deb files.

Code: Select all

sudo dpkg -i libfaudio*.deb
If you still have issues after that you may have to sort out issues with any repositories you've added. But hopefully not.

OrlandoMagic
Level 1
Level 1
Posts: 6
Joined: Sat Jul 04, 2020 1:35 pm

Re: FAudio installation errors on Debian 10 Buster

Post by OrlandoMagic » Sun Jul 05, 2020 9:30 am

spoon0042 thank you for responding.

I tried the command you suggested and got the following output: https://paste.debian.net/1155212/

What do I have to do now?

Cybermax
Level 4
Level 4
Posts: 215
Joined: Fri Dec 01, 2017 5:26 pm

Re: FAudio installation errors on Debian 10 Buster

Post by Cybermax » Mon Jul 06, 2020 8:49 am

Maybe you do not have ffmpeg installed?

Kitsune
Level 2
Level 2
Posts: 10
Joined: Sat Jun 27, 2020 5:01 am

Re: FAudio installation errors on Debian 10 Buster

Post by Kitsune » Mon Jul 06, 2020 10:42 am

This is crazy I don't have these trouble on a "fresh" Buster install...I have downloaded this today and install it by sudo dpkg -i or sudo apt install nameofthedebianfile:
libfaudio0_20.01-0~buster_i386.deb
but I run on a pure 32bits system.

Also I have make after apt-get update --fix-missing like explained:
sudo apt-get update –fix-missing.
sudo dpkg –configure -a.
sudo apt-get install -f
(the last command force install of missing dependancies)

OrlandoMagic
Level 1
Level 1
Posts: 6
Joined: Sat Jul 04, 2020 1:35 pm

Re: FAudio installation errors on Debian 10 Buster

Post by OrlandoMagic » Tue Jul 07, 2020 3:23 pm

@Cybermax I have ffmpeg installed.

@Kitsune I tried running the suggested commands, but I get the following output: https://paste.debian.net/1155523/

I'd also like to note that my system is 64 bit.

spoon0042
Level 5
Level 5
Posts: 359
Joined: Thu Dec 24, 2009 11:00 am

Re: FAudio installation errors on Debian 10 Buster

Post by spoon0042 » Wed Jul 08, 2020 10:34 am

Can you post the output of

Code: Select all

apt policy libavcodec58 libavcodec58:i386
Seems you might have some conflict with another third party repo which can be annoying.

jkfloris
Level 8
Level 8
Posts: 1131
Joined: Thu Aug 14, 2014 10:10 am

Re: FAudio installation errors on Debian 10 Buster

Post by jkfloris » Wed Jul 08, 2020 11:08 am

Two other commands that might help solve the problem.

The following command should not give any output:
Maybe you have to install apt-show-versions with sudo apt install apt-show-versions

Code: Select all

apt-show-versions | grep " version "
The next command will list all your repositories:
Don't mix Debian and Ubuntu packages!

Code: Select all

grep -r ^deb /etc/apt/sources.list*

Kitsune
Level 2
Level 2
Posts: 10
Joined: Sat Jun 27, 2020 5:01 am

Re: FAudio installation errors on Debian 10 Buster

Post by Kitsune » Wed Jul 08, 2020 3:10 pm

OrlandoMagic wrote:
Tue Jul 07, 2020 3:23 pm
@Cybermax I have ffmpeg installed.

@Kitsune I tried running the suggested commands, but I get the following output: https://paste.debian.net/1155523/

I'd also like to note that my system is 64 bit.
You must take the package for 64bit system then ...
Here is the libfaudio for the Debian 10 Buster 64bits:
https://download.opensuse.org/repositor ... _amd64.deb
Here for xUbuntu 18.04 64bit:
https://download.opensuse.org/repositor ... _amd64.deb

In your screenshoot you have a trouble about apt-update commande:
Err:13 http://ppa.launchpad.net/ethereum/ethereum/ubuntu focal InRelease
The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 1C52189C923F6CA9
It's a ppa depot that ask you a key for update it...It can corrupt next installation/ or block it. I don't know this ppa cause I'm not on ubuntu but you need to know what is it this repository.

but it's possible to install it I have do it on Lubuntu 18.04 it's based on Ubuntu.

But also I re-read you first post I read you are on Debian...I'm too I will post my /etc/apt/sources.list here wait...

Code: Select all

# 

# deb cdrom:[Debian GNU/Linux 9.12.0 _Stretch_ - Official i386 NETINST 20200209-03:38]/ stretch main

#deb cdrom:[Debian GNU/Linux 9.12.0 _Stretch_ - Official i386 NETINST 20200209-03:38]/ stretch main

deb http://ftp.be.debian.org/debian/ buster main contrib non-free
deb-src http://ftp.be.debian.org/debian/ buster main contrib non-free

deb http://security.debian.org/debian-security buster/updates main contrib non-free
deb-src http://security.debian.org/debian-security buster/updates main contrib non-free

# stretch-updates, previously known as 'volatile'
deb http://ftp.be.debian.org/debian/ buster-updates main contrib non-free
deb-src http://ftp.be.debian.org/debian/ buster-updates main contrib non-free

# WineHQ
deb https://dl.winehq.org/wine-builds/debian/ buster main

You can copy it I have just replace stretch words by buster to make it compatible with your distrib...normaly that must work but make a backup of your one file before. Also note that my own stretch CD config in start of the file so warning again when replace it just copy the line without a # before or compare it with your file.

sudo nano /etc/apt/sources.list

Here a good tutorial about last Debian install:
viewtopic.php?f=8&t=32192

OrlandoMagic
Level 1
Level 1
Posts: 6
Joined: Sat Jul 04, 2020 1:35 pm

Re: FAudio installation errors on Debian 10 Buster

Post by OrlandoMagic » Sat Jul 11, 2020 11:14 am

Here's the output of

Code: Select all

apt policy libavcodec58 libavcodec58:i386
,

Code: Select all

apt-show-versions | grep " version "
and

Code: Select all

grep -r ^deb /etc/apt/sources.list*
:

http://paste.debian.net/1156035/

I also fixed my /etc/apt/sources.list so that I have no errors.

What do I have to do to fix this?

jkfloris
Level 8
Level 8
Posts: 1131
Joined: Thu Aug 14, 2014 10:10 am

Re: FAudio installation errors on Debian 10 Buster

Post by jkfloris » Sat Jul 11, 2020 11:29 am

What do I have to do to fix this?
Remove/ upgrade/ downgrade all packages you have installed from an Ubuntu PPA

Code: Select all

ray@void-ray:~$ apt-show-versions | grep " version "
bash: apt-show-versions: command not found
The following command should not give any output:
Maybe you have to install apt-show-versions with sudo apt install apt-show-versions

Code: Select all

apt-show-versions | grep " version "

OrlandoMagic
Level 1
Level 1
Posts: 6
Joined: Sat Jul 04, 2020 1:35 pm

Re: FAudio installation errors on Debian 10 Buster

Post by OrlandoMagic » Sat Jul 11, 2020 12:39 pm

@jkfloris here's my output from

Code: Select all

apt-show-versions | grep " version "
:

http://paste.debian.net/1156043/

Does that mean that I should uninstall all those packages? I don't think Atom is interfering with WINE, for example.

Could you tell me what I need to uninstall and what do I do after that uninstalling?

Thank you for your support so far. From the link you sent over (https://wiki.debian.org/DontBreakDebian) maybe it's best for me to install WINE from the official Debian package repository, even if it's not the latest version of WINE?

Again, many thanks.

jkfloris
Level 8
Level 8
Posts: 1131
Joined: Thu Aug 14, 2014 10:10 am

Re: FAudio installation errors on Debian 10 Buster

Post by jkfloris » Sat Jul 11, 2020 4:45 pm

Weird, those packages look good.
Can you post the output of the following commands just to be sure?

Code: Select all

dpkg --print-foreign-architectures
sudo apt update
sudo dpkg -i libfaudio0_20.01-0~buster_i386.deb
sudo apt install -f
sudo apt install wine-stable-i386:i386

OrlandoMagic
Level 1
Level 1
Posts: 6
Joined: Sat Jul 04, 2020 1:35 pm

Re: FAudio installation errors on Debian 10 Buster

Post by OrlandoMagic » Thu Jul 16, 2020 6:04 am

@jkfloris here's the output of the following commands:

http://paste.debian.net/1156639/

spoon0042
Level 5
Level 5
Posts: 359
Joined: Thu Dec 24, 2009 11:00 am

Re: FAudio installation errors on Debian 10 Buster

Post by spoon0042 » Thu Jul 16, 2020 11:27 am

Wait, have you tried to install the listed dependencies for libfaudio0 yet? When using 'dpkg' that doesn't happen automatically.

Code: Select all

sudo apt install libavcodec58 libavcodec58:i386 libavutil56 libavutil56:i386 libsdl2-2.0-0 libsdl2-2.0-0:i386 libstb0 libstb0:i386

jkfloris
Level 8
Level 8
Posts: 1131
Joined: Thu Aug 14, 2014 10:10 am

Re: FAudio installation errors on Debian 10 Buster

Post by jkfloris » Thu Jul 16, 2020 3:30 pm

Other things you can check:

Make sure your download isn't corrupt:

Code: Select all

sha1sum libfaudio0_20.01-0_buster_i386.deb 
# Output:
# f64a362a54b3017db7e4fa23f135249a2ac6d510  libfaudio0_20.01-0_buster_i386.deb
Do you have any packages on hold?
Both commands shouldn't give any output.

Code: Select all

apt-mark showhold
dpkg -l | grep "^hi"
Do you have any custom apt preferences?

Code: Select all

ls -ls /etc/apt/preferences.d/

DRanged
Newbie
Newbie
Posts: 3
Joined: Tue Mar 28, 2017 6:47 am

Re: FAudio installation errors on Debian 10 Buster

Post by DRanged » Fri Jul 24, 2020 10:11 am

Just for your info libfaudio0 is available for Debian bullseye and sid in the Debian repo's. It has not been backported yet, I think, for buster. The bullseye/sid package should also work on buster but you have to check the dependencies of the libfaudio0 package as you might have these in the buster-backports. https://packages.debian.org/bullseye/libfaudio0
Hope it helps

Post Reply