Powerpoint 2007 unable to insert video

Open forum for end-user questions about Wine. Before asking questions, check out the Wiki as a first step.
Forum Rules
Locked
lostandfound
Level 2
Level 2
Posts: 20
Joined: Sun Oct 05, 2008 7:38 am

Powerpoint 2007 unable to insert video

Post by lostandfound » Fri Dec 12, 2008 7:54 pm

Hi, installing Office 2007 was a breeze, I then added the override for riched20.dll.

Word works fine AFAICS except for font anti-aliasing, but that's not crucial for now.

Powerpoint can import .wav files but not .mp3 files. More crucially, I'm unable to import .mpg or any other video files.

http://ubuntuforums.org/archive/index.php/t-470842.html has maybe a similar problem (year-old thread on ubuntuforums).

Original error message is:-

Code: Select all

fixme:mci:MCI_LoadMciDriver Couldn't load driver for type L"MPEGVIDEO".
My system.ini shows:-

Code: Select all

[mci]
MPEGVideo=mciqtz.drv
MPEGVideo2=mciqtz.drv
avivideo=mciavi32.dll
cdaudio=mcicda.dll
sequencer=mciseq.dll
vcr=mcivisca.drv
; videodisc=mcipionr.drv
waveaudio=mciwave.dll
Based on some random threads I read, I tried copying mciqtz32.dll and mciavi32.dll from my Vista install (don't have a XP install handy ATM). I then changed system.ini to this:-

Code: Select all

[mci]
MPEGVideo=mciqtz32.dll
MPEGVideo2=mciqtz32.dll
avivideo=mciavi32.dll
cdaudio=mcicda.dll
sequencer=mciseq.dll
vcr=mcivisca.drv
; videodisc=mcipionr.drv
waveaudio=mciwave.dll
The new error I get is:-

Code: Select all

fixme:msi:MsiUseFeatureExW mark product L"{90120000-0030-0000-0000-0000000FF1CE}" feature L"CAGFiles" as used

As of now, I'm stuck. Anyone have any ideas? Kind of pointless to use Powerpoint without videos, after all, as that's (for me) the major problem with Impress ATM. :roll:

User avatar
dimesio
Moderator
Moderator
Posts: 13004
Joined: Tue Mar 25, 2008 10:30 pm

Post by dimesio » Fri Dec 12, 2008 8:13 pm

Just off the top of my head, do you have the necessary codecs installed in Wine?

Other than that--file a bug report.

lostandfound
Level 2
Level 2
Posts: 20
Joined: Sun Oct 05, 2008 7:38 am

Re: Powerpoint 2007 unable to insert video

Post by lostandfound » Fri Dec 12, 2008 9:40 pm

Ah, after I posted this I figured out I might try that. Using winetricks to download now. Will update, either way.

UPDATE:

Installed allcodecs, the important message/error is below:-

Code: Select all

fixme:quartz:MPEGSplitter_query_accept MPEG-1 system streams not yet supported.

err:quartz:GetClassMediaFile Media class not found
The first line when I'm importing a .mpg file, the next with .wmv.

lostandfound
Level 2
Level 2
Posts: 20
Joined: Sun Oct 05, 2008 7:38 am

Re: Powerpoint 2007 unable to insert video

Post by lostandfound » Fri Dec 12, 2008 10:51 pm

Ah, with winetricks, when I install WMP10 I'm able to import videos and play them. Tried with wmvs (fully working) and avis (fully working) but mpg/mpeg files are giving problems. They can import but can't play. Similar problems observed when trying to play the same mpg/mpeg files using WMP10 itself. Will be testing that more.

lostandfound
Level 2
Level 2
Posts: 20
Joined: Sun Oct 05, 2008 7:38 am

Re: Powerpoint 2007 unable to insert video

Post by lostandfound » Sat Dec 13, 2008 12:41 am

So anyway, everything else is working (w.r.t videos in Powerpoint) except for mpg files. This is the related debug message from Wine.

Code: Select all

fixme:quartz:MPEGSplitter_query_accept MPEG-1 system streams not yet supported.
And the error message from Powerpoint:-

Code: Select all

Windows Media Player cannot play the file. The file is either corrupt or the Player does not support the format you are trying to play.%0
Note, this is easily replicated in a fresh Wine install without Office 2007, just install Windows Media Player and try to play an mpeg/mpg file.

Should I file a bug? Am not sure on the procedure for doing so/assigning the bug etc.etc. for Wine.

austin987
Wine Developer
Wine Developer
Posts: 2383
Joined: Fri Feb 22, 2008 8:19 pm
Contact:

Powerpoint 2007 unable to insert video

Post by austin987 » Sat Dec 13, 2008 3:22 am

On Fri, Dec 12, 2008 at 11:41 PM, lostandfound
<wineforum-user@winehq.org> wrote:
So anyway, everything else is working (w.r.t videos in Powerpoint) except for mpg files. This is the related debug message from Wine.


Code:
fixme:quartz:MPEGSplitter_query_accept MPEG-1 system streams not yet supported.



And the error message from Powerpoint:-


Code:
Windows Media Player cannot play the file. The file is either corrupt or the Player does not support the format you are trying to play.%0



Note, this is easily replicated in a fresh Wine install without Office 2007, just install Windows Media Player and try to play an mpeg/mpg file.

Should I file a bug? Am not sure on the procedure for doing so/assigning the bug etc.etc. for Wine.
Please. We don't know to fix what's broken.

--
-Austin

lostandfound
Level 2
Level 2
Posts: 20
Joined: Sun Oct 05, 2008 7:38 am

Re: Powerpoint 2007 unable to insert video

Post by lostandfound » Sat Dec 13, 2008 7:10 am

austin987 wrote: Please. We don't know to fix what's broken.

--
-Austin
Filed a bug. The bug trace was really fat, so had to compress it, but its still larger than 1 MB.

The bug is here[/url]

Locked