opengl32.dll problem running WoW.exe after new graphics card

Open forum for end-user questions about Wine. Before asking questions, check out the Wiki as a first step.
Forum Rules
Locked
jetbadkey1
Newbie
Newbie
Posts: 3
Joined: Fri Mar 21, 2008 1:05 pm

opengl32.dll problem running WoW.exe after new graphics card

Post by jetbadkey1 » Fri Mar 21, 2008 1:33 pm

Running Ubuntu 7.10 64bit / Wine 0.9.57, had World of Warcraft running fine under Wine with OpenGL, then my graphics card ate itself (Nvidia 7900GTX). Bought a new one (Nvidia 8800GT), but I had to monkey with the system in order to get the 8800GT to work. I'm pretty sure I messed something up trying to get the 8800GT to work as I had to remove the restricted drivers module. Now when I try to run WoW.exe I get the following error;

$ wine WoW.exe
err:module:load_builtin_dll failed to load .so lib for builtin L"OPENGL32.dll": libGL.so.1: cannot open shared object file: No such file or directory
err:module:import_dll Loading library OPENGL32.dll (which is needed by L"Z:~\\World of Warcraft\\WoW.exe") failed (error c000007a).
err:module:LdrInitializeThunk Main exe initialization for L"Z:~\\World of Warcraft\\WoW.exe" failed, status c0000135

I tried completely removing Wine and re-installing. When I run winecfg I get the following error;

$ winecfg
wine: creating configuration directory '~/.wine'...
Could not load Mozilla. HTML rendering will be disabled.
err:module:load_builtin_dll failed to load .so lib for builtin L"opengl32.dll": libGL.so.1: cannot open shared object file: No such file or directory
wine: '~/.wine' created successfully.

I've tried searching around to see if anyone else has had this problem and I find reference to it here: http://www.wowwiki.com/Linux/Wine/Troubleshooting however I do not have a /usr/local/lib/wine directory. I believe this is because I'm missing a lib that I may have lost trying to get the 8800GT to work. I do have /usr/lib32/wine and opengl32.dll.so is there with root owner permissions -rw-r--r--.

My next step will be to compile source instead of apt-getting from Ubuntu's repositories but I don't think that will make a difference since I think I'm missing a lib.

Any ideas much appreciated.

austin987
Wine Developer
Wine Developer
Posts: 2383
Joined: Fri Feb 22, 2008 8:19 pm
Contact:

opengl32.dll problem running WoW.exe after new graphics card

Post by austin987 » Fri Mar 21, 2008 1:38 pm

On Fri, Mar 21, 2008 at 1:33 PM, jetbadkey1 <wineforum-user@winehq.org> wrote:
Running Ubuntu 7.10 64bit, had World of Warcraft running fine under Wine with OpenGL, then my graphics card ate itself (Nvidia 7900GTX). Bought a new one (Nvidia 8800GT), but I had to monkey with the system in order to get the 8800GT to work. I'm pretty sure I messed something up trying to get the 8800GT to work as I had to remove the restricted drivers module. Now when I try to run WoW.exe I get the following error;

$ wine WoW.exe
err:module:load_builtin_dll failed to load .so lib for builtin L"OPENGL32.dll": libGL.so.1: cannot open shared object file: No such file or directory
err:module:import_dll Loading library OPENGL32.dll (which is needed by L"Z:~\\World of Warcraft\\WoW.exe") failed (error c000007a).
err:module:LdrInitializeThunk Main exe initialization for L"Z:~\\World of Warcraft\\WoW.exe" failed, status c0000135

I tried completely removing Wine and re-installing. When I run winecfg I get the following error;

$ winecfg
wine: creating configuration directory '~/.wine'...
Could not load Mozilla. HTML rendering will be disabled.
err:module:load_builtin_dll failed to load .so lib for builtin L"opengl32.dll": libGL.so.1: cannot open shared object file: No such file or directory
wine: '~/.wine' created successfully.

I've tried searching around to see if anyone else has had this problem and I find reference to it here: http://www.wowwiki.com/Linux/Wine/Troubleshooting however I do not have a /usr/local/lib/wine directory. I believe this is because I'm missing a lib that I may have lost trying to get the 8800GT to work. I do have /usr/lib32/wine and opengl32.dll.so is there with root owner permissions -rw-r--r--.

My next step will be to compile source instead of apt-getting from Ubuntu's repositories but I don't think that will make a difference since I think I'm missing a lib.

Any ideas much appreciated.
Reinstall your video drivers.

jetbadkey1
Newbie
Newbie
Posts: 3
Joined: Fri Mar 21, 2008 1:05 pm

opengl32.dll problem running WoW.exe after new graphics card

Post by jetbadkey1 » Fri Mar 21, 2008 2:27 pm

Reinstall your video drivers.
Just tried that with nvidia 169.12 using envy. The winecfg error is gone but the WoW.exe one is still there.

austin987
Wine Developer
Wine Developer
Posts: 2383
Joined: Fri Feb 22, 2008 8:19 pm
Contact:

opengl32.dll problem running WoW.exe after new graphics card

Post by austin987 » Fri Mar 21, 2008 2:31 pm

On Fri, Mar 21, 2008 at 2:27 PM, jetbadkey1 <wineforum-user@winehq.org> wrote:
Reinstall your video drivers.
Just tried that with nvidia 169.12 using envy. The winecfg error is gone but the WoW.exe one is still there.
Is the opengl error still there as well? If so, you probably goofed up
some GL/X libraries. I did this a couple weeks ago, and found that
searching for X and GL libraries in synaptic and reinstalling them
fixed the issue (though now my sound is messed up after upgrading to
hardy, so go figure). I'm about to do a clean upgrade on that box, but
it did fix the video issue for me. Not the cleanest way, but it did
the trick.

jetbadkey1
Newbie
Newbie
Posts: 3
Joined: Fri Mar 21, 2008 1:05 pm

Post by jetbadkey1 » Tue Mar 25, 2008 6:33 am

Is the opengl error still there as well? If so, you probably goofed up
some GL/X libraries. I did this a couple weeks ago, and found that
searching for X and GL libraries in synaptic and reinstalling them
fixed the issue (though now my sound is messed up after upgrading to
hardy, so go figure). I'm about to do a clean upgrade on that box, but
it did fix the video issue for me. Not the cleanest way, but it did
the trick.
I ended up doing a clean install on that box. When I did the original installation I was thinking and did /home as a separate partition which made the re-installation smoother.
The clean install fixed the opengl error after I used Envy to install the drivers for the 8800GT. Straight out of the clean install Ubuntu didn't even register the 8800GT. I've now done clean installs with the 8800GT and 8800GTX with Ubuntu 7.10 and here are the steps I took to get them working (I know the 8 series is a pain for Ubuntu);
  • 1. When the boot CD loads, highlight Graphic Safe Mode and press F6 for more options.

    2. Delete 'quiet' and 'splash' and press Enter.

    3. Install Ubuntu (I mount /home in a separate partition because it makes re-installation easier, but I tend to tinker and mess things up requiring frequent installs)

    4. After the first reboot highlight the first Ubuntu boot option and press 'e'.

    5. Highlight the second line, should look similar to;

    Code: Select all

    kernel		/boot/vmlinuz-2.6.22-14-generic root=UUID=... quiet splash ro
    and press 'e'.

    6. Delete 'quiet' and 'splash' and press Enter.

    7. When I did the 8800GTX Ubuntu recognized the card and all I had to do was allow the NVIDIA restricted driver manager. When I did the 8800GT Ubuntu loaded the vesa drivers and didn't see the card. I ran Envy http://www.albertomilone.com/nvidia_scripts1.html with the latest drivers (169.12) and that card worked. Using Envy to install the drivers allows more control over the graphics card, but personally I haven't seen any performance differences between the drivers on my 8800GTX system.

    8. I still have problems on both systems with the Ubuntu boot screen so I run;

    Code: Select all

    gksudo gedit /boot/grub/menu.lst
    in terminal and comment out the line;

    Code: Select all

    kernel		/boot/vmlinuz-2.6.22-14-generic root=UUID=... quiet splash ro
    copy that line, paste it below without quiet and splash;

    Code: Select all

    kernel		/boot/vmlinuz-2.6.22-14-generic root=UUID=... ro
    9. Eliminating 'splash' stops the boot load screen. I also take out 'quiet' because I can visually confirm that Ubuntu is loading. This might not be the right way to get those card working but it's how I've done so. World of Warcraft works so I'm content for now :D.

Locked