WineHQ
Wine Forums

Board index » WineHQ » Wine Help




 Page 1 of 1 [ 12 posts ] 



 
Author Message
 Post Posted: Tue Jul 01, 2008 1:42 pm 
Offline
Level 2
Level 2

Joined: Fri May 30, 2008 2:38 pm
Posts: 23
A month ago I had my Quicken working great and printing from Darwine running on an iMac. Yesterday, I attempted to use CUPS-PDF to make a PDF of an invoice in Quicken and Quicken said there were no printers installed. So, obviously something changed since my last printing but I had installed some new apps and some additional winetricks so I assumed I broke something. I deleted my Darwine folder, my wine plist file and my .wine file. I updated OS X to 10.5.4, downloaded version 1.0b of Darwine and rebuilt the .wine file with a collection of winetricks (v6run, fonts, gecko, flash, mdac28) and re-installed ies4osx. I then installed Quicken Home and Business 2006 again. The app runs fine but when I go to print it says "No Windows Printers Installed" and wants me to go to the Control panel and install a printer. I can log into the CUPS web interface and I have 2 physical printers listed there as well as the CUPS-PDF printer. I can print to all three of these printers in OS X. Rebooting the iMac changes nothing. Is there some linkage between Darwine and CUPS that can be reset?


Top 
 Post subject:
 Post Posted: Tue Jul 01, 2008 6:44 pm 
Offline
Level 2
Level 2

Joined: Sat Jun 28, 2008 7:54 pm
Posts: 10
Just so you know you're not the only one, here's my recent thread about the same problem:

viewtopic.php?t=1518


Top 
 Post subject:
 Post Posted: Tue Jul 01, 2008 7:18 pm 
Offline
Level 2
Level 2

Joined: Sat Jun 28, 2008 7:54 pm
Posts: 10
I'm intrigued by your having been able to print from Wine in OS X before. Do you have a "printcap" file anywhere?


Top 
 Post subject:
 Post Posted: Wed Jul 02, 2008 8:05 pm 
Offline
Level 2
Level 2

Joined: Fri May 30, 2008 2:38 pm
Posts: 23
Did a few searches and didn't find a printcap anywhere.


Top 
 Post subject:
 Post Posted: Thu Jul 03, 2008 6:34 am 
Offline
Newbie
Newbie

Joined: Thu Jul 03, 2008 6:19 am
Posts: 4
I exactly have the same problem. Someone gave a manual solution for ubuntu here: http://forum.ubuntu-fr.org/viewtopic.php?id=58083 (french). Maybe it could work for osx. But I didn't try it...


Top 
 Post subject:
 Post Posted: Thu Jul 03, 2008 8:03 am 
Offline
Newbie
Newbie

Joined: Thu Jul 03, 2008 6:19 am
Posts: 4
I tried this package and it works now :D : http://thisismyinter.net/?p=47


Top 
 Post subject:
 Post Posted: Thu Jul 03, 2008 2:57 pm 
Offline
Level 2
Level 2

Joined: Sat Jun 28, 2008 7:54 pm
Posts: 10
The French link describes adding entries to the [devices] and [windows] sections in win.ini:

~/.wine/drive_c/windows/win.ini

Catwalk, do you now have a win.ini file in this location, and does it contain information for your printer as mentioned?


Top 
 Post subject:
 Post Posted: Thu Jul 03, 2008 4:46 pm 
Offline
Level 2
Level 2

Joined: Fri May 30, 2008 2:38 pm
Posts: 23
Catwalk - when you say you
Quote:
"I tried this package and it works now Very Happy : http://thisismyinter.net/?p=47"
are you referring to the Xquartz? I tried taking the space out of my path and building the symlinks they refer to in that thread but no change. I am running Apple's X11 and am open to switching but have never found any instructions on how to remove Apple's X11 completely so I get a clean install of Xquartz. How did you remove Apple's X11?

Didn't try the French forum idea since I didn't find a printcap to symlink.

As a test I went ahead and put Quicken on my Ubuntu Hardy box and don't have any trouble creating a PDF in that environment. So the problem seems isolated to the Leopard/Darwine system.

I copied the winelog entries for when I open Quicken and attempt a print in case it gives anyone some ideas.

fixme:ole:TLB_ReadTypeLib Header type magic 0x00905a4d not supported.
err:ole:TLB_ReadTypeLib Loading of typelib L"C:\\Program Files\\Quicken\\QWUTIL.dll" failed with error 0
err:ole:TLB_ReadTypeLib Loading of typelib L"C:\\Program Files\\Quicken\\QWUTIL.tlb" failed with error 2
fixme:winspool:OpenPrinterW PRINTER_DEFAULTS ignored => (null),0x0,0x000f000c
fixme:htmlhelp:HtmlHelpW HH case HH_CLOSE_ALL not handled.

Thanks.


Top 
 Post subject:
 Post Posted: Thu Jul 03, 2008 7:52 pm 
Offline
Level 2
Level 2

Joined: Sat Jun 28, 2008 7:54 pm
Posts: 10
catwalk wrote:
I tried this package and it works now http://thisismyinter.net/?p=47


Using this package, I too can print from Windows applications on OS X.

So Darwine works... but my MacPorts Wine installation still cannot print.

It appears to have nothing to do with the printcap file -- there is no such file in OS X.

The Darwine package created this file with the correct printer entries:
.wine/drive_c/windows/win.ini

My MacPorts Wine installation does not see the win.ini file. So Darwine is linking to something and creating this file.


Top 
 Post subject:
 Post Posted: Fri Jul 04, 2008 2:35 am 
Offline
Newbie
Newbie

Joined: Thu Jul 03, 2008 6:19 am
Posts: 4
I tried 3 wine packages:

The macports package
This one: http://www.kronenberg.org/darwine/
And this one: http://thisismyinter.net/?p=47

Only the last one can print something.
With macports and kronenberg packages I didn't had anything about printers in my win.ini file. With thisismyinter package I have that:

[devices]
CUPS_PDF=WINEPS.DRV,LPR:CUPS_PDF
hp_LaserJet_4345_mfp__8E4A7C_=WINEPS.DRV,LPR:hp_LaserJet_4345_mfp__8E4A7C_

[PrinterPorts]
CUPS_PDF=WINEPS.DRV,LPR:CUPS_PDF,15,45
hp_LaserJet_4345_mfp__8E4A7C_=WINEPS.DRV,LPR:hp_LaserJet_4345_mfp__8E4A7C_,15,45

[windows]
device=hp_LaserJet_4345_mfp__8E4A7C_,WINEPS.DRV,LPR:hp_LaserJet_4345_mfp__8E4A7C_

I also installed the last xquartz (http://xquartz.macosforge.org/trac/wiki) but I don't think it was needed.

I've read that wine needs an additional library to print through cups printers (cups and cups-devel or libwine-print or libwine-cups) (=> http://source.winehq.org/source/documen ... ine-0.9.24). Maybe that the thisismyinter package include one of them and the other ones not.


Top 
 Post subject:
 Post Posted: Mon Jul 07, 2008 1:06 pm 
Offline
Level 2
Level 2

Joined: Fri May 30, 2008 2:38 pm
Posts: 23
After trying everything I could think of and getting nowhere with my initial Darwine package, I tried the Darwine package at http://thisismyinter.net/?p=47 and it works and I now get PDF's in my cups-pdf desktop folder. Took me quite a while to get Quicken to download it's updates -- started working after I installed Flash for Firefox. I also installed the latest X11 package from Xquartz which fixed a Firefox 3 crash problem.

Now if I could just get X11 to stop moving the application window down every time there's a screen refresh/change.

Thanks for all the help. :D


Top 
 Post subject:
 Post Posted: Tue Jul 08, 2008 2:14 am 
Offline
Newbie
Newbie

Joined: Thu Jul 03, 2008 6:19 am
Posts: 4
I've got the same problem with the window moving down, if you find a solution... :wink:


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 12 posts ] 




Board index » WineHQ » Wine Help


Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 20 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: