No Sound in Wine - disable / remove pulseaudio

Questions about Wine on Linux
Locked
vitamin
Moderator
Moderator
Posts: 6605
Joined: Sat Feb 23, 2008 2:29 pm

No Sound in Wine - disable / remove pulseaudio

Post by vitamin » Mon Jun 23, 2008 8:39 pm

Wine requires direct access to sound device(s) to make sound. This is true for both ALSA and OSS driver back-ends. However most sound servers are not compatible with neither of these back-ends. This also true about pulse-audio - it is not fully compatible with Wine.

If you using new distro (Fedora 8, Ubuntu 8.04, SuSE 11) and do not have sound you should:
1. Report problem to your distro support
2. Disable or even remove pulse-audio

In case some one have a recipe to make pulse-audio work with wine - post it. Only please DO NOT post stuff like "I don't know what I did but it's working". Figure it out first. Then let everyone know.

To disable PulseAudio in new Ubuntu versions
(Contributed by Susan Cragin).
Here's what I do to run audio applications in wine.
in terminal:

Code: Select all

sudo nano /etc/pulse/client.conf
uncomment and change this line as follows:

Code: Select all

; autospawn = yes
autospawn = no
(Otherwise killing pulseaudio has no effect, it just re-starts automatically.)

In terminal, every time you boot up, type:

Code: Select all

killall pulseaudio
Last edited by vitamin on Sat Oct 31, 2009 10:36 am, edited 2 times in total.

Scott Ritchie

No Sound in Wine - disable / remove pulseaudio

Post by Scott Ritchie » Tue Jun 24, 2008 2:08 am

vitamin wrote:
Wine requires direct access to sound device(s) to make sound. This is true for both ALSA and OSS driver back-ends. However most sound servers are not compatible with neither of these back-ends. This also true about pulse-audio - it is not fully compatible with Wine.

If you using new distro (Fedora 8, Ubuntu 8.04, SuSE 11) and do not have sound you should:
1. Report problem to your distro support
2. Disable or even remove pulse-audio
Will pasuspender work in these circumstances?

Thanks,
Scott Ritchie

vitamin
Moderator
Moderator
Posts: 6605
Joined: Sat Feb 23, 2008 2:29 pm

Re: No Sound in Wine - disable / remove pulseaudio

Post by vitamin » Tue Jun 24, 2008 8:28 am

Scott Ritchie wrote:vitamin wrote:
Wine requires direct access to sound device(s) to make sound. This is true for both ALSA and OSS driver back-ends. However most sound servers are not compatible with neither of these back-ends. This also true about pulse-audio - it is not fully compatible with Wine.

If you using new distro (Fedora 8, Ubuntu 8.04, SuSE 11) and do not have sound you should:
1. Report problem to your distro support
2. Disable or even remove pulse-audio
Will pasuspender work in these circumstances?
I'm guessing not always: http://forum.winehq.org/viewtopic.php?p=8505#8505

Usurp
Level 4
Level 4
Posts: 161
Joined: Sat Apr 19, 2008 7:16 am

Re: No Sound in Wine - disable / remove pulseaudio

Post by Usurp » Tue Jun 24, 2008 9:33 am

vitamin wrote:Wine requires direct access to sound device(s) to make sound. This is true for both ALSA and OSS driver back-ends. However most sound servers are not compatible with neither of these back-ends. This also true about pulse-audio - it is not fully compatible with Wine.

If you using new distro (Fedora 8, Ubuntu 8.04, SuSE 11) and do not have sound you should:
1. Report problem to your distro support
2. Disable or even remove pulse-audio
Im using Fedora 9 with a few apps that need sound, and got no problems with PA running so far.
By the way, you maybe mention Fedora 9.

oiaohm
Level 8
Level 8
Posts: 1020
Joined: Fri Feb 29, 2008 2:54 am

Post by oiaohm » Sat Jul 05, 2008 2:39 am

pasuspender is card dependant and the author of pulse will not change it.

Reason if card does not have a onboard mixer pasuspender will not start dmix to replace the mixer part when pulse audio is disabled.

Please complain to pulseaudio about this. pasuspender really should warn users they are walking into limited function.

kleinlohmi
Newbie
Newbie
Posts: 1
Joined: Sun Jul 13, 2008 5:28 am

Post by kleinlohmi » Sun Jul 13, 2008 5:32 am

Hi,
i am using Wine successfully with Pulseaudio via padsp!!

First you have to run

Code: Select all

padsp winecfg
and select the OSS output under Audio. The other outputs should be toggled off.

Then you can use any program via

Code: Select all

padsp wine myprogram.exe
It works fine for me. I am using Teamspeak 2 and Steam/CS 1.6 with it.

vitamin
Moderator
Moderator
Posts: 6605
Joined: Sat Feb 23, 2008 2:29 pm

Post by vitamin » Sun Jul 13, 2008 11:01 pm

kleinlohmi wrote:Hi,
i am using Wine successfully with Pulseaudio via padsp!!
The problem with this solution - you adding extra conversion OSS -> ALSA. This never worked properly in all cases with ALSA before. And I doubt it's any better with pulse audio.

Also note that OSS is not the recommended sound driver in Wine anymore. And it does not support the full HW acceleration in your configuration. This does affect sound quality on lots of programs.

Susan Cragin

No Sound in Wine - disable / remove pulseaudio

Post by Susan Cragin » Tue Jul 15, 2008 9:15 am

-----Original Message-----
From: kleinlohmi <wineforum-user@winehq.org>
Sent: Jul 13, 2008 6:32 AM
To: wine-users@winehq.org
Subject: [Wine] Re: No Sound in Wine - disable / remove pulseaudio

Hi,
i am using Wine successfully with Pulseaudio via padsp!!

First you have to run


Code:
padsp winecfg

and select the OSS output under Audio. The other outputs should be toggled off.

Then you can use any program via

Code:
padsp wine myprogram.exe



It works fine for me. I am using Teamspeak 2 and Steam/CS 1.6 with it.
I have gotten it to run with Dragon NaturallySpeaking. Right now I am dictating into Notepad using it. Preliminary results show that the accuracy score yielded me a 28 or 29, versus 26 for alsa. The improvement in sound quality is probably statistically insignificant, but it is definitely not worse.
I can't tell yet if it's any slower at running the speech recognition engine.

Susan Cragin

No Sound in Wine - disable / remove pulseaudio

Post by Susan Cragin » Tue Jul 15, 2008 10:12 am

-----Original Message-----
From: Susan Cragin <susancragin@earthlink.net>
Sent: Jul 15, 2008 10:15 AM
To: wine users <wine-users@winehq.org>
Subject: Re: [Wine] Re: No Sound in Wine - disable / remove pulseaudio



-----Original Message-----
From: kleinlohmi <wineforum-user@winehq.org>
Sent: Jul 13, 2008 6:32 AM
To: wine-users@winehq.org
Subject: [Wine] Re: No Sound in Wine - disable / remove pulseaudio

Hi,
i am using Wine successfully with Pulseaudio via padsp!!

First you have to run


Code:
padsp winecfg

and select the OSS output under Audio. The other outputs should be toggled off.

Then you can use any program via

Code:
padsp wine myprogram.exe



It works fine for me. I am using Teamspeak 2 and Steam/CS 1.6 with it.
I have gotten it to run with Dragon NaturallySpeaking. Right now I am dictating into Notepad using it. Preliminary results show that the accuracy score yielded me a 28 or 29, versus 26 for alsa. The improvement in sound quality is probably statistically insignificant, but it is definitely not worse.
I can't tell yet if it's any slower at running the speech recognition engine.
Perhaps I am premature. The program runs but crashes every once in a while.

Aleks
Newbie
Newbie
Posts: 2
Joined: Wed Jul 16, 2008 10:45 pm
Location: Toronto, Canada
Contact:

Post by Aleks » Wed Jul 16, 2008 11:04 pm

kleinlohmi wrote:Hi,
i am using Wine successfully with Pulseaudio via padsp!!

First you have to run

Code: Select all

padsp winecfg
and select the OSS output under Audio. The other outputs should be toggled off.

Then you can use any program via

Code: Select all

padsp wine myprogram.exe
It works fine for me. I am using Teamspeak 2 and Steam/CS 1.6 with it.
I would like to confirm that this is indeed working. Thank you very much! Sound barely worked at all before doing this; now it works perfectly. I had Rosetta Stone installed on a different computer that didn't have Pulse Audio, and it ran like a charm in WINE. On this one (the computer with Pulse Audio), there was a 0.5 second burst of sound (I'm assuming the beginning of the sound file) and then nothing else. Running wine with padsp remedies this.

So yeah. I can confirm this method as a way to get around Pulse Audio.

Job well done, kleinlohmi.
Susan Cragin wrote:I have gotten it to run with Dragon NaturallySpeaking. Right now I am dictating into Notepad using it. Preliminary results show that the accuracy score yielded me a 28 or 29, versus 26 for alsa. The improvement in sound quality is probably statistically insignificant, but it is definitely not worse.
I can't tell yet if it's any slower at running the speech recognition engine.
If it's of any interest, when I tried recording my voice in Rosetta Stone, I noticed a slight to noticeable lag at the beginning, causing my recording to start later. I don't know how reliable this is, considering I'm using a different app, but I thought you'd like to know. I now speak with a momentary pause at the beginning of my recordings. I'm not too familiar with Dragon NaturallySpeaking, but perhaps you could start speaking with momentary pauses? :-) (or test the theory out by running windows audio recorder or something)

dr_costas
Level 2
Level 2
Posts: 17
Joined: Fri Oct 10, 2008 5:10 pm

Post by dr_costas » Sun Nov 02, 2008 8:51 am

EDIT: with the following i thought i was on a home run but my sound lags.

hi all, wine sound works with me as follows:

fresh install of ubuntu 8.04 (gnome), added any pulseaudio plugins i could find
run playonlinux so i could wineprefix any game with individual wine versions

setup esd as audio driver in winecfg (made sure alsa was not selected as well)

tested with playing mp3 with mplayer and starting wine game (myth 2). I got sound from both programs. Also run teamspeak and got sound while testing the mic.

the idea was not mine, i found it over some ubuntu forums if i remember correctly.

i am on a laptop listening via headphones so sound quality / surround is not an issue with me. (in case someone starts saying alsa is better etc :P)

EDIT: I SHOULD KNOW BETTER FROM POSTING B4 FULL TESTING. i get sound now with the above but it lags, go figure,

User avatar
zweistecken
Newbie
Newbie
Posts: 2
Joined: Sat Dec 06, 2008 12:50 am

simple

Post by zweistecken » Sat Dec 06, 2008 12:58 am

as i do like the pulseaudio server, i do not want to remove it completely.

instead, each time i want to run a program thru wine i kill the pulseaudio.
can be done by a hotkey or shortcut.

' killall pulseaudio

done. Sound works.

and when u want pulseaudio to run again, use this

' pulseaudio

even simpler.

So if you make shortcuts or hotkeys, this is a piece of cake.

stop pulseaudio: ' killall pulseaudio
start pulseaudio: ' pulseaudio

p.s.: if you start pulseaudio again in a terminal, dont forget to start it
as a deamon detached from the terminal or
it will get terminated when you close your terminal emulator.

p.p.s: who ever has read this has been reading it. ÖÖÖÖÖsdaäpkre,m dunno

Sardem FF7
Level 1
Level 1
Posts: 5
Joined: Wed Dec 10, 2008 8:17 am

Post by Sardem FF7 » Wed Dec 10, 2008 8:29 am

Hello,

PulseAudio is not a problem. You can use the OSS Emulation of PA, it works perfectly. (I saw a test with Dragon NaturallySpeaking, and it seems imply that it's good, isn't it ?)

I used padsp for a while when a beautiful project was born : WinePulse. I'm actually testing it with the main (and only) developer of this PulseAudio backend for Wine and recently he made it working on my Ubuntu 8.10 with PulseAudio 0.9.10. So it's not yet a full implementation and WaveIn doesn't work for me, but it will be fine and I hope integrated in Wine.

Susan Cragin

No Sound in Wine - disable / remove pulseaudio

Post by Susan Cragin » Wed Dec 10, 2008 11:50 am

Hello,

PulseAudio is not a problem. You can use the OSS Emulation of PA, it works perfectly. (I saw a test with Dragon NaturallySpeaking, and it seems imply that it's good, isn't it ?)

I used padsp for a while when a beautiful project was born : WinePulse. I'm actually testing it with the main (and only) developer of this PulseAudio backend for Wine and recently he made it working on my Ubuntu 8.10 with PulseAudio 0.9.10. So it's not yet a full implementation and WaveIn doesn't work for me, but it will be fine and I hope integrated in Wine.
Do you have a link to that DNS test with PA and OSS?
Thanks,
Susan Cragin

Sardem FF7
Level 1
Level 1
Posts: 5
Joined: Wed Dec 10, 2008 8:17 am

Re: No Sound in Wine - disable / remove pulseaudio

Post by Sardem FF7 » Wed Dec 10, 2008 12:00 pm

Susan Cragin wrote:
Hello,

PulseAudio is not a problem. You can use the OSS Emulation of PA, it works perfectly. (I saw a test with Dragon NaturallySpeaking, and it seems imply that it's good, isn't it ?)

I used padsp for a while when a beautiful project was born : WinePulse. I'm actually testing it with the main (and only) developer of this PulseAudio backend for Wine and recently he made it working on my Ubuntu 8.10 with PulseAudio 0.9.10. So it's not yet a full implementation and WaveIn doesn't work for me, but it will be fine and I hope integrated in Wine.
Do you have a link to that DNS test with PA and OSS?
Thanks,
Susan Cragin
I maybe badly expressed myself, I spoke simply of yours.:-)

vitamin
Moderator
Moderator
Posts: 6605
Joined: Sat Feb 23, 2008 2:29 pm

Re: No Sound in Wine - disable / remove pulseaudio

Post by vitamin » Wed Dec 10, 2008 12:05 pm

Sardem FF7 wrote:I maybe badly expressed myself, I spoke simply of yours.:-)
Then the origina solution stands - remove pulseaudio it's not compatible with Wine. Like any other sound server it plain _DOES NOT WORK_.

lostandfound
Level 2
Level 2
Posts: 20
Joined: Sun Oct 05, 2008 7:38 am

Re: No Sound in Wine - disable / remove pulseaudio

Post by lostandfound » Fri Dec 12, 2008 6:52 pm

I've got my Pulseaudio working perfectly with Wine (such that I can run my music player while some Wine app is running, and no, I don't have hardware mixing).

I just use alsa-oss (that's the name of the package in Ubuntu). Its 32-bit only, but I just extracted it to lib32 in my 64-bit Ubuntu Intrepid install. So when I run my app, I run it with:-

aoss wine executable.exe <any_options>

And I've set output to OSS within winecfg. Pulse plays MUCH better with ALSA than OSS, and aoss allows Wine to believe that its got total control of the sound device.

An alternative would be to use JACK, but setting that up to work with Pulse is a headache, though I've done it also. No benefit, though, unless you're already running JACK all the time.

Sardem FF7
Level 1
Level 1
Posts: 5
Joined: Wed Dec 10, 2008 8:17 am

Post by Sardem FF7 » Sat Dec 13, 2008 5:30 am

Alsa-OSS and PulseAudio ? So Wine <=> OSS <=> ALSA (pulse) <=> PulseAudio <=> ALSA (hw) ? I prefer use padsp to take off the "ALSA (pulse)" part, even if I lose the "hardware control". But I agree : OSS backend is very good and I've played a long time with it.

For JACK : "aoss jackd -d oss" works fine :mrgreen: (Wine <=> JACK <=> OSS <=> ALSA (pulse) <=> PulseAudio <=> ALSA (hw))

For info : the new WinePulse 0.10 works fine on WaveOut (with a little (<1s) latency), and I'll read some doc to help Art in this development so I hope it will be easier to use directly WinePulse in a "'few" time. :mrgreen:

lostandfound
Level 2
Level 2
Posts: 20
Joined: Sun Oct 05, 2008 7:38 am

Re: No Sound in Wine - disable / remove pulseaudio

Post by lostandfound » Sat Dec 13, 2008 6:02 am

Ah, a Pulse output for Wine would be superb, esp for users of distros which default to Pulse (Ubuntu and Fedora AFAIK, there are a few more). Thank you to all who are working on this, and on Wine.

Locked