Problem with automatic mounting of disc drive (Ubuntu 11.10)

Questions about Wine on Linux
Locked
RFS-81
Newbie
Newbie
Posts: 4
Joined: Thu Jan 19, 2012 11:58 am

Problem with automatic mounting of disc drive (Ubuntu 11.10)

Post by RFS-81 » Mon Jan 23, 2012 6:03 pm

Hi!

First of all, WINE is great! There is only one little inconvenience for me: I am using WINE 1.2 under Ubuntu 11.10. It automatically mounts CDs and DVDs at /media/(disc name). So whenever I insert a new disc, I have to change the configuration of WINE which is a bit annoying. I could not find any help via Google. On ubuntuforum.org I was told to point WINE to the device itself (/dev/sr0) instead of the mount point, but that didn't work. Or at least, Baldur's Gate does not believe me that I have it's disc inserted. When I give WINE the mount point, then it runs fine.

Since I got no more replies on ubuntuforum for some days now, I thought maybe someone here can help me.

vitamin
Moderator
Moderator
Posts: 6605
Joined: Sat Feb 23, 2008 2:29 pm

Re: Problem with automatic mounting of disc drive (Ubuntu 11

Post by vitamin » Tue Jan 24, 2012 11:19 pm

RFS-81 wrote:I am using WINE 1.2 under Ubuntu 11.10.
That old Wine doesn't support dbus that's used in Ubuntu 11.10. It still uses HAL that's no longer supported by most distros.

Wine supports dbus starting from wine-1.3.36. So the answer to your problem - upgrade Wine.

RFS-81
Newbie
Newbie
Posts: 4
Joined: Thu Jan 19, 2012 11:58 am

Post by RFS-81 » Thu Jan 26, 2012 1:50 pm

Thanks, but it does not work with WINE 1.3 either. Maybe that's a problem specific to the game I'm trying to play. I'll try it with a different game later. Or did I do it wrong? I opened winecfg, went to drives, added a drive D: mapped to /dev/sr0, opened the advanced options and selected CD.

And the new version produced a couple of new graphic bugs in Baldur's Gate (the mouse pointer now leaves permanent traces). Maybe I should stick with the last stable release and just make a drive for every disc I want to use...

jjmckenzie
Moderator
Moderator
Posts: 1153
Joined: Wed Apr 27, 2011 11:01 pm

Problem with automatic mounting of disc drive (Ubuntu 11.10)

Post by jjmckenzie » Thu Jan 26, 2012 1:56 pm

On Thu, Jan 26, 2012 at 11:50 AM, RFS-81 <wineforum-user@winehq.org> wrote:
Thanks, but it does not work with WINE 1.3 either. Maybe that's a problem specific to the game I'm trying to play. I'll
try it with a different game later. Or did I do it wrong? I opened winecfg, went to drives, added a drive D: mapped
to /dev/sr0, opened the advanced options and selected CD.

And the new version produced a couple of new graphic bugs in Baldur's Gate (the mouse pointer now leaves
permanent traces). Maybe I should stick with the last stable release and just make a drive for every disc I want to
use...
The 'latest' stable release, Wine 1.2.3 is over one and a half years
old and is only maintained for translation bug reports. The best
course of action is to file bug reports, if they do not already exist,
for any anomolies you find with Wine. Remember, graphical issues may
actually be related to your Linux video drivers and not Wine.

James

vitamin
Moderator
Moderator
Posts: 6605
Joined: Sat Feb 23, 2008 2:29 pm

Post by vitamin » Thu Jan 26, 2012 9:17 pm

RFS-81 wrote:it does not work with WINE 1.3 either
No such version. I said you have to have wine-1.3.36 or wine-1.3.37 (last two releases, until tomorrow that is of course).
RFS-81 wrote:I opened winecfg, went to drives, added a drive D: mapped to /dev/sr0, opened the advanced options and selected CD.
Wrong. You map drive to a mount directory, not to a device. To get mount directory see output of "mount" command, search for sr0 and pick the left most part.

Usurp
Level 4
Level 4
Posts: 161
Joined: Sat Apr 19, 2008 7:16 am

Re: Problem with automatic mounting of disc drive (Ubuntu 11

Post by Usurp » Fri Jan 27, 2012 4:16 am

vitamin wrote:
RFS-81 wrote:it does not work with WINE 1.3 either
No such version. I said you have to have wine-1.3.36 or wine-1.3.37 (last two releases, until tomorrow that is of course).
RFS-81 wrote:I opened winecfg, went to drives, added a drive D: mapped to /dev/sr0, opened the advanced options and selected CD.
Wrong. You map drive to a mount directory, not to a device. To get mount directory see output of "mount" command, search for sr0 and pick the left most part.
This why the OP went there - the mount point is dynamic nowadays in many distros.
RFS-81 wrote:Hi!

First of all, WINE is great! There is only one little inconvenience for me: I am using WINE 1.2 under Ubuntu 11.10. It automatically mounts CDs and DVDs at /media/(disc name). So whenever I insert a new disc, I have to change the configuration of WINE which is a bit annoying.

RFS-81
Newbie
Newbie
Posts: 4
Joined: Thu Jan 19, 2012 11:58 am

Post by RFS-81 » Fri Jan 27, 2012 5:44 am

I just checked the version number, it was 1.3.28 from the Software Center. Now I added the Wine repository and installed 1.3.37 and the graphic bugs are gone! I feel stupid now... :roll:

Ok, but what can I do about my old problem? Is it possible to have dynamic mappings for the drives in Wine?

RFS-81
Newbie
Newbie
Posts: 4
Joined: Thu Jan 19, 2012 11:58 am

Post by RFS-81 » Fri Jan 27, 2012 6:03 am

Oh, I just saw that Wine does that automatically now.

Thanks everyone!

vitamin
Moderator
Moderator
Posts: 6605
Joined: Sat Feb 23, 2008 2:29 pm

Re: Problem with automatic mounting of disc drive (Ubuntu 11

Post by vitamin » Sun Jan 29, 2012 12:34 pm

Usurp wrote:This why the OP went there - the mount point is dynamic nowadays in many distros.
It doesn't make it correct tho. You can't point a drive to a device instead of a mount point and hope it some-how works. Remember that:
d: -> mount point
d:: -> device

And without HAL/dbus Wine won't be able to detect auto-mounts anyway.

Locked