(Mint 19.3 Tricia) Can't install vcrun2010 with PlayOnLinux 4.3.4

Questions about Wine on Linux
Post Reply
data-angel
Level 1
Level 1
Posts: 6
Joined: Fri Oct 30, 2020 4:02 pm

(Mint 19.3 Tricia) Can't install vcrun2010 with PlayOnLinux 4.3.4

Post by data-angel » Fri Oct 30, 2020 4:13 pm

I've made a post here and here but i'll put the info down here too. Any input or troubleshooting tips would be helpful, been giving me a headache and would love to get it sorted.

When trying to install vcrun2010 with POL 4.3.4 I experience a crash and i'm not sure what to do about it. I was following this steam install guide, i installed everything in the same order with no problem until vcrun2010 and it doesn't seem i can continue without it.

versions of wine i tried:

Code: Select all

5.19
5.17
3.14
4.2
2.4-staging
error i get:

Code: Select all

Unhandled exception: C++ exception(object = 0x0031f594, type = 0x1009c200) in 32-bit code (0x7b00f2b4).
Register dump:
 CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
 EIP:7b00f2b4 ESP:0031f4a4 EBP:0031f508 EFLAGS:00000246(   - --  I  Z- -P- )
 EAX:0031f4b0 EBX:0031f594 ECX:00000008 EDX:0031f534
 ESI:100187ac EDI:00000000
Stack dump:
0x0031f4a4:  00110094 00000000 100858ab e06d7363
0x0031f4b4:  00000001 00000000 7b00f2b4 00000003
0x0031f4c4:  19930520 0031f594 1009c200 7bc2687e
0x0031f4d4:  00110094 100858ab 00110000 00000000
0x0031f4e4:  00b56c78 0031f514 0031f514 1005ed93
0x0031f4f4:  1005ed98 323be257 00110094 00000000
Backtrace:
=>0 0x7b00f2b4 RaiseException+0x6f(code=<is not available>, flags=<is not available>, count=<is not available>, args=<is not available>) [Z:\root\wine-git\dlls\kernelbase\debug.c:316] in kernelbase (0x0031f508)
  1 0x1008188f in setupengine (+0x8188e) (0x0031f540)
  2 0x10066e96 EntryPoint+0xffffffff() in setupengine (0x0031f5b0)
  3 0x1006380b EntryPoint+0xffffffff() in setupengine (0x0031f5d0)
  4 0x10061405 EntryPoint+0xffffffff() in setupengine (0x0031f608)
  5 0x10035a52 EntryPoint+0xffffffff() in setupengine (0x0031f678)
  6 0x1006b83a EntryPoint+0xffffffff() in setupengine (0x0031fdd8)
  7 0x1005faa0 EntryPoint+0xffffffff() in setupengine (0x0031fe48)
  8 0x100580de EntryPoint+0xffffffff() in setupengine (0x0031fe9c)
  9 0x00402928 EntryPoint+0xffffffff() in setup (0x0031ff30)
  10 0x7b661bb0 in kernel32 (+0x41baf) (0x0031ff48)
  11 0x7bc571f7 RtlSleepConditionVariableSRW+0x156(variable=<is not available>, lock=<is not available>, timeout=<is not available>, flags=<is not available>) [Z:\root\wine-git\dlls\ntdll\sync.c:556] in ntdll (0x0031ff5c)
  12 0x7bc573e8 call_thread_func+0xb7() [Z:\root\wine-git\dlls\ntdll\thread.c:133] in ntdll (0x0031ffec)
0x7b00f2b4 RaiseException+0x6f [Z:\root\wine-git\dlls\kernelbase\debug.c:316] in kernelbase: movl	0xfffffffc(%ebp),%ebx
Unable to access file 'Z:\root\wine-git\dlls\kernelbase\debug.c'
Modules:
Module	Address			Debug info	Name (48 modules)
PE	  320000-  397000	Deferred        wintrust
PE	  3a0000-  3e1000	Deferred        jsproxy
PE	  400000-  415000	Export          setup
PE	  420000-  626000	Deferred        urlmon
PE	10000000-100c8000	Export          setupengine
PE	61b00000-61b6f000	Deferred        sechost
PE	61f00000-61f32000	Deferred        sxs
PE	62340000-623a6000	Deferred        uxtheme
PE	62780000-627a4000	Deferred        mspatcha
PE	62800000-6289b000	Deferred        usp10
PE	62940000-62967000	Deferred        imagehlp
PE	62d00000-62da6000	Deferred        advapi32
PE	64540000-64606000	Deferred        winhttp
PE	64b40000-64b71000	Deferred        shcore
PE	65200000-65553000	Deferred        ole32
PE	65980000-65997000	Deferred        version
PE	67800000-678fb000	Deferred        combase
PE	67f00000-67f1d000	Deferred        userenv
PE	68c40000-68d26000	Deferred        shlwapi
PE	6a300000-6a5d2000	Deferred        oleaut32
PE	6a900000-6aa48000	Deferred        setupapi
PE	6aec0000-6aecf000	Deferred        psapi
PE	6b4c0000-6b60c000	Deferred        wininet
PE	6c0c0000-6c0f2000	Deferred        imm32
PE	6cd00000-6cd24000	Deferred        sqmapi
PE	6dbc0000-6dc01000	Deferred        mpr
PE	6e1c0000-6e205000	Deferred        cabinet
PE	6e8c0000-6ebb7000	Deferred        comctl32
PE	6f280000-6f2ac000	Deferred        odbccp32
PE	6fdc0000-6ff4e000	Deferred        rpcrt4
PE	71400000-71875000	Deferred        msi
PE	7b000000-7b23f000	Dwarf           kernelbase
PE	7b620000-7b7dc000	Export          kernel32
PE	7bc00000-7be17000	Dwarf           ntdll
PE	7d150000-7d153000	Deferred        kerberos
PE	7d350000-7d354000	Deferred        winex11
PE	7d960000-7d964000	Deferred        msvcrt
PE	7da30000-7da34000	Deferred        dnsapi
PE	7da60000-7da64000	Deferred        iphlpapi
PE	7da90000-7da93000	Deferred        netapi32
PE	7dae0000-7dae3000	Deferred        secur32
PE	7db30000-7db34000	Deferred        ws2_32
PE	7dba0000-7e477000	Deferred        shell32
PE	7e5b0000-7e5b7000	Deferred        gdi32
PE	7e770000-7e774000	Deferred        bcrypt
PE	7e7c0000-7e804000	Deferred        crypt32
PE	7e8e0000-7e9c8000	Deferred        user32
PE	7eb60000-7eb64000	Deferred        ucrtbase
Threads:
process  tid      prio (all id:s are in hex)
00000038 services.exe
	0000003c    0
	00000040    0
	0000004c    0
	00000064    0
	000000d0    0
00000044 winedevice.exe
	00000048    0
	00000054    0
	00000058    0
	000000a8    0
0000005c plugplay.exe
	00000060    0
	00000068    0
	0000006c    0
	00000070    0
000000ac vcredist_x86.exe
	000000b0    0
	000000ec    0
000000b4 explorer.exe
	000000b8    0
	000000bc    0
	000000c0    0
000000c8 rpcss.exe
	000000cc    0
	000000d4    0
	000000d8    0
	000000dc    0
	000000e0    0
	000000e4    0
	000000e8    0
	000000f8    0
000000f0 (D) c:\92a554ae3672254cfbe362\Setup.exe
	000000f4    0 <==
	00000104    0
System information:
    Wine build: wine-5.17
    Platform: i386
    Version: Windows XP
    Host system: Linux
    Host version: 5.4.0-48-generic

jkfloris
Level 8
Level 8
Posts: 1202
Joined: Thu Aug 14, 2014 10:10 am

Re: (Mint 19.3 Tricia) Can't install vcrun2010 with PlayOnLinux 4.3.4

Post by jkfloris » Sat Oct 31, 2020 11:15 am

PlayOnLinux isn't supported here.
I can't reproduce your issue with the WineHQ packages in a clean Wineprefix.

Code: Select all

...
Z:\root\wine-git\dlls\kernelbase\debug.c
...
Did you run Wine/ POL as root?

data-angel
Level 1
Level 1
Posts: 6
Joined: Fri Oct 30, 2020 4:02 pm

Re: (Mint 19.3 Tricia) Can't install vcrun2010 with PlayOnLinux 4.3.4

Post by data-angel » Sat Oct 31, 2020 4:13 pm

@jkfloris

if i am, definitely not intentionally, i just start it from the graphical menu, no special commands or anything, does that line suggest it's running as root? how would i stop it?

jkfloris
Level 8
Level 8
Posts: 1202
Joined: Thu Aug 14, 2014 10:10 am

Re: (Mint 19.3 Tricia) Can't install vcrun2010 with PlayOnLinux 4.3.4

Post by jkfloris » Mon Nov 02, 2020 7:27 am

I don't have any experience with PlayOnLinux so I cannot say for sure, but it looks like the program tries to access a file in the /root directory.

Do you have the same issue if you use plain Wine?
Install an up to date Wine version from WineHQ and run:

Code: Select all

WINEPREFIX=~/vcrun2010-test winetricks -q vcrun2010

Bamm
Level 4
Level 4
Posts: 107
Joined: Thu May 22, 2008 3:18 am
Location: Manila, Philippines

Re: (Mint 19.3 Tricia) Can't install vcrun2010 with PlayOnLinux 4.3.4

Post by Bamm » Mon Nov 02, 2020 8:23 am

I also have an app that requires vcrun2010, but I never had issues installing it in Wine using winetricks -q vcrun2010. Maybe it's a PlayOnLinux bug? I'm currently running Wine 5.0.2 on an older Linux Mint 18.3 Sylvia system, but I tested it in Mint Tricia and Mint Ulyana in Virtualbox, and also in Ubuntu MATE 20.04 Focal, and I didn't get any errors installing winetricks -q vcrun2010.

Gcenx
Level 6
Level 6
Posts: 526
Joined: Mon Dec 25, 2017 12:11 pm

Re: (Mint 19.3 Tricia) Can't install vcrun2010 with PlayOnLinux 4.3.4

Post by Gcenx » Mon Nov 02, 2020 10:35 am

jkfloris wrote:
Mon Nov 02, 2020 7:27 am
I don't have any experience with PlayOnLinux so I cannot say for sure, but it looks like the program tries to access a file in the /root directory.

Do you have the same issue if you use plain Wine?
Install an up to date Wine version from WineHQ and run:

Code: Select all

WINEPREFIX=~/vcrun2010-test winetricks -q vcrun2010
The output is showing the source location and file that’s related to the issue, PlayOnLinux/PlayOnMac doesn’t run as root.

However there winebuilder does download the wine source into /root/wine-git, so any crash using one of there builds will show the source file that needs investigating so it will show /root/wine-git/

data-angel
Level 1
Level 1
Posts: 6
Joined: Fri Oct 30, 2020 4:02 pm

Re: (Mint 19.3 Tricia) Can't install vcrun2010 with PlayOnLinux 4.3.4

Post by data-angel » Wed Nov 11, 2020 4:51 pm

I'm having trouble with unsatisfiable dependencies when trying to install plain wine from the bionic repository, when i run

Code: Select all

sudo apt install --install-recommends winehq-stable
it tells me it depends on wine-stable (and that i have broken packages but i couldn't find any following these methods), then that depends on libfaudio0, is there a repository that can be suggested for this?


data-angel
Level 1
Level 1
Posts: 6
Joined: Fri Oct 30, 2020 4:02 pm

Re: (Mint 19.3 Tricia) Can't install vcrun2010 with PlayOnLinux 4.3.4

Post by data-angel » Mon Nov 16, 2020 8:17 pm

thank you dimesio! i managed to get a prefix running but i'm not used to running wine in terminal so i'm not really sure how to interpret this output from trying to install vcrun2010, if someone could help interpret for me that would be great

Code: Select all

$ WINEPREFIX=~/.wine/drive_c winetricks -q vcrun2010
Using winetricks 20180217 - sha256sum: 1b156c616174f41df79d72a90c52eb2b110c63a6e8ecb865d303a8f9f0908924 with wine-5.0.3 and WINEARCH=win32
Executing w_do_call vcrun2010
Executing load_vcrun2010 
Executing mkdir -p /home/data-angel/.cache/winetricks/vcrun2010
Executing cd /home/data-angel/.cache/winetricks/vcrun2010
Downloading https://download.microsoft.com/download/5/B/C/5BC5DBB3-652D-4DCE-B14A-475AB85EEF6E/vcredist_x86.exe to /home/data-angel/.cache/winetricks/vcrun2010
--2020-11-17 01:06:09--  https://download.microsoft.com/download/5/B/C/5BC5DBB3-652D-4DCE-B14A-475AB85EEF6E/vcredist_x86.exe
Resolving download.microsoft.com (download.microsoft.com)... 2a02:26f0:8f:481::e59, 2a02:26f0:8f:483::e59, 96.16.108.145
Connecting to download.microsoft.com (download.microsoft.com)|2a02:26f0:8f:481::e59|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 5073240 (4.8M) [application/octet-stream]
Saving to: ‘vcredist_x86.exe’

vcredist_x86.exe    100%[===================>]   4.84M  5.64MB/s    in 0.9s    

2020-11-17 01:06:10 (5.64 MB/s) - ‘vcredist_x86.exe’ saved [5073240/5073240]

Executing cd /
Using native,builtin override for following DLLs: msvcp100 msvcr100 vcomp100 atl100
Executing wine regedit /S C:\windows\Temp\_vcrun2010\override-dll.reg
Executing cd /home/data-angel/.cache/winetricks/vcrun2010
Executing wine vcredist_x86.exe /q
0035:fixme:clusapi:GetNodeClusterState ((null),0032EBE4) stub!
0035:fixme:advapi:DecryptFileA ("c:\\cf8768423386b28d97a52edb49daedea\\", 00000000): stub
003d:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
003d:fixme:ntdll:EtwRegisterTraceGuidsW (0x6cd15f38, 0x6cd20180, {e2821408-c59d-418f-ad3f-aa4e792aeb79}, 1, 0x32e6d0, (null), (null), 0x6cd20188): stub
003d:fixme:ntdll:EtwRegisterTraceGuidsW   register trace class {e2821408-c59d-418f-ad3f-aa4e792aeb79}
003d:fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
003d:fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
003d:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
003d:fixme:advapi:LsaOpenPolicy ((null),0x32f4b8,0x00000001,0x32f4ac) stub
003d:fixme:security:GetWindowsAccountDomainSid (0032F314 00B3816C 0032F310): semi-stub
003d:fixme:secur32:GetComputerObjectNameW NameFormat 7 not implemented
003d:fixme:advapi:LsaClose (0xcafe) stub
003e:fixme:wintrust:SOFTPUB_VerifyImageHash Cannot verify hash for pszObjId="1.3.6.1.4.1.311.2.1.25"
003e:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
003e:fixme:wintrust:SOFTPUB_VerifyImageHash Cannot verify hash for pszObjId="1.3.6.1.4.1.311.2.1.30"
003d:fixme:advapi:LsaOpenPolicy ((null),0x32f308,0x00000001,0x32f2fc) stub
003d:fixme:security:GetWindowsAccountDomainSid (0032F164 00B38E74 0032F160): semi-stub
003d:fixme:secur32:GetComputerObjectNameW NameFormat 7 not implemented
003d:fixme:advapi:LsaClose (0xcafe) stub
003d:fixme:ntdll:EtwUnregisterTraceGuids deadbeef: stub
idk what any of this means but "fixme" seems like it might indicate a problem? lol

spoon0042
Level 5
Level 5
Posts: 404
Joined: Thu Dec 24, 2009 11:00 am

Re: (Mint 19.3 Tricia) Can't install vcrun2010 with PlayOnLinux 4.3.4

Post by spoon0042 » Tue Nov 17, 2020 12:46 pm

That looks ok, but a few notes:
003d:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
1. It may not matter but you can fix that.

2. How did you install winetricks? If it was a package it may be out of date. Again, may not matter but you can get a current version: https://wiki.winehq.org/Winetricks

3. The default WINEPREFIX is ~/.wine so you don't need to specify it. Your log though specifies it as ~/.wine/drive_c which will put another wine installation there with its own drive_c which isn't really what you want. Again, it may not matter. :) ... but it's messy and you'll probably want to delete your ~/.wine and start over installing what you were trying to install. If that's clear.

4. That install guide is... well it's kind of old and doesn't look good. There is https://appdb.winehq.org where users can report how well different apps work. I assume the page for Victoria II is here. You can look over that, or if you've installed a current (5.x) wine you maybe should try running the game as is first, and only install what you really need via winetricks after.

data-angel
Level 1
Level 1
Posts: 6
Joined: Fri Oct 30, 2020 4:02 pm

Re: (Mint 19.3 Tricia) Can't install vcrun2010 with PlayOnLinux 4.3.4

Post by data-angel » Thu Nov 19, 2020 12:29 pm

@spoon0042
1. I have now installed ntlm_auth! thanks for singling that out
2.This is what I did to install wintricks so i think it's up to date
3. OOPS... thanks for pointing that out, sorted it! lol
4. ah i thought i edited my original post, the guide i was using was from steam here but thank you for those links.

I'm using a 32 prefix as suggested which allowed me to install steam via wine and then install vicky2 thru that, i had to do that thru the terminal because I can't seem to fix the blackscreen error for steam BUT i could not use the vicky 2 launcher through wine like it says i should be able to, i get this backtrace, when trying to start it through v2game.exe i get a black screen with vicky 2's loading cursor before it crashes without a log 😥

spoon0042
Level 5
Level 5
Posts: 404
Joined: Thu Dec 24, 2009 11:00 am

Re: (Mint 19.3 Tricia) Can't install vcrun2010 with PlayOnLinux 4.3.4

Post by spoon0042 » Fri Nov 20, 2020 5:59 pm

Did you (attempt to) install .net or vcrun? Because that doesn't seem to be necessary anymore and may cause problems. At least for me (turns out I bought this at some point?) it runs with both 5.0.3 and staging 5.21 with no additional setup. Well, the launcher seems to be missing images but it seems fine otherwise. You'll probably want to try a staging build if you want steam to be at all functional; 5.22 should be up shortly.

User avatar
Bob Wya
Level 12
Level 12
Posts: 2889
Joined: Sat Oct 16, 2010 7:40 pm
Location: Scotland
Contact:

Re: (Mint 19.3 Tricia) Can't install vcrun2010 with PlayOnLinux 4.3.4

Post by Bob Wya » Sat Nov 21, 2020 11:57 am

data-angel wrote:
Mon Nov 16, 2020 8:17 pm
...

Code: Select all

$ WINEPREFIX=~/.wine/drive_c winetricks -q vcrun2010
Using winetricks 20180217 - sha256sum: 1b156c616174f41df79d72a90c52eb2b110c63a6e8ecb865d303a8f9f0908924 with ...
...
@data-angel

That version of winetricks is years out-of-date.
You'd want to update your winetricks installation...

See: github.com: Winetricks/winetricks.

You can use:

Code: Select all

sudo winetricks --self-update
with your current version of winetricks.

But I don't think that pulls in, or updates, the winetricks BASH completion script (I wrote).

Bob

data-angel
Level 1
Level 1
Posts: 6
Joined: Fri Oct 30, 2020 4:02 pm

Re: (Mint 19.3 Tricia) Can't install vcrun2010 with PlayOnLinux 4.3.4

Post by data-angel » Tue Nov 24, 2020 7:51 pm

Oh! Idk how that happened, i guess i installed the wrong one lol, updating wintricks and not installing .net or vcrun seems to get vicky 2 to work! there is an issue of not being able to hear the music specifically but it's no big deal with this game, if it's something fixable anyone knows about i'd appreciate a pointer in case it's something that messes up other games too! but otherwise thank you everyone you've all been a big help! i may never know why POL died for me but wine itself seems to be good now 😎

Post Reply