problem with installing winehq

Questions about Wine on Linux
Post Reply
yonder17
Level 1
Level 1
Posts: 7
Joined: Wed Oct 03, 2018 5:44 pm

problem with installing winehq

Post by yonder17 » Wed Oct 03, 2018 5:58 pm

Hello everyone, I have debian 9 and I have been trying to install winehq, but I could not get it, I followed the step of the page to the letter and I always get this error:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
winehq-stable : Depends: wine-stable (= 3.0.3~stretch)
E: Unable to correct problems, you have held broken packages.

If I try to install the missing dependency, I get other dependencies and so on, I do not know if someone else has presented this problem, to help me and thank you.

jkfloris
Level 6
Level 6
Posts: 695
Joined: Thu Aug 14, 2014 10:10 am

Re: problem with installing winehq

Post by jkfloris » Thu Oct 04, 2018 10:18 am

Did you have any "non-native-Debian-stable" packages installed? (e.g. packages from Ubuntu, ppa, deb-Multimedia or Debian testing/sid)
If I try to install the missing dependency, I get other dependencies and so on
That's the only way to fix this. Manually find the broken dependency.

yonder17
Level 1
Level 1
Posts: 7
Joined: Wed Oct 03, 2018 5:44 pm

Re: problem with installing winehq

Post by yonder17 » Thu Oct 04, 2018 10:52 pm

Yes, I have packages that are not debian, for example I have gns3
deb http://ppa.launchpad.net/gns3/ppa/ubuntu xenial main

megasync, skype, sublime text, vscode

Should I uninstall them?

jkfloris
Level 6
Level 6
Posts: 695
Joined: Thu Aug 14, 2014 10:10 am

Re: problem with installing winehq

Post by jkfloris » Fri Oct 05, 2018 9:20 am

You don't have to uninstall them if you need those programs, but you haven't a "real" Debian installation. And dependency-solving will be up to you.
https://wiki.debian.org/DontBreakDebian
(TL;DR: Don't mix Debian and Ubuntu!)

In other words two possible solutions:
1. Remove all non-native-Debian packages and remove their sources.list lines/files
2. Manually find the broken dependency.

yonder17
Level 1
Level 1
Posts: 7
Joined: Wed Oct 03, 2018 5:44 pm

Re: problem with installing winehq

Post by yonder17 » Fri Oct 05, 2018 8:48 pm

Thank you very much, the programs are already uninstalled, I alone, that only one of them was the one that we had to do.
However, I can not install, how can we get a broken package, they instruct me?

jkfloris
Level 6
Level 6
Posts: 695
Joined: Thu Aug 14, 2014 10:10 am

Re: problem with installing winehq

Post by jkfloris » Sat Oct 06, 2018 2:32 am

Can you post the terminal output?

User avatar
Bob Wya
Level 12
Level 12
Posts: 2772
Joined: Sat Oct 16, 2010 7:40 pm
Location: Cambridge
Contact:

Re: problem with installing winehq

Post by Bob Wya » Sat Oct 06, 2018 3:36 am

@ yonder17

Please can you use the forum Code tags:

Code: Select all

...
for posting terminal commands and output.
This will make your posts easier to read / parse.
Highlight a block, of terminal commands+text, and press the Code button - which is above the full reply (not the quick reply) forum edit box.

Thanks
Bob

yonder17
Level 1
Level 1
Posts: 7
Joined: Wed Oct 03, 2018 5:44 pm

Re: problem with installing winehq

Post by yonder17 » Sat Oct 06, 2018 4:16 pm

Code: Select all

jon@nolips:~$ sudo apt install winehq-stable 
[sudo] password for jon: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 winehq-stable : Depends: wine-stable (= 3.0.3~stretch)
E: Unable to correct problems, you have held broken packages.
jon@nolips:~$ sudo apt install wine-stable
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-stable : Depends: wine-stable-i386 (= 3.0.3~stretch)
E: Unable to correct problems, you have held broken packages.
jon@nolips:~$ sudo apt install wine-stable-i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-stable-i386:i386 : Depends: libgphoto2-6:i386 (>= 2.5.10) but it is not going to be installed
                         Depends: libasound2-plugins:i386 but it is not going to be installed
                         Recommends: libfontconfig1:i386 (>= 2.11) but it is not going to be installed
                         Recommends: libsane:i386 (>= 1.0.24) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
jon@nolips:~$ 
That's what I see in the terminal, I hope it's not too much trouble

User avatar
Bob Wya
Level 12
Level 12
Posts: 2772
Joined: Sat Oct 16, 2010 7:40 pm
Location: Cambridge
Contact:

Re: problem with installing winehq

Post by Bob Wya » Sat Oct 06, 2018 4:26 pm

@yonder17

Have a shot with the aptitude package manager:

Code: Select all

sudo apt-get install aptitude
aptitude install winehq-stable
I find apt is pretty hopeless - it just gives up at the first sign of trouble... :roll:

Also see: Ask Ubuntu: Unable to correct problems, you have held broken packages.

Bob

yonder17
Level 1
Level 1
Posts: 7
Joined: Wed Oct 03, 2018 5:44 pm

Re: problem with installing winehq

Post by yonder17 » Sun Oct 07, 2018 7:56 pm

Code: Select all

The following NEW packages will be installed:
  gcc-6-base:i386{a} gstreamer1.0-plugins-base:i386{a} i965-va-driver:i386{a} 
  libasound2:i386{a} libasound2-plugins:i386{a} libasyncns0:i386{a} libavahi-client3:i386{a} 
  libavahi-common-data:i386{a} libavahi-common3:i386{a} libavcodec57:i386{a} 
  libavresample3:i386{a} libavutil55:i386{a} libblkid1:i386{a} libbsd0:i386{a} libc6:i386{a} 
  libcairo2:i386{a} libcap2:i386{a} libcapi20-3{a} libcapi20-3:i386{a} libcdparanoia0:i386{a} 
  libcomerr2:i386{a} libcrystalhd3:i386{a} libcups2:i386{a} libdb5.3:i386{a} 
  libdbus-1-3:i386{a} libdrm-amdgpu1:i386{a} libdrm-intel1:i386{a} libdrm-nouveau2:i386{a} 
  libdrm-radeon1:i386{a} libdrm2:i386{a} libedit2:i386{a} libelf1:i386{a} libexif12:i386{a} 
  libexpat1:i386{a} libfdk-aac1:i386{a} libffi6:i386{a} libflac8:i386{a} 
  libfontconfig1:i386{ab} libfreetype6:i386{a} libgcc1:i386{a} libgcrypt20:i386{a} 
  libgd3:i386{a} libgl1-mesa-dri:i386{a} libgl1-mesa-glx:i386{a} libglapi-mesa:i386{a} 
  libglib2.0-0:i386{a} libglu1-mesa:i386{a} libgmp10:i386{a} libgnutls30:i386{a} 
  libgomp1:i386{a} libgpg-error0:i386{a} libgphoto2-6:i386{a} libgphoto2-port12:i386{a} 
  libgpm2:i386{a} libgsm1:i386{a} libgssapi-krb5-2:i386{a} 
  libgstreamer-plugins-base1.0-0:i386{a} libgstreamer1.0-0:i386{a} libhogweed4:i386{a} 
  libice6:i386{a} libicu57:i386{a} libidn11:i386{a} libieee1284-3:i386{a} libilbc2:i386{a} 
  libjack-jackd2-0:i386{a} libjbig0:i386{a} libjpeg62-turbo:i386{a} libk5crypto3:i386{a} 
  libkeyutils1:i386{a} libkrb5-3:i386{a} libkrb5support0:i386{a} libkvazaar3:i386{a} 
  liblcms2-2:i386{a} libldap-2.4-2:i386{a} libllvm3.9:i386{a} libltdl7:i386{a} liblz4-1:i386{a} 
  liblzma5:i386{a} libmfx0:i386{a} libmount1:i386{a} libmp3lame0:i386{a} libmpg123-0:i386{a} 
  libncurses5:i386{a} libnettle6:i386{a} libnuma1:i386{a} libodbc1:i386{a} libogg0:i386{a} 
  libopenal1:i386{a} libopencore-amrnb0:i386{a} libopencore-amrwb0:i386{a} 
  libopenh264-2:i386{a} libopenjp2-7:i386{a} libopus0:i386{a} liborc-0.4-0:i386{a} 
  libosmesa6{a} libosmesa6:i386{a} libp11-kit0:i386{a} libpcap0.8:i386{a} libpciaccess0:i386{a} 
  libpcre3:i386{a} libpixman-1-0:i386{a} libpng16-16:i386{a} libpulse0:i386{a} 
  libsamplerate0:i386{a} libsane:i386{a} libsane-extras:i386{a} libsasl2-2:i386{a} 
  libsasl2-modules:i386{a} libsasl2-modules-db:i386{a} libselinux1:i386{a} libsensors4:i386{a} 
  libshine3:i386{a} libsm6:i386{a} libsnappy1v5:i386{a} libsndfile1:i386{a} libsndio6.1:i386{a} 
  libsoxr0:i386{a} libspeex1:i386{a} libssl1.1:i386{a} libstdc++6:i386{a} 
  libswresample2:i386{a} libsystemd0:i386{a} libtasn1-6:i386{a} libtheora0:i386{a} 
  libtiff5:i386{a} libtinfo5:i386{a} libtxc-dxtn-s2tc:i386{a} libudev1:i386{a} 
  libusb-1.0-0:i386{a} libuuid1:i386{a} libv4l-0:i386{a} libv4lconvert0:i386{a} 
  libva-drm1:i386{a} libva-x11-1:i386{a} libva1:i386{a} libvdpau-va-gl1:i386{a} 
  libvdpau1:i386{a} libvisual-0.4-0:i386{a} libvo-amrwbenc0:i386{a} libvorbis0a:i386{a} 
  libvorbisenc2:i386{a} libvpx4:i386{a} libwebp6:i386{a} libwrap0:i386{a} libx11-6:i386{a} 
  libx11-xcb1:i386{a} libx264-150:i386{a} libx265-116:i386{a} libxau6:i386{a} 
  libxcb-dri2-0:i386{a} libxcb-dri3-0:i386{a} libxcb-glx0:i386{a} libxcb-present0:i386{a} 
  libxcb-render0:i386{a} libxcb-shm0:i386{a} libxcb-sync1:i386{a} libxcb1:i386{a} 
  libxcomposite1:i386{a} libxcursor1:i386{a} libxdamage1:i386{a} libxdmcp6:i386{a} 
  libxext6:i386{a} libxfixes3:i386{a} libxi6:i386{a} libxinerama1:i386{a} libxml2:i386{a} 
  libxpm4:i386{a} libxrandr2:i386{a} libxrender1:i386{a} libxshmfence1:i386{a} 
  libxslt1.1:i386{a} libxtst6:i386{a} libxvidcore4:i386{a} libxxf86vm1:i386{a} libzvbi0:i386{a} 
  mesa-va-drivers:i386{a} mesa-vdpau-drivers:i386{a} va-driver-all:i386{a} 
  vdpau-driver-all:i386{a} wine-stable{a} wine-stable-amd64{a} wine-stable-i386:i386{a} 
  winehq-stable zlib1g:i386{a} 
0 packages upgraded, 184 newly installed, 0 to remove and 4 not upgraded.
Need to get 120 MB of archives. After unpacking 769 MB will be used.
The following packages have unmet dependencies:
 libfontconfig1 : Breaks: libfontconfig1:i386 (!= 2.12.6-0.1) but 2.11.0-6.7+b1 is to be installed
 libfontconfig1:i386 : Breaks: libfontconfig1 (!= 2.11.0-6.7+b1) but 2.12.6-0.1 is installed
open: 69; closed: 757; defer: 33; conflict: 45                                                     .The following actions will resolve these dependencies:

      Keep the following packages at their current version:                          
1)      gstreamer1.0-plugins-base:i386 [Not Installed]                               
2)      libasound2-plugins:i386 [Not Installed]                                      
3)      libavcodec57:i386 [Not Installed]                                            
4)      libcairo2:i386 [Not Installed]                                               
5)      libfontconfig1:i386 [Not Installed]                                          
6)      libgd3:i386 [Not Installed]                                                  
7)      libgphoto2-6:i386 [Not Installed]                                            
8)      libsane:i386 [Not Installed]                                                 
9)      libtheora0:i386 [Not Installed]                                              
10)     wine-stable [Not Installed]                                                  
11)     wine-stable-i386:i386 [Not Installed]                                        
12)     winehq-stable [Not Installed]                                                

      Leave the following dependencies unresolved:                                   
13)     libgstreamer-plugins-base1.0-0:i386 recommends gstreamer1.0-plugins-base:i386
14)     wine-stable-i386:i386 recommends libfontconfig1:i386 (>= 2.11)               
15)     wine-stable-i386:i386 recommends libsane:i386 (>= 1.0.24)                    



Accept this solution? [Y/n/q/?] 
That's what I get when I try to install with aptitude.

User avatar
dimesio
Moderator
Moderator
Posts: 12687
Joined: Tue Mar 25, 2008 10:30 pm

Re: problem with installing winehq

Post by dimesio » Sun Oct 07, 2018 9:51 pm

Code: Select all

The following packages have unmet dependencies:
 libfontconfig1 : Breaks: libfontconfig1:i386 (!= 2.12.6-0.1) but 2.11.0-6.7+b1 is to be installed
 libfontconfig1:i386 : Breaks: libfontconfig1 (!= 2.11.0-6.7+b1) but 2.12.6-0.1 is installed
64 and 32 bit packages of the same library can be installed side by side, but they have to be the same version number. Try installing the libfontconfig1:i386 package version that matches the 64 bit version you already have installed first, then retry installing Wine.

yonder17
Level 1
Level 1
Posts: 7
Joined: Wed Oct 03, 2018 5:44 pm

Re: problem with installing winehq

Post by yonder17 » Mon Oct 08, 2018 9:06 pm

I am trying to get the libfontconfig1 package: i386 2.12.6-0.1 but I can not find it, someone could provide me with a link

User avatar
dimesio
Moderator
Moderator
Posts: 12687
Joined: Tue Mar 25, 2008 10:30 pm

Re: problem with installing winehq

Post by dimesio » Tue Oct 09, 2018 5:15 am

If you can't find a 32 bit package for the newer version, downgrade the 64 bit version to the one your distro provides.

yonder17
Level 1
Level 1
Posts: 7
Joined: Wed Oct 03, 2018 5:44 pm

Re: problem with installing winehq

Post by yonder17 » Tue Oct 09, 2018 8:15 am

Thanks to all I could do the downgrade and I could do the installation, thank you very much and sorry for the inconvenience caused

henczati
Newbie
Newbie
Posts: 2
Joined: Sat Dec 03, 2016 9:13 pm

Re: problem with installing winehq

Post by henczati » Thu Jan 31, 2019 11:21 pm

In case of having multiple installed package versions not available from defined repos (e.g. removed a ppa just by deleting the deb line instead of using ppa-purge), instead of manually downgrading everything to last repo versions, it can be automated.
Inspired by https://askubuntu.com/a/1112347 :
```bash
sudo apt install $(apt-show-versions | fgrep 'newer than version in archive' | sed "s, .*,/$(lsb_release -sc),") \
&& sudo apt dist-upgrade
```

Post Reply