Help Installing GStreamer plug ins, wine 3.0 in ubuntu

Open forum for end-user questions about Wine. Before asking questions, check out the Wiki as a first step.
Forum Rules
Locked
tuixec
Newbie
Newbie
Posts: 2
Joined: Tue Feb 27, 2018 10:50 am

Help Installing GStreamer plug ins, wine 3.0 in ubuntu

Post by tuixec » Tue Feb 27, 2018 11:06 am

Hello,
I am totally noob in wine and a very basic ubuntu user.
I am trying to play a Pokemon customized game, so I tried installing wine to run it. After a couple of times, I managed to run it, but the game crashes whenever the character interacts with an object.
According to the people fixing bugs I am missing a "plug-in" however I have no clue how to install it. Any help?

Not sure about the version of wine installed. wine --version returns 3.0 but no mention to rc5 or rc6. I installed it with the following sequence.

sudo dpkg --add-architecture i386
sudo apt-add-repository 'https://dl.winehq.org/wine-builds/ubuntu/'
wget https://dl.winehq.org/wine-builds/Release.key && sudo apt-key add Release.key
sudo apt update && sudo apt install winehq-stable

Specific Pokemon version:
http://www.mediafire.com/file/cl6f7n7s1 ... +0.8.0.rar

SO: Ubuntu 17.10
Wine: 3.0 rc????

Text on the terminal Were I thing the error is.

0009:fixme:gstreamer:GST_QueryInterface No interface for {37d84f60-42cb-11ce-8135-00aa004bb851}!
0036:fixme:gstreamer:event_src 0x7d47d708 (61441) stub
0036:fixme:gstreamer:unknown_type Could not find a filter for caps: audio/mpeg, mpegversion=(int)1, layer=(int)3, parsed=(boolean)false
0037:fixme:gstreamer:watch_bus decodebin0: Your GStreamer installation is missing a plug-in.
0009:fixme:gstreamer:GST_Connect GStreamer could not find any streams
wine: Unhandled page fault on read access to 0x00000000 at address 0x7bd26d4c (thread 0038), starting debugger...
0009:fixme:quartz:MPEGSplitter_QueryInterface No interface for {37d84f60-42cb-11ce-8135-00aa004bb851}!
0009:fixme:gstreamer:Gstreamer_FindMatch Could not find plugin for audio/mpeg, mpegversion=(int) 1
0009:fixme:ole:CoCreateInstanceEx no instance created for interface {00000000-0000-0000-c000-000000000046} of class {728dcf55-128f-4dd1-ad22-becfa66ce7aa}, hres is 0x80004005
0009:fixme:strmbase:TransformFilterImpl_QueryInterface No interface for {37d84f60-42cb-11ce-8135-00aa004bb851}!


Any help about how to proceed will be appreciated, specially if explained at a extremely basic level.

User avatar
Bob Wya
Level 12
Level 12
Posts: 2778
Joined: Sat Oct 16, 2010 7:40 pm
Location: Cambridge
Contact:

Re: Help Installing GStreamer plug ins, wine 3.0 in ubuntu

Post by Bob Wya » Tue Feb 27, 2018 12:14 pm

You need the gstreamer1.0-plugins-ugly (1.12.3-1) [universe] package. That contains the MP3 decoder plugin you're missing.

Both 32-bit (multilib) and 64-bit (native):

Code: Select all

aptitude install gstreamer1.0-plugins-ugly:i386 gstreamer1.0-plugins-ugly
Good luck with that - last time I tried it, it was impossible to install both these packages, simultaneously, on Ubuntu 17.10. :roll:
Someone who uses Ubuntu on a regular basis - probably actually needs to actually file a bug about this! :lol:

Bob

tuixec
Newbie
Newbie
Posts: 2
Joined: Tue Feb 27, 2018 10:50 am

Re: Help Installing GStreamer plug ins, wine 3.0 in ubuntu

Post by tuixec » Tue Feb 27, 2018 2:03 pm

Thanx Bob, I will try to file a bug, since I encounter the same Conflict of packages.

User avatar
Bob Wya
Level 12
Level 12
Posts: 2778
Joined: Sat Oct 16, 2010 7:40 pm
Location: Cambridge
Contact:

Re: Help Installing GStreamer plug ins, wine 3.0 in ubuntu

Post by Bob Wya » Wed Feb 28, 2018 8:15 am

tuixec wrote:Thanx Bob, I will try to file a bug, since I encounter the same Conflict of packages.
Yes that would be v. helpful...! 8)

Thanks
Bob

froschmaterial
Level 2
Level 2
Posts: 11
Joined: Tue Feb 27, 2018 7:51 am

Re: Help Installing GStreamer plug ins, wine 3.0 in ubuntu

Post by froschmaterial » Thu Mar 01, 2018 6:12 pm

Try

Code: Select all

wine --version
in the console to discover what you are running.

Locked