WineHQ
Wine Forums

Board index » WineHQ » Wine Help » Linux




 Page 1 of 1 [ 8 posts ] 



 
Author Message
 Post Posted: Fri Aug 21, 2009 5:16 am 
Offline
Level 1
Level 1

Joined: Mon Aug 17, 2009 8:20 pm
Posts: 8
I am running wine 1.1.27 on Ubuntu 9.04 amd64. I install wine, making no changes to it. Run "wine vcredist_x86.exe". I eventually come up with the "Unable to find a volume for file extraction. Please verify that you have proper permissions."

Code:
wine vcredist_x86.exe
wine: created the configuration directory '/home/user/.wine'
fixme:mixer:ALSA_MixerInit No master control found on HDA ATI HDMI, disabling mixer
fixme:system:SetProcessDPIAware stub!
fixme:dwmapi:DwmIsCompositionEnabled 0x33cf94
fixme:file:MoveFileWithProgressW MOVEFILE_WRITE_THROUGH unimplemented
fixme:advapi:SetNamedSecurityInfoW L"C:\\windows\\system32\\gecko\\1.0.0\\wine_gecko\\components\\xpti.dat" 1 536870916 (nil) (nil) 0x19c214 (nil)
fixme:iphlpapi:NotifyAddrChange (Handle 0xa71e908, overlapped 0xa71e910): stub
fixme:iphlpapi:GetAdaptersAddresses no support for IPv6 addresses
fixme:file:MoveFileWithProgressW MOVEFILE_WRITE_THROUGH unimplemented
fixme:advapi:SetNamedSecurityInfoW L"C:\\windows\\system32\\gecko\\1.0.0\\wine_gecko\\components\\compreg.dat" 1 536870916 (nil) (nil) 0x1ecb65c (nil)
fixme:shell:DllCanUnloadNow stub
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  152 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  1998
  Current serial number in output stream:  1998
err:process:__wine_kernel_init boot event wait timed out
fixme:clusapi:GetNodeClusterState ((null),0x32ec9c,0) stub!

The error occurs in a pop up window at the end. Using the winetricks script where it creates "~/.wine/harddiskvolume0/" to link to "~/.wine/drive_c/" does not change anything (looks like it shouldn't matter anyway).


Top 
 Post Posted: Fri Aug 21, 2009 9:14 am 
Offline
Moderator
Moderator

Joined: Sat Feb 23, 2008 2:29 pm
Posts: 6605
fuzzylunkinz wrote:
Using the winetricks script where it creates "~/.wine/harddiskvolume0/" to link to "~/.wine/drive_c/" does not change anything (looks like it shouldn't matter anyway).

It actually does matter. Where is your c: ?

Have you tried removing ~/.wine directory (or using totally separate WINEPREFIX)?


Top 
 Post subject:
 Post Posted: Fri Aug 21, 2009 3:08 pm 
Offline
Level 1
Level 1

Joined: Mon Aug 17, 2009 8:20 pm
Posts: 8
My "C:" is at "~/.wine/dosdevices/" but is a link to "~/.wine/drive_c/".

I have completely deleted my .wine folder several times and tried multiple different times. You can see in the first part of my provided logs it says:
Code:
ine: created the configuration directory '/home/user/.wine'


I don't think creating the "~/.wine/harddiskvolume0" makes much of a difference, but the only reason I think that is because I read it in a comment in winetricks in the load_vcrun2008sp1 function:
Code:
load_vcrun2008sp1() {
    # This should be fixed in recent Wine, but for those using 1.0.1, fails.
    volnum

    # Load the Visual C++ 2008 SP1 runtime libraries
    # See http://www.microsoft.com/downloads/details.aspx?FamilyID=a5c84275-3b97-4ab7-a40d-3802b2af5fc2
    download vcrun2008sp1 http://download.microsoft.com/download/d/d/9/dd9a82d0-52ef-40db-8dab-795376989c03/vcredist_x86.exe 6939100e397cef26ec22e95e53fcd9fc979b7bc9
    try $WINE "$WINETRICKS_CACHE"/vcrun2008sp1/vcredist_x86.exe $WINETRICKS_QUIET
}


Using winetricks doesn't work anyway. It gives the same error.


Top 
 Post Posted: Fri Aug 21, 2009 8:13 pm 
Offline
Wine Developer
Wine Developer

Joined: Fri Feb 22, 2008 8:19 pm
Posts: 2383
On Fri, Aug 21, 2009 at 5:16 AM, fuzzylunkinz<wineforum-user@winehq.org> wrote:
Quote:
I am running wine 1.1.27 on Ubuntu 9.04 amd64.  I install wine, making no changes to it.  Run "wine vcredist_x86.exe".  I eventually come up with the "Unable to find a volume for file extraction.  Please verify that you have proper permissions."

This should've been fixed a long time ago. Retry in a clean ~/.wine
--
-Austin


Top 
 Post Posted: Fri Aug 21, 2009 10:17 pm 
Offline
Level 1
Level 1

Joined: Mon Aug 17, 2009 8:20 pm
Posts: 8
austin987 wrote:
On Fri, Aug 21, 2009 at 5:16 AM,
This should've been fixed a long time ago. Retry in a clean ~/.wine
--
-Austin

Yeah that's what I thought.

I didn't feel like spending a whole lot of time on the issue, so I decided to use /extract instead. Works perfectly fine.
Code:
wine vcredist_x86.exe


Oh, I read somewhere improper graphic drivers might effect this. Maybe that's my problem. I've been having a lot of trouble with drivers on Linux.


Top 
 Post subject:
 Post Posted: Fri Aug 21, 2009 10:18 pm 
Offline
Level 1
Level 1

Joined: Mon Aug 17, 2009 8:20 pm
Posts: 8
Durrr, that should be this:
Code:
wine vcredist_x86.exe /extract


Top 
 Post subject: to be continued...
 Post Posted: Mon May 28, 2012 5:20 am 
Offline
Newbie
Newbie

Joined: Mon May 28, 2012 5:03 am
Posts: 1
Hi fuzzylunkinz!
I am having the same problem:
I try to execute winetricks vcrun 2010
when: "Executing wine vcredist_x86.exe" i get the error message: "Unable to find a volume for file extraction"

It seems the problem that the folder where to extract vcredist_x86 is not specified in my wine settings.

If i go to ./cache/winetricks/vcrun2010 and i type
wine vcredist_x86.exe /extract
it makes me choose the directory for extracted files and it works fine.
Where do I have to change my settings in order to run correctly winetricks vcrun2010?

Any help would be really appreciated.
Forgot to say it...but i guess it's pretty clear....i'm a real beginner in this matter :D


Top 
 Post subject: Re: to be continued...
 Post Posted: Mon May 28, 2012 10:52 am 
Offline
Moderator
Moderator
User avatar

Joined: Tue Mar 25, 2008 10:30 pm
Posts: 11630
MozzoZozzo wrote:
Hi fuzzylunkinz!
I am having the same problem:

Did you notice that this thread is almost three years old?

Quote:
Where do I have to change my settings in order to run correctly winetricks vcrun2010?

Report problems with winetricks to http://winetricks.org.


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 8 posts ] 




Board index » WineHQ » Wine Help » Linux


Who is online

Users browsing this forum: Google [Bot], jkfloris, Yahoo [Bot] and 7 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: