Swedish characters seem broken on AppDB-site

Post issues, bugs, and feature requests about the various WineHQ websites to this forum.
Post Reply
odecif
Level 1
Level 1
Posts: 9
Joined: Thu Feb 17, 2022 7:40 am

Swedish characters seem broken on AppDB-site

Post by odecif »

Hi!

I have noticed that instead of showing the swedish umlaut-characters (å ä ö) on entries in the AppDB it instead shows diamonds with question marks in them (for example https://appdb.winehq.org/objectManager. ... &iId=20546). I am not sure when this happened but it should probably be looked in to.

Attached is an image of how it looks and I've tested this on 2 computers, one running Windows in swedish and one running Manjaro in english.

Thanks for the hard work!

Br
Attachments
wine_appdb_issue.jpg
User avatar
dimesio
Moderator
Moderator
Posts: 13228
Joined: Tue Mar 25, 2008 10:30 pm

Re: Swedish characters seem broken on AppDB-site

Post by dimesio »

I've fixed that page. If there are any others, post links here.
odecif
Level 1
Level 1
Posts: 9
Joined: Thu Feb 17, 2022 7:40 am

Re: Swedish characters seem broken on AppDB-site

Post by odecif »

I believe this is a bigger problem than just game pages. For example I can see that the test results of https://appdb.winehq.org/objectManager. ... &iId=37869 also now have missing Å Ä and Ö characters. Is there maybe some way to bulk-check this?

For more references I can see the following pages need update
https://appdb.winehq.org/objectManager. ... gId=112027

And the following testresults
https://appdb.winehq.org/objectManager. ... &iId=37869 (all)
https://appdb.winehq.org/objectManager. ... &iId=37844 (all)
https://appdb.winehq.org/objectManager. ... &iId=37851 (two latest results)
https://appdb.winehq.org/objectManager. ... &iId=32259 (two latest results + notes)

The developer "Levande Böcker" also seem to have been garbled https://appdb.winehq.org/objectManager. ... +Developer
User avatar
dimesio
Moderator
Moderator
Posts: 13228
Joined: Tue Mar 25, 2008 10:30 pm

Re: Swedish characters seem broken on AppDB-site

Post by dimesio »

I've fixed those. There is no way to bulk check this.
User avatar
sotel
Level 2
Level 2
Posts: 10
Joined: Thu Aug 07, 2008 9:09 am

Re: Swedish characters seem broken on AppDB-site

Post by sotel »

dimesio wrote: Tue Apr 30, 2024 12:57 pm I've fixed those. There is no way to bulk check this.
Hi Rosanne!

I watched this issue since the AppDB database (and others) was highjacked some years ago.
Also, German vovel mutations (Umlauts) did not work. And I saw now you fixed the author's name of the JavaEditor.
My idea was to create a sed-script that fixes all known Aliens in a database dump.

If I can help in some ways, please mail me!
User avatar
sotel
Level 2
Level 2
Posts: 10
Joined: Thu Aug 07, 2008 9:09 am

Re: Swedish characters seem broken on AppDB-site

Post by sotel »

Hi Rosanne!

As a maintainer of TreeComp I found another Developer name which isn't correctly shown. Correct will be this writing: Éric de Guillebon de Resnes.
And yes: this isn't a Swedish name - it's French.

What will be a useful way to report these mistakes?
Post Reply