FYI: update 5.7 to 5.8 (staging) broke fresh prefixes on Ubuntu 19.10 (eoan) here

Questions about Wine on Linux
Post Reply
fallenguru
Newbie
Newbie
Posts: 4
Joined: Sun May 03, 2020 8:45 am

FYI: update 5.7 to 5.8 (staging) broke fresh prefixes on Ubuntu 19.10 (eoan) here

Post by fallenguru » Sun May 10, 2020 2:12 am

Code: Select all

chris@oldkenny:~$ wine --version
wine-5.8 (Staging)
chris@oldkenny:~$ wineboot
wine: created the configuration directory '/home/chris/.wine'
002c:err:module:__wine_process_init failed to load L"C:\\windows\\system32\\wineboot.exe", error c0000018
0024:err:environ:run_wineboot failed to start wineboot c0000018
0024:fixme:winediag:start_process Wine Staging 5.8 is a testing version containing experimental patches.
0024:fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq.org.
0034:err:module:__wine_process_init failed to load L"C:\\windows\\system32\\wineboot.exe", error c0000018
0024:err:wineboot:main failed to restart 64-bit L"C:\\windows\\system32\\wineboot.exe", err 487
003c:err:module:__wine_process_init failed to load L"C:\\windows\\system32\\explorer.exe", error c0000018
Fresh prefix, as you can see, and it does not matter what I try to run, it always fails in this way Existing prefixes still seem to work (including wineboot).

User avatar
dimesio
Moderator
Moderator
Posts: 12813
Joined: Tue Mar 25, 2008 10:30 pm

Re: FYI: update 5.7 to 5.8 (staging) broke fresh prefixes on Ubuntu 19.10 (eoan) here

Post by dimesio » Sun May 10, 2020 7:16 am

Does the problem exist in the winehq-devel packages also, or is it staging only? Does downgrading to 5.7 fix the problem?

There was a bug affecting wineboot that was reported for wine-staging 5.7, but it has been marked fixed. https://bugs.winehq.org/show_bug.cgi?id=49065

fallenguru
Newbie
Newbie
Posts: 4
Joined: Sun May 03, 2020 8:45 am

Re: FYI: update 5.7 to 5.8 (staging) broke fresh prefixes on Ubuntu 19.10 (eoan) here

Post by fallenguru » Sun May 10, 2020 9:03 am

Does the problem exist in the winehq-devel packages also, or is it staging only?
Hm, looks like it's staging-only (I even switched back and forth between winehq-devel and winehq-staging a couple of times).

Do you want me to try the downgrade back to 5.7 as well? I'm just asking because downgrading packages on Debian-based systems has been ... hairy for me in the past.

lemonzest
Newbie
Newbie
Posts: 3
Joined: Sun May 10, 2020 12:49 pm

Re: FYI: update 5.7 to 5.8 (staging) broke fresh prefixes on Ubuntu 19.10 (eoan) here

Post by lemonzest » Sun May 10, 2020 12:52 pm

Can confirm with winehq-staging for fedora 32 GNOME (Wayland session)

WINEPREFIX=~/.testwine winecfg
002c:err:module:__wine_process_init failed to load L"C:\\windows\\system32\\wineboot.exe", error c0000018
0024:err:environ:run_wineboot failed to start wineboot c0000018
0024:fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
0034:err:module:__wine_process_init failed to load L"C:\\windows\\system32\\explorer.exe", error c0000018
0024:fixme:winediag:start_process Wine Staging 5.8 is a testing version containing experimental patches.
0024:fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq.org.
003c:fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
003c:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
003c:err:winediag:nodrv_CreateWindow The explorer process failed to start.


Neo21101970
Newbie
Newbie
Posts: 1
Joined: Wed May 13, 2020 7:02 am

Re: FYI: update 5.7 to 5.8 (staging) broke fresh prefixes on Ubuntu 19.10 (eoan) here

Post by Neo21101970 » Wed May 13, 2020 7:07 am

Please remove 5.8 - it is indeed broken. If you do not believe - fresh install - broken wineprefix!

Enter "winetricks" in commandline und you will see what i mean !

Ubuntu 20.04
Manjaro 20
Debian 10

NomisGnos
Newbie
Newbie
Posts: 3
Joined: Sun May 17, 2020 10:28 pm

Re: FYI: update 5.7 to 5.8 (staging) broke fresh prefixes on Ubuntu 19.10 (eoan) here

Post by NomisGnos » Sun May 17, 2020 10:56 pm

I can confirm that this is still an issue with Wine Staging 5.8. I can see that the commit to fix this was already submitted (not sure if this is just a fix for Macs but I am currently running Ubuntu 20.04.) Any ideas when this will be moved to a new tag Wine 5.9?

Wine 5.8 works fine when you use a win32 arch, but not a win64.

fallenguru
Newbie
Newbie
Posts: 4
Joined: Sun May 03, 2020 8:45 am

Re: FYI: update 5.7 to 5.8 (staging) broke fresh prefixes on Ubuntu 19.10 (eoan) here

Post by fallenguru » Sat May 23, 2020 11:10 am

5.9 is still broken for me ...

Any ideas?

Code: Select all

$ wine --version
wine-5.9
$ wineboot
wine: created the configuration directory '/home/chris/local/fatamorgana/pfx'
002c:err:module:__wine_process_init failed to load L"C:\\windows\\system32\\wineboot.exe", error c0000018
0024:err:environ:run_wineboot failed to start wineboot c0000018
0034:err:module:__wine_process_init failed to load L"C:\\windows\\system32\\wineboot.exe", error c0000018
0024:err:wineboot:main failed to restart 64-bit L"C:\\windows\\system32\\wineboot.exe", err 487

codyf86
Newbie
Newbie
Posts: 3
Joined: Sat May 23, 2020 2:41 pm

Re: FYI: update 5.7 to 5.8 (staging) broke fresh prefixes on Ubuntu 19.10 (eoan) here

Post by codyf86 » Sat May 23, 2020 2:43 pm

Aye, wine-devel 5.9 and wine-staging 5.8 are still broken with the same error message on ubuntu 20.04 Focal.

wine 5.7 works though.

NomisGnos
Newbie
Newbie
Posts: 3
Joined: Sun May 17, 2020 10:28 pm

Re: FYI: update 5.7 to 5.8 (staging) broke fresh prefixes on Ubuntu 19.10 (eoan) here

Post by NomisGnos » Sat May 23, 2020 10:53 pm

Yup 5.9 still gives out the same error.

lemonzest
Newbie
Newbie
Posts: 3
Joined: Sun May 10, 2020 12:49 pm

Re: FYI: update 5.7 to 5.8 (staging) broke fresh prefixes on Ubuntu 19.10 (eoan) here

Post by lemonzest » Sun May 24, 2020 9:06 am

Same issue with Wine-Staging 5.9 here on Fedora 32, I can't make a 64bit prefix but I noticed I can create 32bit ones

wine: created the configuration directory '/home/lemonzest/.wine'
002c:err:module:__wine_process_init failed to load L"C:\\windows\\system32\\wineboot.exe", error c0000018
0024:err:environ:run_wineboot failed to start wineboot c0000018
0024:fixme:winediag:start_process Wine Staging 5.9 is a testing version containing experimental patches.
0024:fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq.org.
0034:err:module:__wine_process_init failed to load L"C:\\windows\\system32\\wineboot.exe", error c0000018
0024:err:wineboot:main failed to restart 64-bit L"C:\\windows\\system32\\wineboot.exe", err 487
003c:err:module:__wine_process_init failed to load L"C:\\windows\\system32\\explorer.exe", error c0000018

codyf86
Newbie
Newbie
Posts: 3
Joined: Sat May 23, 2020 2:41 pm

Re: FYI: update 5.7 to 5.8 (staging) broke fresh prefixes on Ubuntu 19.10 (eoan) here

Post by codyf86 » Sun May 24, 2020 11:20 am

An update, the same error occurs in the 5.9 staging that was just released in the repo.

codyf86
Newbie
Newbie
Posts: 3
Joined: Sat May 23, 2020 2:41 pm

Re: FYI: update 5.7 to 5.8 (staging) broke fresh prefixes on Ubuntu 19.10 (eoan) here

Post by codyf86 » Sun May 24, 2020 11:27 am

Sorry for the 3 posts in a row but it appears the actual files in .wine aren't being populated properly. You can install wine-staging 5.7 run winecfg to create your prefix then upgrade to 5.9 staging and it works fine.

If you create a prefix with 5.8/5.9 there are basically 0 files in the windows etc directory, so if you have a correctly populated prefix then it works fine.

Post Reply