ISN AutoIt Studio doesn't work - FolderImpl_GetDetailsOf problem

Questions about Wine on Linux
Post Reply
tomaskir
Level 1
Level 1
Posts: 9
Joined: Tue Jul 02, 2019 4:38 pm

ISN AutoIt Studio doesn't work - FolderImpl_GetDetailsOf problem

Post by tomaskir » Wed Jan 15, 2020 4:56 pm

Greetings,

I am attempting to run "ISN AutoIt Studio" under Wine5.
It crashes during startup.

Code: Select all

[me@pc ISN AutoIt Studio]$ ./Autoit_Studio.exe 

000b:fixme:winediag:start_process Wine Staging 5.0-rc2 is a testing version containing experimental patches.
000b:fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq.org.
0009:fixme:ver:GetCurrentPackageId (0xaefc1c (nil)): stub
0009:err:winediag:MIDIMAP_drvOpen No software synthesizer midi port found, Midi sound output probably won't work.
0009:fixme:gstreamer:source_query_accept (0x5be8e88) stub
0009:fixme:shell:FolderImpl_GetDetailsOf (0x5bd95b0,0xaeea40 {VT_DISPATCH: 0x5bd99b0},-1,0xaeebb0)

-- ISN crashes here --
Running ISN in debug mode shows the following error:

Code: Select all

The requested action with this object has failed.:

Local $sRaw = $oShellDir.GetDetailsOf($oShellDirFile, -1)
Local $sRaw = $oShellDir^ ERROR
After a bit of investigation, I would guess FolderImpl_GetDetailsOf doesn't support "iColumn" of "-1" in Wine (as suggested by the fixme in console):
https://docs.microsoft.com/en-us/window ... tdetailsof

AutoIt requires this in it's built-in Sound.au3 library.
From the above fragment we can see "$oShellDir.GetDetailsOf($oShellDirFile, -1)" is called, and "The requested action with this object has failed" is received.

It's likely this makes any AutoIt script / application using the native Sound.au3 library non-functional.
Is there anything I can do to make this work, or work around this?

tomaskir
Level 1
Level 1
Posts: 9
Joined: Tue Jul 02, 2019 4:38 pm

Re: ISN AutoIt Studio doesn't work - FolderImpl_GetDetailsOf problem

Post by tomaskir » Mon Jan 20, 2020 2:33 pm

Any chance for a comment on this?

If there is any chance, I would really like to avoid running a Windows VM for ISN.

Thanks in advance!

spoon0042
Level 4
Level 4
Posts: 184
Joined: Thu Dec 24, 2009 11:00 am

Re: ISN AutoIt Studio doesn't work - FolderImpl_GetDetailsOf problem

Post by spoon0042 » Tue Jan 21, 2020 12:00 pm

You're on the right track, the function isn't implemented at all and returns as such. If you're feeling up to it you can file a bug.

tomaskir
Level 1
Level 1
Posts: 9
Joined: Tue Jul 02, 2019 4:38 pm

Re: ISN AutoIt Studio doesn't work - FolderImpl_GetDetailsOf problem

Post by tomaskir » Tue Jan 21, 2020 6:43 pm

Thanks for confirming my suspicions, bug created here:
https://bugs.winehq.org/show_bug.cgi?id=48493

Post Reply