FYI: Database Error: Field 'testedVersion' doesn't have a default value

Post issues, bugs, and feature requests about the various WineHQ websites to this forum.
Post Reply
Announcer6431
Newbie
Newbie
Posts: 1
Joined: Mon Sep 30, 2019 8:21 am

FYI: Database Error: Field 'testedVersion' doesn't have a default value

Post by Announcer6431 » Mon Sep 30, 2019 8:34 am

I think no one can submit any applications due to this error.

Summary: Cannot submit due to error:

error details:
Error Message: Database Error: Field 'testedVersion' doesn't have a default value Comment:

File: query.php:149

---

Generally this treasure of a site needs some work.

1. The process of submitting an app is slightly infuriating. It might have to do with being a very web 1.0 type process without live validation, including old-school error messages on a different location than the actual input that triggered the error, only shown after a submit, requiring you to press back, requiring your browser to submit some cached form, causing an old version of the form to be submitted, causing your latest precious edits to be gone, etc. Also nothing is cached, and if you can't find all the problems with your submission, _nothing_ is saved. Discouraging for (new) people spending an hour testing and trying to submit something, and running out of time/patience, needing to go to work.

2. I cannot use my winehq account on the forum, so I need to create a new separate account.

3. I cannot use the search to see if something was already reported, because I need to "wait 2600 seconds" to use the search.

User avatar
dimesio
Moderator
Moderator
Posts: 12681
Joined: Tue Mar 25, 2008 10:30 pm

Re: FYI: Database Error: Field 'testedVersion' doesn't have a default value

Post by dimesio » Mon Sep 30, 2019 6:41 pm

Announcer6431 wrote:
Mon Sep 30, 2019 8:34 am
I think no one can submit any applications due to this error.

Summary: Cannot submit due to error:

error details:
Error Message: Database Error: Field 'testedVersion' doesn't have a default value Comment:

File: query.php:149
Other people have managed to submit test reports. I don't know how you got that error; what browser were you using, and were you using any browser plugins?

---
1. The process of submitting an app is slightly infuriating. It might have to do with being a very web 1.0 type process without live validation, including old-school error messages on a different location than the actual input that triggered the error,
I agree, it's dated. Patches are welcome. Keep in mind that any change has to be backwards compatible with 10+ years of data.
2. I cannot use my winehq account on the forum, so I need to create a new separate account.
There's a longstanding bug for that, and https://bugs.winehq.org/show_bug.cgi?id=19386#c13 explains why it is never going to be fixed.
3. I cannot use the search to see if something was already reported, because I need to "wait 2600 seconds" to use the search.
Log in to do your search. That delay is part of the forum's flood control; the interval is much shorter for logged in users.

Djamana
Newbie
Newbie
Posts: 1
Joined: Thu Oct 17, 2019 8:05 am

Re: FYI: Database Error: Field 'testedVersion' doesn't have a default value

Post by Djamana » Thu Oct 17, 2019 8:22 am

I can just confirm this error
Image

Here are the post data the were submitted:

Code: Select all

Request URL: https://appdb.winehq.org/objectManager.php?bIsQueue=false&bIsRejected=false&sClass=application_queue&sAction=add&sTitle=Submit+Application
Request Method: POST
Status Code: 500 Internal Server Error
Remote Address: 4.15.184.77:443
Referrer Policy: no-referrer-when-downgrade
Cache-Control: no-store, no-cache, must-revalidate
Connection: close
Content-Length: 6071
Content-Type: text/html; charset=UTF-8
Date: Thu, 17 Oct 2019 13:13:29 GMT
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Pragma: no-cache
Server: Apache/2.4.38 (Debian)
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3
Accept-Encoding: gzip, deflate, br
Accept-Language: de-DE,de;q=0.9,en-US;q=0.8,en;q=0.7
Cache-Control: max-age=0
Connection: keep-alive
Content-Length: 2379
Content-Type: application/x-www-form-urlencoded
Cookie: whq_appdb=a9bi8a9oldms2tmelt468qs9lk;
Host: appdb.winehq.org
Origin: https://appdb.winehq.org
Referer: https://appdb.winehq.org/objectManager.php?bIsQueue=false&bIsRejected=false&sClass=application_queue&sAction=add&sTitle=Submit+Application
Sec-Fetch-Mode: navigate
Sec-Fetch-Site: same-origin
Sec-Fetch-User: ?1
Upgrade-Insecure-Requests: 1
User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.120 Safari/537.36
bIsQueue: false
bIsRejected: false
sClass: application_queue
sAction: add
sTitle: Submit Application
bIsQueue: false
bIsRejected: false
sClass: application_queue
sTitle: Submit Application
sReturnTo: 
iId: 0
iAppId: 
bMainAppForm: true
sAppName: Active@ Undelete
iAppCatId: 10
iAppVendorId: 0
sAppWebpage: http://www.active-undelete.com/
sAppKeywords: datarecovery undelete
shAppDescription: <p>Tool to recovery deleted files and partitions</p>
iMaintainerRequest: 0
sVendorName: LSoft Technologies Inc.
sVendorWebpage: https://www.lsoft.net
iVendorId: 
iVersionId: 
iAppId: 0
sVersionName: 15
sLicense: Demo
shVersionDescription: <p>-</p>
sMaintainerRating: 
sMaintainerRelease: 
sDownloadUrlUrl: https://www.lsoft.net/undelete.aspx
sDownloadUrlDescription: Active@ UNDELETE
sInstalls: Yes
sRuns: Yes
shWhatWorks: <p>Gui and all that stuff</p>
sHasProblems: Yes
shWhatDoesnt: <p>Accessing physical drives fails.<br></p>
sUsedWorkaround: Yes
shWorkarounds: <p>Copy the partition / disk to an image file an open it</p>
shWhatNotTested: <p>Rebuilding RAID-Array</p>
sTestedDate: 2019-10-17 06:53:18
sTestedRelease: 4.17
sTestedRating: Bronze
shComments: <p>In the Terminal&nbsp;console that is running wine&nbsp;you see errors like these:</p>
<pre>
0028:fixme:mountmgr:harddisk_ioctl The DISK_PARTITION_INFO and DISK_DETECTION_INFO structures will not be filled
0030:fixme:ntdll:server_ioctl_file Unsupported ioctl 700a0 (device=7 access=0 func=28 method=0) 
0028:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 4d02c (device=4 access=3 func=40b method=0) 
0028:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 4d02c (device=4 access=3 func=40b method=0) 
0028:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 7c088 (device=7 access=3 func=22 method=0) 
0028:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 4d02c (device=4 access=3 func=40b method=0) 
0028:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 4d02c (device=4 access=3 func=40b method=0) 
0028:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 7c088 (device=7 access=3 func=22 method=0)
...</pre>
sGpuMfr: AMD
sGraphicsDriver: open source
iTestDistributionId: 1697
iVersionId: 0
iTestingId: 
iTestDataId: 
sDistribution: 
sUrl: 
bPreviewVersion: true
sSubmit: Submit
So I hope you can reproduce this error now somehow - and fix it. :D

User avatar
dimesio
Moderator
Moderator
Posts: 12681
Joined: Tue Mar 25, 2008 10:30 pm

Re: FYI: Database Error: Field 'testedVersion' doesn't have a default value

Post by dimesio » Thu Oct 17, 2019 2:51 pm

sAppName: Active@ Undelete
When I checked the new application queue I found five identical submissions of this application from the same person. I processed one and deleted the duplicates, so it is now in the AppDB. https://appdb.winehq.org/objectManager. ... &iId=38347

As to why you got this error, I'll ask the same question as I did of the original poster: what browser are you using, and are you using any browser add-ons?

User avatar
dimesio
Moderator
Moderator
Posts: 12681
Joined: Tue Mar 25, 2008 10:30 pm

Re: FYI: Database Error: Field 'testedVersion' doesn't have a default value

Post by dimesio » Fri Oct 18, 2019 9:57 pm

I was able to reproduce the error and filed a bug. https://bugs.winehq.org/show_bug.cgi?id=47963

Post Reply