wine32 debian buster

Questions about Wine on Linux
Post Reply
Amenos
Newbie
Newbie
Posts: 1
Joined: Fri Sep 13, 2019 4:14 am

wine32 debian buster

Post by Amenos » Fri Sep 13, 2019 4:26 am

Hi all,

i'm trying desperately to install 'winehq-stable' on my fresh debian buster but it failed on wine32.
Following:

Code: Select all

{~} > sudo dpkg --add-architecture i386
{~} > cat /etc/apt/sources.list.d/wine.list 
deb https://dl.winehq.org/wine-builds/debian/ buster main

Code: Select all

{~} > sudo apt install --install-recommends winehq-stable
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 winehq-stable : Dépend: wine-stable (= 4.0.2~buster)
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Code: Select all

{~} > sudo apt install --install-recommends wine-stable
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 wine-stable : Dépend: wine-stable-i386 (= 4.0.2~buster)
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Code: Select all

{~} > sudo apt install --install-recommends wine-stable-i386
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 wine-stable-i386:i386 : Dépend: libglib2.0-0:i386 (>= 2.12.0) mais ne sera pas installé
                         Dépend: libgphoto2-6:i386 (>= 2.5.10) mais ne sera pas installé
                         Dépend: libgstreamer-plugins-base1.0-0:i386 (>= 1.0.0) mais ne sera pas installé
                         Dépend: libgstreamer1.0-0:i386 (>= 1.4.0) mais ne sera pas installé
                         Dépend: libxml2:i386 (>= 2.9.0) mais ne sera pas installé
                         Dépend: libasound2-plugins:i386 mais ne sera pas installé
                         Recommande: libcups2:i386 mais ne sera pas installé
                         Recommande: libgssapi-krb5-2:i386 mais ne sera pas installé
                         Recommande: libkrb5-3:i386 mais ne sera pas installé
                         Recommande: libsane:i386 mais ne sera pas installé ou
                                     libsane1:i386
                         Recommande: libxslt1.1:i386 mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
I have only managed to install the 64bit version:

Code: Select all

{~} > wine --version
it looks like wine32 is missing, you should install it.
as root, please execute "apt-get install wine32"
wine-4.0 (Debian 4.0-2)
How I can install it (wine32) since I need it to be able to launch battle.net with lutris.

Thanks for the help.

jkfloris
Level 6
Level 6
Posts: 655
Joined: Thu Aug 14, 2014 10:10 am

Re: wine32 debian buster

Post by jkfloris » Sat Sep 14, 2019 7:02 am

Did you add any other non-Debian repository?
Could you post the output of the following two commands?

Code: Select all

apt-mark showhold
grep -r ^deb /etc/apt/sources.list*
The 32-bit and 64-bit packages must have the same version number. Probably, you have to find by hand which package the culprit.

Post Reply