WineHQ
Wine Forums

Board index » WineHQ » Wine Help » Linux




 Page 1 of 1 [ 3 posts ] 



 
Author Message
 Post Posted: Wed Apr 17, 2019 5:50 am 
Offline
Newbie
Newbie

Joined: Wed Apr 17, 2019 5:28 am
Posts: 2
I'm trying to install an application (LPStudio Pro) on Mint, but installation fails with an error message that "latest version of" Windows media player is needed. The program is from around 2000, so latest version would probably mean wmp9 or 10, and I tried installing both versions using winetricks. Version 10 installs, but doesn't really run, except once, right after installation, but the installer for LPStudio still closes with the same error message.
Any ideas on what could be the reason for it not detecting wmp?
Is there a way to simulate having a working wmp installation? (The idea here is that wmp shouldn't really be essential for running the application, and it would be good to at least get past installation...)
Where would the installation program check to see if wmp is installed (registry or program files-folder?) and would it be possible to install wmp on another system, like in a virtual machine, and just copy installation folder and registry content into my wine prefix? (Again, just to get past installation.)

Using a clean 32-bit wine prefix, wine 4.0 and Mint 19.1
(Apologies if this has been discussed before, I couldn't find anything that seemed relevant when searching forums and google, and I have big patches of noobism here)


Top 
 Post Posted: Thu Apr 18, 2019 12:47 am 
Offline
Level 3
Level 3

Joined: Sun Jan 17, 2016 4:36 pm
Posts: 83
Location: Eindhoven de gekste!
Hi,

>Where would the installation program check to see if wmp is installed (registry or program files-folder?)

That would be interesting to know, but cannot be said on forehand. What you could try to do is produce a debug log, that might reveal the cause:

WINEDEBUG=+relay,+seh wine name_of_installer.exe &>log

and put the (bzipped2) file "log" somewhere up so we could have a look at it.

Regards


Top 
 Post Posted: Thu Apr 18, 2019 9:03 am 
Offline
Newbie
Newbie

Joined: Wed Apr 17, 2019 5:28 am
Posts: 2
Thank you for replying, I'll try that next week when I have access to the installer!


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 3 posts ] 




Board index » WineHQ » Wine Help » Linux


Who is online

Users browsing this forum: Bob Wya, Google [Bot] and 17 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: