WineHQ
Wine Forums

Board index » WineHQ » Wine Help » Linux




 Page 1 of 1 [ 9 posts ] 



 
Author Message
 Post Posted: Wed Dec 26, 2018 12:38 pm 
Offline
Level 2
Level 2
User avatar

Joined: Tue May 08, 2018 1:18 am
Posts: 12
(as root)

dpkg --add-architecture i386

wget -nc https://dl.winehq.org/wine-builds/winehq.key
(the key gets saved)

apt-key add winehq.key
key 76F1A20FF987672F:
1 signature not checked due to a missing key
OK

added:
deb https://dl.winehq.org/wine-builds/debian/ stretch main
to my /etc/apt/sources.list file

apt update
Hit:1 http://security.debian.org stretch/updates InRelease
Ign:2 http://deb.debian.org/debian stretch InRelease
Hit:3 http://deb.debian.org/debian stretch-updates InRelease
Ign:4 https://dl.winehq.org/wine-builds/debian stretch InRelease
Hit:5 http://deb.debian.org/debian stretch Release
Err:6 https://dl.winehq.org/wine-builds/debian stretch Release
gnutls_handshake() failed: Public key signature verification has failed.
Reading package lists... Done
E: The repository 'https://dl.winehq.org/wine-builds/debian stretch Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

help ?


Top 
 Post Posted: Wed Dec 26, 2018 3:04 pm 
Offline
Moderator
Moderator
User avatar

Joined: Tue Mar 25, 2008 10:30 pm
Posts: 12620
Quote:
Code:
apt-key add winehq.key
key 76F1A20FF987672F:
1 signature not checked due to a missing key
OK


It looks like the winehq.key wasn't added for some reason. When you ran that command, were you in the directory where the key was saved? If not, you would need to use the full path to it.

What are the contents of your /etc/apt/sources.list?


Top 
 Post Posted: Thu Dec 27, 2018 4:11 am 
Offline
Level 2
Level 2
User avatar

Joined: Tue May 08, 2018 1:18 am
Posts: 12
Hey dimesio thanks for your help :)

The gnutls handshake problem was given by spurious packages I had after upgrading from debian 8 to debian 9,
I noticed similar problems with git clone and other ssl/tls related stuff
and did a big cleanup of the system, which fixed the issue.
Sorry for the mess.

This is what I get now:

Code:
root@linux:~# apt install --install-recommends winehq-staging
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 winehq-staging : Depends: wine-staging (= 4.0~rc3~stretch)
E: Unable to correct problems, you have held broken packages.
root@linux:~#


My /etc/apt/sources.list is as follows:

Code:
deb http://deb.debian.org/debian/ stretch main contrib non-free
deb http://security.debian.org/ stretch/updates main contrib non-free
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
deb http://ftp.debian.org/debian stretch-backports main contrib
deb https://dl.winehq.org/wine-builds/debian/ stretch main


I've also tried this:

Code:
root@linux:~# apt install --install-recommends winehq-staging wine-staging wine-staging-i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-staging-i386:i386 : Depends: libavcodec57:i386 (>= 7:3.2.12) but it is not going to be installed or
                                   libavcodec-extra57:i386 (>= 7:3.2.12) but it is not going to be installed
                          Depends: libasound2-plugins:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@linux:~#


Top 
 Post Posted: Thu Dec 27, 2018 8:46 am 
Offline
Moderator
Moderator
User avatar

Joined: Tue Mar 25, 2008 10:30 pm
Posts: 12620
Quote:
Code:
The following packages have unmet dependencies:
 wine-staging-i386:i386 : Depends: libavcodec57:i386 (>= 7:3.2.12) but it is not going to be installed or
                                   libavcodec-extra57:i386 (>= 7:3.2.12) but it is not going to be installed
                          Depends: libasound2-plugins:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

The way to sort out dependency issues is to work your way backwards. Try installing libavcode57:i586 or libavcodec-extra57:i386 to find out why they can't be installed. One possibility is that you have a 64 bit libavcodec package installed that is a different version than the 32 bit packages available. 32 and 64 bit packages have to be the same version.


Top 
 Post Posted: Thu Dec 27, 2018 11:32 am 
Offline
Level 2
Level 2
User avatar

Joined: Tue May 08, 2018 1:18 am
Posts: 12
Thank you again dimesio for your help :)

I've tried several combinations and checked the various versions between amd64 and i386, I don't know how to proceed further:

Code:

root@linux:~# apt install --install-recommends winehq-staging
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 winehq-staging : Depends: wine-staging (= 4.0~rc3~stretch)
E: Unable to correct problems, you have held broken packages.


root@linux:~# apt install --install-recommends winehq-staging wine-staging
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-staging : Depends: wine-staging-i386 (= 4.0~rc3~stretch)
E: Unable to correct problems, you have held broken packages.


root@linux:~# apt install --install-recommends winehq-staging wine-staging wine-staging-i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-staging-i386:i386 : Depends: libavcodec57:i386 (>= 7:3.2.12) but it is not going to be installed or
                                   libavcodec-extra57:i386 (>= 7:3.2.12) but it is not going to be installed
                          Depends: libasound2-plugins:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


root@linux:~# apt-mark showhold
root@linux:~#
(no packages are 'on hold')


root@linux:~# apt install libavcodec57:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libavcodec57:i386 : Depends: libmp3lame0:i386 but it is not going to be installed
                     Depends: libx264-148:i386 but it is not going to be installed
                     Depends: libxvidcore4:i386 (>= 1.2.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


root@linux:~# apt-get install libmp3lame0:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 pulseaudio : Depends: libasound2-plugins but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.


root@linux:~# apt install libx264-148:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  apg cheese-common freepats gimp-data gir1.2-totem-1.0 gnome-control-center-data gstreamer1.0-clutter-3.0 liba52-0.7.4 libamd2 libavahi-ui-gtk3-0 libbabl-0.1-0 libcamd2
  libcapi20-3 libccolamd2 libcholmod3 libcrystalhd3 libdc1394-22 libdca0 libde265-0 libdirectfb-1.2-9 libebur128-1 libfaad2 libflite1 libfluidsynth1 libfolks-telepathy25
  libfreerdp-cache1.1 libfreerdp-codec1.1 libfreerdp-common1.1.0 libfreerdp-core1.1 libfreerdp-crypto1.1 libfreerdp-gdi1.1 libfreerdp-locale1.1 libfreerdp-primitives1.1
  libfreerdp-utils1.1 libgimp2.0 libgtk-vnc-2.0-0 libgvnc-1.0-0 libkate1 liblilv-0-0 libmad0 libmetis5 libmjpegutils-2.1-0 libmms0 libmpcdec6 libmpeg2-4
  libmpeg2encpp-2.1-0 libmplex2-2.1-0 libnss-myhostname libofa0 libopenmpt0 libpgm-5.2-0 libphodav-2.0-0 libphodav-2.0-common libsbc1 libserd-0-0 libsidplay1v5 libsodium18
  libsord-0-0 libspandsp2 libsratom-0-0 libsrtp0 libssh-gcrypt-4 libswresample2 libtotem0 libumfpack5 libusbredirhost1 libvo-aacenc0 libvorbisidec1
  libwebrtc-audio-processing1 libwildmidi-config libwildmidi2 libwinpr-crt0.1 libwinpr-crypto0.1 libwinpr-dsparse0.1 libwinpr-environment0.1 libwinpr-file0.1
  libwinpr-handle0.1 libwinpr-heap0.1 libwinpr-input0.1 libwinpr-interlocked0.1 libwinpr-library0.1 libwinpr-path0.1 libwinpr-pool0.1 libwinpr-registry0.1 libwinpr-rpc0.1
  libwinpr-sspi0.1 libwinpr-synch0.1 libwinpr-sysinfo0.1 libwinpr-thread0.1 libwinpr-utils0.1 libx265-95 libzbar0 libzmq5 mousetweaks rtkit
  spice-client-glib-usb-acl-helper totem-common
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  cheese gimp gnome gnome-contacts gnome-control-center gnome-core gnome-video-effects gstreamer1.0-libav gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly
  libasound2-plugins libavcodec57 libavfilter6 libavformat57 libcanberra-pulse libcheese-gtk25 libcheese8 libchromaprint1 libgegl-0.3-0 libopencv-calib3d-dev
  libopencv-calib3d2.4v5 libopencv-features2d-dev libopencv-features2d2.4v5 libopencv-gpu-dev libopencv-gpu2.4v5 libopencv-highgui2.4-deb0 libopencv-legacy2.4v5
  libopencv-objdetect2.4v5 libopencv-ts-dev libopencv-ts2.4v5 libspice-client-glib-2.0-8 libspice-client-gtk-3.0-5 libx264-148 libx264-dev mplayer pulseaudio
  pulseaudio-module-bluetooth totem totem-plugins vinagre wine-staging-amd64
The following NEW packages will be installed:
  libx264-148:i386
0 upgraded, 1 newly installed, 41 to remove and 0 not upgraded.
Need to get 904 kB of archives.
After this operation, 328 MB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.

(i'm aborting because it wants to remove gnome :) )





root@linux:~# aptitude install winehq-staging
The following NEW packages will be installed:
  glib-networking:i386{a} gstreamer1.0-plugins-base:i386{a} libasound2-plugins:i386{a} libatk-bridge2.0-0:i386{a} libatspi2.0-0:i386{a} libavcodec57:i386{a}
  libavresample3:i386{a} libavutil55:i386{a} libcairo-gobject2:i386{a} libcapi20-3:i386{a} libcdparanoia0:i386{a} libcolord2:i386{a} libcrystalhd3:i386{a}
  libdb5.3:i386{a} libepoxy0:i386{a} libexif12:i386{a} libgd3:i386{a} libglu1-mesa:i386{a} libgomp1:i386{a} libgphoto2-6:i386{a} libgphoto2-port12:i386{a}
  libgsm1:i386{a} libgstreamer-plugins-base1.0-0:i386{a} libgstreamer1.0-0:i386{a} libgtk-3-0:i386{a} libicu57:i386{a} libieee1284-3:i386{a} libjack-jackd2-0:i386{a}
  libjson-glib-1.0-0:i386{a} liblcms2-2:i386{a} libldap-2.4-2:i386{a} libltdl7:i386{a} libmp3lame0:i386{ab} libmpg123-0:i386{a} libnuma1:i386{a} libodbc1:i386{a}
  libopenal1:i386{a} libopenjp2-7:i386{a} libopus0:i386{a} liborc-0.4-0:i386{a} libpcap0.8:i386{a} libproxy1v5:i386{a} librest-0.7-0:i386{a} libsamplerate0:i386{a}
  libsane:i386{a} libsane-extras:i386{a} libsasl2-2:i386{a} libsasl2-modules:i386{a} libsasl2-modules-db:i386{a} libshine3:i386{a} libsnappy1v5:i386{a}
  libsoup-gnome2.4-1:i386{a} libsoup2.4-1:i386{a} libsoxr0:i386{a} libspeex1:i386{a} libspeexdsp1:i386{a} libsqlite3-0:i386{a} libssl1.1:i386{a} libswresample2:i386{a}
  libtheora0:i386{a} libtwolame0:i386{a} libv4l-0:i386{a} libv4lconvert0:i386{a} libva-drm1:i386{a} libva-x11-1:i386{a} libva1:i386{a} libvisual-0.4-0:i386{a}
  libvpx4:i386{a} libwavpack1:i386{a} libwebp6:i386{a} libwebpmux2:i386{a} libx264-148:i386{ab} libx265-95:i386{a} libxml2:i386{a} libxpm4:i386{a} libxslt1.1:i386{a}
  libxvidcore4:i386{ab} libzvbi0:i386{a} ocl-icd-libopencl1:i386{a} wine-staging{a} wine-staging-i386:i386{a} winehq-staging
0 packages upgraded, 82 newly installed, 0 to remove and 0 not upgraded.
Need to get 64.9 MB of archives. After unpacking 352 MB will be used.
The following packages have unmet dependencies:
 libmp3lame0 : Breaks: libmp3lame0:i386 (!= 1:3.99.5-dmo4) but 3.99.5+repack1-9+b2 is to be installed
 libmp3lame0:i386 : Breaks: libmp3lame0 (!= 3.99.5+repack1-9+b2) but 1:3.99.5-dmo4 is installed
 libx264-148 : Breaks: libx264-148:i386 (!= 3:0.148.2762+git90a61ec-dmo1~bpo8+1) but 2:0.148.2748+git97eaef2-1 is to be installed
 libx264-148:i386 : Breaks: libx264-148 (!= 2:0.148.2748+git97eaef2-1) but 3:0.148.2762+git90a61ec-dmo1~bpo8+1 is installed
 libxvidcore4 : Breaks: libxvidcore4:i386 (!= 3:1.3.3-dmo1) but 2:1.3.4-1+b2 is to be installed
 libxvidcore4:i386 : Breaks: libxvidcore4 (!= 2:1.3.4-1+b2) but 3:1.3.3-dmo1 is installed
The following actions will resolve these dependencies:

      Remove the following packages:                                                                                                                                         
1)      cheese [3.22.1-1+b1 (now, stable)]                                                                                                                                   
2)      gimp [2.8.18-1+deb9u1 (now, stable)]                                                                                                                                 
3)      gnome [1:3.22+3 (now, stable)]                                                                                                                                       
4)      gnome-contacts [3.22.1-1+b2 (now, stable)]                                                                                                                           
5)      gnome-control-center [1:3.22.2-3 (now, stable)]                                                                                                                     
6)      gnome-core [1:3.22+3 (now, stable)]                                                                                                                                 
7)      gnome-video-effects [0.4.1-3 (now, stable)]                                                                                                                         
8)      gstreamer1.0-libav [1.10.4-1 (now, stable)]                                                                                                                         
9)      gstreamer1.0-plugins-bad [1.10.4-1 (now, stable)]                                                                                                                   
10)     gstreamer1.0-plugins-ugly [1.10.4-1 (now, stable)]                                                                                                                   
11)     libasound2-plugins [1.1.1-1 (now, stable)]                                                                                                                           
12)     libavcodec57 [7:3.2.12-1~deb9u1 (now, stable)]                                                                                                                       
13)     libavfilter6 [7:3.2.12-1~deb9u1 (now, stable)]                                                                                                                       
14)     libavformat57 [7:3.2.12-1~deb9u1 (now, stable)]                                                                                                                     
15)     libcheese-gtk25 [3.22.1-1+b1 (now, stable)]                                                                                                                         
16)     libcheese8 [3.22.1-1+b1 (now, stable)]                                                                                                                               
17)     libchromaprint1 [1.4.2-1 (now, stable)]                                                                                                                             
18)     libgegl-0.3-0 [0.3.8-4 (now, stable)]                                                                                                                               
19)     libmp3lame-dev [1:3.99.5-dmo4 (now)]                                                                                                                                 
20)     libmp3lame0 [1:3.99.5-dmo4 (now)]                                                                                                                                   
21)     libopencv-calib3d-dev [2.4.9.1+dfsg1-2 (now, stable)]                                                                                                               
22)     libopencv-calib3d2.4v5 [2.4.9.1+dfsg1-2 (now, stable)]                                                                                                               
23)     libopencv-features2d-dev [2.4.9.1+dfsg1-2 (now, stable)]                                                                                                             
24)     libopencv-features2d2.4v5 [2.4.9.1+dfsg1-2 (now, stable)]                                                                                                           
25)     libopencv-gpu-dev [2.4.9.1+dfsg1-2 (now, stable)]                                                                                                                   
26)     libopencv-gpu2.4v5 [2.4.9.1+dfsg1-2 (now, stable)]                                                                                                                   
27)     libopencv-highgui2.4-deb0 [2.4.9.1+dfsg1-2 (now, stable)]                                                                                                           
28)     libopencv-legacy2.4v5 [2.4.9.1+dfsg1-2 (now, stable)]                                                                                                               
29)     libopencv-objdetect2.4v5 [2.4.9.1+dfsg1-2 (now, stable)]                                                                                                             
30)     libopencv-ts-dev [2.4.9.1+dfsg1-2 (now, stable)]                                                                                                                     
31)     libopencv-ts2.4v5 [2.4.9.1+dfsg1-2 (now, stable)]                                                                                                                   
32)     libspice-client-glib-2.0-8 [0.33-3.3+deb9u1 (now, stable)]                                                                                                           
33)     libspice-client-gtk-3.0-5 [0.33-3.3+deb9u1 (now, stable)]                                                                                                           
34)     libx264-148 [3:0.148.2762+git90a61ec-dmo1~bpo8+1 (now)]                                                                                                             
35)     libx264-dev [3:0.148.2762+git90a61ec-dmo1~bpo8+1 (now)]                                                                                                             
36)     libxvidcore4 [3:1.3.3-dmo1 (now)]                                                                                                                                   
37)     mplayer [2:1.3.0-6 (now, stable)]                                                                                                                                   
38)     pulseaudio [10.0-1+deb9u1 (now, stable)]                                                                                                                             
39)     pulseaudio-utils [10.0-1+deb9u1 (now, stable)]                                                                                                                       
40)     rtkit [0.11-4+b1 (now, stable)]                                                                                                                                     
41)     totem [3.22.1-1 (now, stable)]                                                                                                                                       
42)     totem-plugins [3.22.1-1 (now, stable)]                                                                                                                               
43)     vinagre [3.22.0-1+b1 (now, stable)]                                                                                                                                 
44)     wine-staging-amd64 [4.0~rc3~stretch (now, stable)]                                                                                                                   

      Install the following packages:                                                                                                                                       
45)     libpulsedsp:i386 [10.0-1+deb9u1 (stable)]                                                                                                                           
46)     libtdb1:i386 [1.3.11-2 (stable)]                                                                                                                                     
47)     libwebrtc-audio-processing1:i386 [0.3-1 (stable)]                                                                                                                   
48)     pulseaudio:i386 [10.0-1+deb9u1 (stable)]                                                                                                                             
49)     pulseaudio-utils:i386 [10.0-1+deb9u1 (stable)]                                                                                                                       
50)     rtkit:i386 [0.11-4+b1 (stable)]                                                                                                                                     
51)     wine-staging:i386 [4.0~rc3~stretch (stable)]                                                                                                                         

      Keep the following packages at their current version:                                                                                                                 
52)     wine-staging [Not Installed]                                                                                                                                         

      Leave the following dependencies unresolved:                                                                                                                           
53)     libbrasero-media3-1 recommends gstreamer1.0-plugins-ugly                                                                                                             
54)     gimp-data recommends gimp                                                                                                                                           
55)     gnome-bluetooth recommends gnome-control-center                                                                                                                     
56)     gnome-online-accounts recommends gnome-control-center (>= 3.6.1)                                                                                                     
57)     gnome-shell recommends gnome-contacts                                                                                                                               
58)     gnome-shell recommends gnome-control-center                                                                                                                         
59)     mousetweaks recommends gnome-control-center                                                                                                                         
60)     rhythmbox recommends gstreamer1.0-plugins-ugly                                                                                                                       
61)     rygel recommends gstreamer1.0-libav                                                                                                                                 
62)     rygel recommends gstreamer1.0-plugins-ugly                                                                                                                           
63)     totem recommends gstreamer1.0-libav                                                                                                                                 
64)     totem recommends gstreamer1.0-plugins-ugly                                                                                                                           
65)     firefox-esr recommends libavcodec58 | libavcodec-extra58 | libavcodec57 | libavcodec-extra57 | libavcodec56 | libavcodec-extra56 | libavcodec55 | libavcodec-extra55
66)     youtube-dl recommends mpv | mplayer                                                                                                                                 



Accept this solution? [Y/n/q/?] q
Abandoning all efforts to resolve these dependencies.
Abort.

(i'm quitting because aptitute suggests to remove gnome :) )




No idea how to proceed further, if you want I can try to remove gnome and let aptitute do its magic (I can then use xfce4),
I've also removed stretch-backports from my sources.list (and apt update) but same result.

Thank you :)


Top 
 Post Posted: Thu Dec 27, 2018 12:07 pm 
Offline
Level 2
Level 2
User avatar

Joined: Tue May 08, 2018 1:18 am
Posts: 12
Progress! I've manually downloaded and installed packages from packages.debian.org
and was able to install winehq-staging :)

For some reason apt-get, apt and aptitute weren't able to fetch the newer packages ..

Thank you again dimesio for your pointers !


Top 
 Post Posted: Thu Dec 27, 2018 3:50 pm 
Offline
Level 2
Level 2
User avatar

Joined: Tue May 08, 2018 1:18 am
Posts: 12
btw do you know if vulkan/dxvk will work with wine-staging on debian 9 stretch ?


Top 
 Post Posted: Fri Dec 28, 2018 12:42 pm 
Offline
Level 6
Level 6

Joined: Thu Aug 14, 2014 10:10 am
Posts: 512
Quote:
For some reason apt-get, apt and aptitute weren't able to fetch the newer packages ..

There are packages from the "deb multimedia" repository on your system. Often these packages works like a charm, but they are unsupported by Debian, because sometimes they will break things.
Quote:
btw do you know if vulkan/dxvk will work with wine-staging on debian 9 stretch ?

If your GPU supports vulkan, it will work.


Top 
 Post Posted: Fri Dec 28, 2018 6:32 pm 
Offline
Level 4
Level 4

Joined: Thu Dec 24, 2009 11:00 am
Posts: 169
jkfloris wrote:
Quote:
For some reason apt-get, apt and aptitute weren't able to fetch the newer packages ..

There are packages from the "deb multimedia" repository on your system. Often these packages works like a charm, but they are unsupported by Debian, because sometimes they will break things.

Perhaps more importantly they apparently installed something manually and didn't add the repo which can really break things. Don't do that. :)


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 9 posts ] 




Board index » WineHQ » Wine Help » Linux


Who is online

Users browsing this forum: No registered users and 11 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: