WineHQ
Wine Forums

Board index » WineHQ » Wine Help » Linux




 Page 1 of 1 [ 6 posts ] 



 
Author Message
 Post Posted: Sat Aug 11, 2018 9:16 pm 
Offline
Level 1
Level 1

Joined: Tue May 08, 2018 10:52 am
Posts: 7
So I have a music collection that came from various places (East Asian, Indian, those European languages with accents and etc). The filenames are in the original language/character set.

When I launch an app like foobar2000, I can see squares that are used instead of the Japanese characters for the artist I'm looking at.

Any ideas on how to fix this?

As a test, I tried:

1. sudo apt install language-pack-ja* language-pack-gnome*ja*
2. changing Windows version to Windows10 in winecfg

and I still get the same issue in foobar2000.

Thanks


Top 
 Post Posted: Sun Aug 12, 2018 6:55 am 
Offline
Moderator
Moderator
User avatar

Joined: Tue Mar 25, 2008 10:30 pm
Posts: 12362
Start the app with the appropriate LANG variable. There are some examples on https://wiki.winehq.org/Testing_Languages.


Top 
 Post Posted: Sun Aug 12, 2018 8:18 am 
Offline
Level 1
Level 1

Joined: Tue May 08, 2018 10:52 am
Posts: 7
echo $LANG gives me en_US.UTF-8

so I tried:

LANG=en_US.UTF-8 wine ~/.wine/drive_c/Program\ Files\ \(x86\)/foobar2000/foobar2000.exe

LANG=en_US wine ~/.wine/drive_c/Program\ Files\ \(x86\)/foobar2000/foobar2000.exe

and this didn't solve my issue.


Top 
 Post Posted: Sun Aug 12, 2018 8:48 am 
Offline
Level 6
Level 6
User avatar

Joined: Tue Nov 22, 2016 5:39 pm
Posts: 551
Of course setting the variable to what is was before wouldn't help...

Did you try setting it to "ja_JP.UTF-8"?


Top 
 Post Posted: Sun Aug 12, 2018 9:31 am 
Offline
Level 1
Level 1

Joined: Tue May 08, 2018 10:52 am
Posts: 7
DarkShadow44 wrote:
Of course setting the variable to what is was before wouldn't help...

Did you try setting it to "ja_JP.UTF-8"?


That worked but now I can't read/understand foobar2000 since the app interface is entirely in Japanese. I'm guessing this doesn't really solve my issue since I have files (music files) that uses various character sets (Chinese, Thai, Korean and etc)

seems using LANG as "workaround" is not the ideal solution considering other apps (music tag editors) behaves differently when this is set to something other than English.

Would be nice to get the normal Windows behavior without messing around with locales and etc.


Top 
 Post Posted: Sun Aug 12, 2018 1:01 pm 
Offline
Moderator
Moderator
User avatar

Joined: Tue Mar 25, 2008 10:30 pm
Posts: 12362
Try installing fonts with the needed characters to the wineprefix. Winetricks has several options for CJK fonts.


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 6 posts ] 




Board index » WineHQ » Wine Help » Linux


Who is online

Users browsing this forum: Google [Bot] and 11 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: