WineHQ
Wine Forums

Board index » WineHQ » Wine Help » Linux




 Page 1 of 1 [ 9 posts ] 



 
Author Message
 Post Posted: Thu May 17, 2018 9:50 am 
Offline
Level 1
Level 1
User avatar

Joined: Tue Feb 06, 2018 11:13 pm
Posts: 9
system: Archlinux
wine: 3.8

Upgrade wine from 3.7 to 3.8, the installed application not work:

[8:331:0517/222955:3500841:INFO:move_user_data.cpp(407)] satrt qq: C:\Program Files\Tencent\TIM\Bin\TIM.exe
014f:err:module:attach_dlls "gdi32.dll" failed to initialize, aborting
014f:err:module:attach_dlls Initializing dlls for L"C:\\Program Files\\Tencent\\TIM\\Bin\\TIM.exe" failed, status c0000005

Looks like "gdi32.dll" failed to initialize, how to fix it? Thank you.

More logs:

003d:err:module:import_dll Library ntoskrnl.exe (which is needed by L"C:\\windows\\system32\\winedevice.exe") not found
003d:err:module:attach_dlls Importing dlls for L"C:\\windows\\system32\\winedevice.exe" failed, status c0000135
0016:err:service:process_send_command service protocol error - failed to write pipe!
003f:err:module:import_dll Library ntoskrnl.exe (which is needed by L"C:\\windows\\system32\\winedevice.exe") not found
003f:err:module:attach_dlls Importing dlls for L"C:\\windows\\system32\\winedevice.exe" failed, status c0000135
0017:err:service:process_send_command service protocol error - failed to write pipe!


Top 
 Post Posted: Thu May 17, 2018 10:27 am 
Online
Level 12
Level 12
User avatar

Joined: Sat Oct 16, 2010 7:40 pm
Posts: 2066
Location: Cambridge
@CountStarlight

Please use the forum Code:
Code:
I AM CODE
tags for terminal output and logs, in future.

Obvious first test would be to downgrade your wine package to version 3.7.
Then re-test your application.

Bob


Top 
 Post Posted: Thu May 17, 2018 2:52 pm 
Offline
Level 5
Level 5
User avatar

Joined: Tue Nov 22, 2016 5:39 pm
Posts: 386
Looks like a broken installation or a broken WINEPREFIX to me.


Top 
 Post Posted: Fri May 18, 2018 5:36 am 
Offline
Level 1
Level 1
User avatar

Joined: Tue Feb 06, 2018 11:13 pm
Posts: 9
Bob Wya wrote:
@CountStarlight

Please use the forum Code:
Code:
I AM CODE
tags for terminal output and logs, in future.

Obvious first test would be to downgrade your wine package to version 3.7.
Then re-test your application.

Bob

Sorry I'm late(I thought the forum would send me an email). After downgrading wine to version 3.7, the application can work, and not see "gdi32" in log:
Code:
0012:err:module:import_dll Library ntoskrnl.exe (which is needed by L"C:\\windows\\system32\\winedevice.exe") not found
0012:err:module:attach_dlls Importing dlls for L"C:\\windows\\system32\\winedevice.exe" failed, status c0000135
000f:err:service:process_send_command service protocol error - failed to write pipe!
000f:fixme:service:scmdatabase_autostart_services Auto-start service L"MountMgr" failed to start: 1053
001b:fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
0021:fixme:advapi:RegisterEventSourceW ((null),L"QPCore"): stub
0021:fixme:advapi:ReportEventW (0xcafe4242,0x0004,0x0000,0x00000000,(nil),0x0001,0x00000000,0x73fc64,(nil)): stub
0021:fixme:advapi:DeregisterEventSource (0xcafe4242) stub
0024:err:module:import_dll Library ntoskrnl.exe (which is needed by L"C:\\windows\\system32\\winedevice.exe") not found
0024:err:module:attach_dlls Importing dlls for L"C:\\windows\\system32\\winedevice.exe" failed, status c0000135
000f:err:service:process_send_command service protocol error - failed to write pipe!
000f:fixme:service:scmdatabase_autostart_services Auto-start service L"QQFrmMgr" failed to start: 1053
0026:err:module:import_dll Library ntoskrnl.exe (which is needed by L"C:\\windows\\system32\\winedevice.exe") not found
0026:err:module:attach_dlls Importing dlls for L"C:\\windows\\system32\\winedevice.exe" failed, status c0000135
000f:err:service:process_send_command service protocol error - failed to write pipe!
000f:fixme:service:scmdatabase_autostart_services Auto-start service L"QQProtect" failed to start: 1053
0028:err:module:import_dll Library ntoskrnl.exe (which is needed by L"C:\\windows\\system32\\winedevice.exe") not found
0028:err:module:attach_dlls Importing dlls for L"C:\\windows\\system32\\winedevice.exe" failed, status c0000135
000f:err:service:process_send_command service protocol error - failed to write pipe!
000f:fixme:service:scmdatabase_autostart_services Auto-start service L"WineBus" failed to start: 1053
0022:fixme:ntdll:NtQueryInformationProcess (process=0xb0) Unimplemented information class: ProcessSessionInformation
002a:err:setupapi:create_dest_file failed to create L"C:\\windows\\system32\\usp10.dll" (error=80)
0032:err:module:import_dll Library ntoskrnl.exe (which is needed by L"C:\\windows\\system32\\winedevice.exe") not found
0032:err:module:attach_dlls Importing dlls for L"C:\\windows\\system32\\winedevice.exe" failed, status c0000135
0017:err:service:process_send_command service protocol error - failed to write pipe!
0034:err:module:import_dll Library ntoskrnl.exe (which is needed by L"C:\\windows\\system32\\winedevice.exe") not found
0034:err:module:attach_dlls Importing dlls for L"C:\\windows\\system32\\winedevice.exe" failed, status c0000135
0016:err:service:process_send_command service protocol error - failed to write pipe!
0022:fixme:process:WTSGetActiveConsoleSessionId stub
0022:fixme:wtsapi:WTSQueryUserToken 1 0x84f38c
0022:fixme:wtsapi:WTSQueryUserToken 1 0x84f38c
0022:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
0035:fixme:iphlpapi:NotifyAddrChange (Handle 0x1d9fed8, overlapped 0x1d9feb8): stub
0035:fixme:iphlpapi:CancelIPChangeNotify (overlapped 0x1d9feb8): stub
0022:fixme:wtsapi:WTSQueryUserToken 1 0x84f468
0022:fixme:wtsapi:WTSQueryUserToken 1 0x84f470
0022:fixme:ntdll:NtQueryInformationToken QueryInformationToken( ..., TokenElevation, ...) semi-stub
0022:err:winediag:gnutls_initialize failed to load libgnutls, no support for encryption
0022:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x84f1e8 1 C) semi-stub
0022:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x84efd8 1 C) semi-stub
003d:err:module:import_dll Library ntoskrnl.exe (which is needed by L"C:\\windows\\system32\\winedevice.exe") not found


Top 
 Post Posted: Fri May 18, 2018 5:47 am 
Offline
Level 1
Level 1
User avatar

Joined: Tue Feb 06, 2018 11:13 pm
Posts: 9
DarkShadow44 wrote:
Looks like a broken installation or a broken WINEPREFIX to me.

I tried to delete ~/.wine and ~/.deepinwine, and reinstalled the application from archlinux AUR https://aur.archlinux.org/packages/deepin-wine-tim/, it still can't work,
~/.deepinwine is a custom WINEPREFIX.
The installation is download the debian package from https://mirrors.ustc.edu.cn/deepin/pool ... 1_i386.deb, unzip this package and make some changes for Archlinux, then repackage it to an Archlinux package. Maybe need additional modifications?


Top 
 Post Posted: Fri May 18, 2018 3:30 pm 
Offline
Level 5
Level 5
User avatar

Joined: Tue Nov 22, 2016 5:39 pm
Posts: 386
Actually, this really is a bug in wine. Sorry, it just seemed like an odd issue, but I can reproduce it with vanilla wine, too.
If you didn't open a bugreport yet, please do. Feel free to put me on CC.
Do you know how to do a regression test?


Top 
 Post Posted: Fri May 18, 2018 8:44 pm 
Offline
Level 1
Level 1
User avatar

Joined: Tue Feb 06, 2018 11:13 pm
Posts: 9
DarkShadow44 wrote:
Actually, this really is a bug in wine. Sorry, it just seemed like an odd issue, but I can reproduce it with vanilla wine, too.
If you didn't open a bugreport yet, please do. Feel free to put me on CC.
Do you know how to do a regression test?

Sorry, I don't know about regression test, and I will try to open a bugreport. Can you give me your contact details(email, telegram...)? In the forum can't timely receive your message, thanks:)


Top 
 Post Posted: Sat May 19, 2018 10:45 am 
Offline
Level 5
Level 5
User avatar

Joined: Tue Nov 22, 2016 5:39 pm
Posts: 386
CountStarlight wrote:
Sorry, I don't know about regression test, and I will try to open a bugreport. Can you give me your contact details(email, telegram...)? In the forum can't timely receive your message, thanks:)

I could do a regression test, too. My mail is "dark DOT shadow{ANTIBOT} AT web DOT de". Just replace "{ANTIBOT}" with 4.


Top 
 Post Posted: Mon May 21, 2018 7:42 pm 
Offline
Level 1
Level 1
User avatar

Joined: Tue Feb 06, 2018 11:13 pm
Posts: 9
Created bug report (bug 45230)https://bugs.winehq.org/show_bug.cgi?id=45230


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 9 posts ] 




Board index » WineHQ » Wine Help » Linux


Who is online

Users browsing this forum: No registered users and 12 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: