Using wine for Peoplesoft Development

Questions about Wine on Linux
Locked
donkeyx
Newbie
Newbie
Posts: 3
Joined: Sun Jul 06, 2008 10:32 pm

Using wine for Peoplesoft Development

Post by donkeyx » Mon Jul 07, 2008 1:35 am

Hey Guys,

I am trying to use Linux as my work development env but having trouble getting wine to run peopletools. I have already made a little progress in the ubuntu forum so if you don't mind having a look that would be greatly appreciated ;)

http://ubuntuforums.org/showthread.php?t=815973

Cheers David

donkeyx
Newbie
Newbie
Posts: 3
Joined: Sun Jul 06, 2008 10:32 pm

update

Post by donkeyx » Mon Jul 07, 2008 9:15 pm

Hey Again,

I have tried placing the error dll "PSCMN.dll" into the path :

/home/don/.wine/drive_c/windows/system32

but still get the error:

don@pluto:~/.wine/drive_c/Program Files/ptools_8.48.5$ wine pside.exe
err:module:attach_process_dlls "PSCMN.dll" failed to initialize, aborting
err:module:LdrInitializeThunk Main exe initialization for L"C:\\Program Files\\ptools_8.48.5\\pside.exe" failed, status c0000005

This dll is actually in the directory that i am running from so i am not sure what is going on?

Thanks in advance

Marcel W. Wysocki

Using wine for Peoplesoft Development

Post by Marcel W. Wysocki » Wed Jul 09, 2008 8:47 am

On Mon, 07 Jul 2008 21:15:40 -0500
"donkeyx" <wineforum-user@winehq.org> wrote:
Hey Again,

I have tried placing the error dll "PSCMN.dll" into the path :

/home/don/.wine/drive_c/windows/system32

but still get the error:

don@pluto:~/.wine/drive_c/Program Files/ptools_8.48.5$ wine pside.exe
err:module:attach_process_dlls "PSCMN.dll" failed to initialize, aborting
err:module:LdrInitializeThunk Main exe initialization for L"C:\\Program Files\\ptools_8.48.5\\pside.exe" failed, status c0000005

This dll is actually in the directory that i am running from so i am not sure what is going on?

Thanks in advance
perhaps try registering the dll

i think the command was sth like regsrv or regsvr32 or sth along the line



--
Marcel W. Wysocki <maci@satgnu.net>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
Url : http://www.winehq.org/pipermail/wine-us ... chment.pgp

donkeyx
Newbie
Newbie
Posts: 3
Joined: Sun Jul 06, 2008 10:32 pm

update on error

Post by donkeyx » Mon Jul 28, 2008 2:31 am

Hey Guys,

Since last time i have upgraded versions of wine and have gotten a new error message :

don@pluto:~/.wine/drive_c/Program Files/ptools_8.48.5$ wine pscfg.exe
don@pluto:~/.wine/drive_c/Program Files/ptools_8.48.5$ wine pscfg.exe
don@pluto:~/.wine/drive_c/Program Files/ptools_8.48.5$ wine pside.exe
8: 1217229693: PSPAL::Abort: PSPAL: OS process initialization failed
8: 1217229693: PSPAL::Abort: Location: e:\pt848-903-R1-retail\peopletools\SRC\pspal\init.cpp:118: PSPAL::Init::Init
8: 1217229693: PSPAL::Abort: PSPAL not initialized. Terminating process now.

This seems closer but still no cake.

baarney
Newbie
Newbie
Posts: 1
Joined: Tue Jan 24, 2012 7:33 pm

Post by baarney » Tue Jan 24, 2012 8:58 pm

Hi,

Using Wine 1.3.37 from Ubuntu PPA repo on Ubuntu 11.04 amd64.

I know this thread is 3 1/2 years old, but I'm having exactly the same problem, and can't find a resolution anywhere else! I'm basically looking for guidance on the best way forward. There's a couple of possibilities here, and I'm happy to put the time in to getting this working, but would obviously prefer to attack the most likely causes first.

PeopleTools 8.52 has a standalone installer package, using InstallAnywhere, which produces a series of "fixme" statements when running, and eventually crashes trying to clean itself up

$ wine cmd /c Client/Disk1/setup.bat
...
fixme:storage:create_storagefile Storage share mode not implemented.
fixme:sxs:cache_QueryAssemblyInfo 0x182ea8, 0x00000002, L"Microsoft.VC90.MFC,version=\"9.0.30729.5570\",publicKeyToken=\"1fc8b3b9a1e18e3b\",processorArchitecture=\"x86\",type=\"win32\"", 0x33f928
fixme:sxs:cache_QueryAssemblyInfo 0x182ea8, 0x00000002, L"policy.9.0.Microsoft.VC90.CRT,version=\"9.0.30729.5570\",publicKeyToken=\"1fc8b3b9a1e18e3b\",processorArchitecture=\"x86\",type=\"win32-policy\"", 0x33f928
fixme:sxs:cache_QueryAssemblyInfo 0x182ea8, 0x00000002, L"Microsoft.VC90.ATL,version=\"9.0.30729.5570\",publicKeyToken=\"1fc8b3b9a1e18e3b\",processorArchitecture=\"x86\",type=\"win32\"", 0x33f928
fixme:sxs:cache_QueryAssemblyInfo 0x182ea8, 0x00000002, L"policy.9.0.Microsoft.VC90.MFCLOC,version=\"9.0.30729.5570\",publicKeyToken=\"1fc8b3b9a1e18e3b\",processorArchitecture=\"x86\",type=\"win32-policy\"", 0x33f928
fixme:sxs:cache_QueryAssemblyInfo 0x182ea8, 0x00000002, L"Microsoft.VC90.CRT,version=\"9.0.30729.5570\",publicKeyToken=\"1fc8b3b9a1e18e3b\",processorArchitecture=\"x86\",type=\"win32\"", 0x33f928
fixme:sxs:cache_QueryAssemblyInfo 0x182ea8, 0x00000002, L"policy.9.0.Microsoft.VC90.MFC,version=\"9.0.30729.5570\",publicKeyToken=\"1fc8b3b9a1e18e3b\",processorArchitecture=\"x86\",type=\"win32-policy\"", 0x33f928
fixme:sxs:cache_QueryAssemblyInfo 0x182ea8, 0x00000002, L"Microsoft.VC90.MFCLOC,version=\"9.0.30729.5570\",publicKeyToken=\"1fc8b3b9a1e18e3b\",processorArchitecture=\"x86\",type=\"win32\"", 0x33f928
fixme:sxs:cache_QueryAssemblyInfo 0x182ea8, 0x00000002, L"policy.9.0.Microsoft.VC90.ATL,version=\"9.0.30729.5570\",publicKeyToken=\"1fc8b3b9a1e18e3b\",processorArchitecture=\"x86\",type=\"win32-policy\"", 0x33f928
...

See http://paste.ubuntu.com/816030/ for full log. Then when running one of the installed programs, I get exactly the same error as the OP:

$ wine C:/PT8.52/bin/client/winx86/pscfg.exe
fixme:ntdll:NtQueryInformationToken QueryInformationToken( ..., TokenSessionId, ...) semi-stub
8: 1327455420: PSPAL::Abort: PSPAL: OS process initialization failed
8: 1327455420: PSPAL::Abort: Location: E:\pt852-903-R1-retail\peopletools\src\pspal\init.cpp:135: PSPAL::Init::Init
8: 1327455420: PSPAL::Abort: PSPAL not initialized. Terminating process now.

Normally, I'd imagine that getting the installation program running with no errors would be the first step, but I'm not sure if that is the problem. If I run the installer and hit Cancel on the first screen, then I get exactly the same errors, apart from the Wine fixme:storage and fixme:sxs messages. So the other errors appear to be with InstallAnywhere, and may not be directly related to the eventual problem running pscfg.exe.

I've had a look at the QueryInformationToken call, but this appears to be related to terminal services sessions, so I would have thought the stub behaviour of returning zero was correct, but don't really know much more about what it's trying to do.

So if anyone has any suggestions on the best way forward with this I'd be grateful.

If anyone want to try this, then the software is freely available, although it is nearly 600MB and you have to have an Oracle account (free):

* Go to http://edelivery.oracle.com and sign in.
* In the Media Pack Search select the following:

Product Pack: PeopleSoft Enterprise
Platform: Linux x86-64

* Scroll down to "PeopleSoft PeopleTools 8.52 Media Pack" and select the link.
* Scroll down to "PeopleSoft PeopleTools 8.52 Client Only" and select Download.
* Unzip the package, and run the installer from there:

$ wine cmd /c Client/Disk1/setup.bat
$ wine Client/Disk1/InstData/setup.exe

When you run the installer it will ask you for a license code. Use this:

zm7ky3-w41m04-4u863q6-7oke1m-s7t1f2

(which is freely available from http://www.oracle.com/us/support/licens ... index.html)

I've tried both the bat and exe versions with the same results. To run the application:

$ wine C:/PT8.52/bin/client/winx86/pscfg.exe

Cheers,

Barney

bilsil
Newbie
Newbie
Posts: 1
Joined: Tue May 15, 2012 4:58 pm

Post by bilsil » Wed May 16, 2012 6:20 am

Just to let you know, this now works with the latest wine source from the git repository. Changes were committed after version 1.5.4, so should be good from 1.5.5. onwards.

Locked