WineHQ
Wine Forums

Board index » WineHQ » Wine Help




 Page 1 of 1 [ 13 posts ] 



 
Author Message
 Post Posted: Fri Jul 30, 2010 10:20 am 
Offline
Level 3
Level 3

Joined: Sun Mar 14, 2010 4:49 am
Posts: 61
Hi,

i have been using EverNote http://appdb.winehq.org/objectManager.php?sClass=application&iId=2566on debian sid x64 with no problems:installation and running was without any problems.

But because of some troubles with my install of debian 64, i changed to Salix 32. But now I can't use EverNote. Install is OK, but when I try to login, its says: Can't connect to server.

I have tried more different installers [3.0, 3.1], but no change, still the same error with connecting to server.

Any idea what could be the problem?

My wine is: 1.2

Thanks!


Top 
 Post Posted: Fri Jul 30, 2010 9:06 pm 
 
whatbug wrote:
Quote:
Hi,

i have been using EverNote http://appdb.winehq.org/objectManager.p ... n&iId=2566 on debian sid x64 with no problems:installation and running was without any problems.

But because of some troubles with my install of debian 64, i changed to Salix 32. But now I can't use EverNote. Install is OK, but when I try to login, its says: Can't connect to server.


Not a Wine problem. Different security packages have different
settings. Have you opened the Linux firewall to allow the connection?

James McKenzie


Top 
 Post Posted: Sat Jul 31, 2010 3:48 am 
Offline
Level 3
Level 3

Joined: Sun Mar 14, 2010 4:49 am
Posts: 61
James McKenzie wrote:
Not a Wine problem. Different security packages have different
settings. Have you opened the Linux firewall to allow the connection?

James McKenzie


thanks,

But there is no firewall in my linux, except of iptables [with no rules]


Top 
 Post Posted: Sat Jul 31, 2010 5:02 am 
 
On Sat, 2010-07-31 at 03:48 -0500, whatbug wrote:
Quote:
James McKenzie wrote:
Quote:
Not a Wine problem. Different security packages have different
settings. Have you opened the Linux firewall to allow the connection?

James McKenzie


thanks,

But there is no firewall in my linux, except of iptables [with no rules]

and....?

Is it enabled?


Martin


Top 
 Post Posted: Sat Jul 31, 2010 8:30 am 
Offline
Level 3
Level 3

Joined: Sun Mar 14, 2010 4:49 am
Posts: 61
sorry, but I do not understand.

Before you asked me wheter I have firewall that could block it. And I asked about it at my distro IRC and they told me that there is no blocking, only if i do some, but I haven't blocked anything.

Anyway this is what I get when i run from console:

Code:
err:wininet:NETCON_secure_connect SSL_connect failed: 12055


i was trying to google it, but i haven't found anything that I could understand.


Top 
 Post Posted: Sat Jul 31, 2010 10:02 pm 
 
"whatbug" <wineforum-user@winehq.org> wrote:

Quote:
But there is no firewall in my linux, except of iptables
[with no rules]
^^^^^^^^^^^^^

This may be at least part of the problem. Some firewalls default
to "block everything" and rules are required if you want to allow
anything.


Top 
 Post Posted: Sun Aug 01, 2010 8:56 am 
Offline
Moderator
Moderator

Joined: Sat Feb 23, 2008 2:29 pm
Posts: 6605
whatbug wrote:
Anyway this is what I get when i run from console:
Code:
err:wininet:NETCON_secure_connect SSL_connect failed: 12055

Post complete output start to end. You might be missing some package.


Top 
 Post subject:
 Post Posted: Sun Aug 01, 2010 9:35 am 
Offline
Level 3
Level 3

Joined: Sun Mar 14, 2010 4:49 am
Posts: 61
this is what i get until the point I try to login:

Code:
conta[Evernote3]$ wine Evernote.exe
fixme:msg:ChangeWindowMessageFilter 4a 00000001
fixme:msg:ChangeWindowMessageFilter c06e 00000001
err:ole:CoGetClassObject class {aac46a37-9229-4fc0-8cce-4497569bf4d1} not registered
err:ole:CoGetClassObject no class object {aac46a37-9229-4fc0-8cce-4497569bf4d1} could be created for context 0x1
fixme:treeview:TREEVIEW_PrintClient Partial Stub: (hdc=0x63f0 options=0x00000014)



and after:
Code:
fixme:wininet:INET_QueryOption INTERNET_OPTION_CONNECTED_STATE: semi-stub
fixme:wininet:InternetAttemptConnect Stub
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT 3600000
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT 1800000
err:wininet:NETCON_secure_connect SSL_connect failed: 12055



Top 
 Post subject:
 Post Posted: Wed Aug 04, 2010 4:17 am 
Offline
Level 3
Level 3

Joined: Sun Mar 14, 2010 4:49 am
Posts: 61
none ideas?


Top 
 Post subject:
 Post Posted: Thu Aug 12, 2010 1:30 pm 
Offline
Level 3
Level 3

Joined: Sun Mar 14, 2010 4:49 am
Posts: 61
hi all,

i think I made small progress with my problem

i did:

Code:
$ sh winetricks wininet


do not ask me why, because I don't know ;]

after this my app act like this:

Code:
wine Evernote.exe
fixme:msg:ChangeWindowMessageFilter 4a 00000001
fixme:msg:ChangeWindowMessageFilter c06e 00000001
err:ole:CoGetClassObject class {aac46a37-9229-4fc0-8cce-4497569bf4d1} not registered
err:ole:CoGetClassObject no class object {aac46a37-9229-4fc0-8cce-4497569bf4d1} could be created for context 0x1
fixme:treeview:TREEVIEW_PrintClient Partial Stub: (hdc=0x63f0 options=0x00000014)
fixme:ras:RasEnumConnectionsA (0x630607a8,0x253e350,0x6305f610),stub!
fixme:ras:RasEnumConnectionsA RAS support is not implemented! Configure program to use LAN connection/winsock instead!
fixme:crypt:CRYPT_RegControl CERT_STORE_CTRL_AUTO_RESYNC: stub
fixme:crypt:CRYPT_RegControl CERT_STORE_CTRL_AUTO_RESYNC: stub
fixme:secur32:schan_InitializeSecurityContextW Using hardcoded "NORMAL" priority
fixme:wintrust:HTTPSCertificateTrust (0x20db090)
fixme:wintrust:HTTPSFinalProv (0x20db090)
fixme:treeview:TREEVIEW_PrintClient Partial Stub: (hdc=0xb224 options=0x00000014)
fixme:treeview:TREEVIEW_PrintClient Partial Stub: (hdc=0xedec options=0x00000014)
fixme:treeview:TREEVIEW_PrintClient Partial Stub: (hdc=0x3084 options=0x00000014)
fixme:treeview:TREEVIEW_PrintClient Partial Stub: (hdc=0x6c6c options=0x00000014)
fixme:treeview:TREEVIEW_PrintClient Partial Stub: (hdc=0xa840 options=0x00000014)
fixme:treeview:TREEVIEW_PrintClient Partial Stub: (hdc=0xe530 options=0x00000014)
fixme:treeview:TREEVIEW_PrintClient Partial Stub: (hdc=0x2894 options=0x00000014)



seems like it is connecting, but after some time app say: Connection timeout.

Please help me, solutions can't be so far away. This app is registered as well working in app database.


Top 
 Post Posted: Thu Aug 12, 2010 9:09 pm 
 
whatbug wrote:
Quote:
hi all,

i think I made small progress with my problem

i did:


Code:
$ sh winetricks wininet



This should have fixed any internet connection problems.
Quote:
Please help me, solutions can't be so far away. This app is registered as well working in app database.


Then look at what others did in the How-To section to get the program to
work.

BTW, if you are on a Mac and the results are for Linux, you are
basically on your own for results.

James McKenzie


Top 
 Post Posted: Sun Aug 15, 2010 9:53 am 
Offline
Level 3
Level 3

Joined: Sun Mar 14, 2010 4:49 am
Posts: 61
James McKenzie wrote:
whatbug wrote:
Quote:
hi all,

i think I made small progress with my problem

i did:


Code:
$ sh winetricks wininet



This should have fixed any internet connection problems.
Quote:
Please help me, solutions can't be so far away. This app is registered as well working in app database.


Then look at what others did in the How-To section to get the program to
work.

BTW, if you are on a Mac and the results are for Linux, you are
basically on your own for results.

James McKenzie


they were not doing anything, all what another users needed to do was install it


Top 
 Post subject:
 Post Posted: Thu Aug 19, 2010 7:23 pm 
Offline
Newbie
Newbie

Joined: Wed Mar 10, 2010 11:37 am
Posts: 3
whatbug wrote:
this is what i get until the point I try to login:

Code:
conta[Evernote3]$ wine Evernote.exe
fixme:msg:ChangeWindowMessageFilter 4a 00000001
fixme:msg:ChangeWindowMessageFilter c06e 00000001
err:ole:CoGetClassObject class {aac46a37-9229-4fc0-8cce-4497569bf4d1} not registered
err:ole:CoGetClassObject no class object {aac46a37-9229-4fc0-8cce-4497569bf4d1} could be created for context 0x1
fixme:treeview:TREEVIEW_PrintClient Partial Stub: (hdc=0x63f0 options=0x00000014)



and after:
Code:
fixme:wininet:INET_QueryOption INTERNET_OPTION_CONNECTED_STATE: semi-stub
fixme:wininet:InternetAttemptConnect Stub
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT 3600000
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT 1800000
err:wininet:NETCON_secure_connect SSL_connect failed: 12055



This looks like OpenSSL (which wininet uses to create SSL/TLS connections) is rejecting the certificate. Please file a bug so we can track this.


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 13 posts ] 




Board index » WineHQ » Wine Help


Who is online

Users browsing this forum: Bing [Bot] and 11 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: