need wine-6.5 (Staging) .deb file (to revert to earlier version of winehq-staging on Ubuntu)

Questions about Wine on Linux
Post Reply
sponsor61
Level 2
Level 2
Posts: 48
Joined: Tue Apr 07, 2020 10:05 pm

need wine-6.5 (Staging) .deb file (to revert to earlier version of winehq-staging on Ubuntu)

Post by sponsor61 » Mon Apr 19, 2021 2:40 pm

I have two flight sims that install only under winehq-staging. (I'm using Ubuntu 20.04). The install works with any version of winehq-staging later than wine-5.24 (Staging). The current winehq-staging, wine-6.6 (Staging) causes the mouse bug
viewtopic.php?f=8&t=35151&p=132585#p132585
which makes the games unplayable. Thus I need to revert to an earlier version of winehq-staging.

I see at
https://wiki.winehq.org/Ubuntu
that I can download winehq .deb packages rather than adding winehq to /etc/apt/sources.lst. Does this mean I can download winehq-staging as a .deb file and keep using that .deb every time I install, even after subsequent versions of winehq-staging have been released? If so, where can I find the winehq-staging deb file for an earlier version of winehq-staging, such as wine-6.5 (Staging).

Thanks.

P.S. I know that winehq-staging is experimental, and thus it's not good practice to depend on it as part of your install. Unfortunately, I have two flight sims (Rowan's Battle of Britain and BMS 4.35.1) which do not install with wine-development, winehq-stable, or winehq-devel, but ONLY with winehq-staging.

spoon0042
Level 6
Level 6
Posts: 519
Joined: Thu Dec 24, 2009 11:00 am

Re: need wine-6.5 (Staging) .deb file (to revert to earlier version of winehq-staging on Ubuntu)

Post by spoon0042 » Mon Apr 19, 2021 6:13 pm

You can poke around in https://dl.winehq.org/wine-builds/ubuntu/dists/ and find the packages, yes. If you install those but don't add the repository nothing should try to replace or upgrade them, if that's what you want. If you're already using the winehq repo it'd be easier to just force apt to install the previous version, for 20.04:

Code: Select all

sudo apt install wine-staging=6.5~focal-1 wine-staging-amd64=6.5~focal-1 wine-staging-i386=6.5~focal-1
(and optionally winehq-staging=6.5~focal-1)
You can then 'hold' the packages to prevent apt from upgrading them until the bug is fixed. (Alternatively, getting ~advanced~ you can copy the wine tree /opt/wine-staging somewhere.)

sponsor61
Level 2
Level 2
Posts: 48
Joined: Tue Apr 07, 2020 10:05 pm

Re: need wine-6.5 (Staging) .deb file (to revert to earlier version of winehq-staging on Ubuntu)

Post by sponsor61 » Tue Apr 27, 2021 2:31 am

I downloaded and installed wine-6.7 (Staging) on Ubuntu 20.04 LTS using .deb files from https://dl.winehq.org/wine-builds/ubuntu/dists/. Now how do I install winetricks?

Thanks

jkfloris
Level 9
Level 9
Posts: 1472
Joined: Thu Aug 14, 2014 10:10 am

Re: need wine-6.5 (Staging) .deb file (to revert to earlier version of winehq-staging on Ubuntu)

Post by jkfloris » Tue Apr 27, 2021 2:50 am

Now how do I install winetricks?
An older version of winetricks is available from the Ubuntu repository.

Code: Select all

sudo apt install winetricks
Use the built-in update tool to update winetricks.

Code: Select all

sudo winetricks --self-update

sponsor61
Level 2
Level 2
Posts: 48
Joined: Tue Apr 07, 2020 10:05 pm

Re: need wine-6.5 (Staging) .deb file (to revert to earlier version of winehq-staging on Ubuntu)

Post by sponsor61 » Tue Apr 27, 2021 3:58 pm

Thanks for the quick reply.

Code: Select all

sudo apt install winetricks
overwrites the symbolic links I made from, e.g., /opt/wine-staging/bin/wine to /usr/bin/wine, reverting the wine version to wine-5.0

I'm assuming the user has access to the default Ubuntu 20.04.2 LTS repositories.

I'm trying to install winetricks such that
1. no change is made to the default /etc/apt/sources.list, and
2. when the user types "wine", wine-6.7 (Staging) executes
3. when the user types "winetricks", a winetricks compatible with wine-6.7 (Staging) executes

I previously installed wine-6.7 (Staging) under a new Ubuntu 20.04.2 LTS install using .deb files with these commands:

Code: Select all

sudo apt install ./wine_6_7_staging_for_Ubuntu_20.04LTS/wine-staging-i386_6.7~focal-1_i386.deb
sudo apt install ./wine_6_7_staging_for_Ubuntu_20.04LTS/wine-staging-amd64_6.7~focal-1_amd64.deb
sudo apt install ./wine_6_7_staging_for_Ubuntu_20.04LTS/wine-staging-bin/wine-staging_6.7~focal-1_amd64.deb
sudo ln -s /opt/wine-staging/bin/msidb /usr/bin/msidb
sudo ln -s /opt/wine-staging/bin/msiexec /usr/bin/msiexec
sudo ln -s /opt/wine-staging/bin/notepad /usr/bin/notepad
sudo ln -s /opt/wine-staging/bin/regedit /usr/bin/regedit
sudo ln -s /opt/wine-staging/bin/regsvr32 /usr/bin/regsvr32
sudo ln -s /opt/wine-staging/bin/widl /usr/bin/widl
sudo ln -s /opt/wine-staging/bin/wine /usr/bin/wine
sudo ln -s /opt/wine-staging/bin/wine64 /usr/bin/wine64
sudo ln -s /opt/wine-staging/bin/wine64-preloader /usr/bin/wine64-preloader
sudo ln -s /opt/wine-staging/bin/wineboot /usr/bin/wineboot
sudo ln -s /opt/wine-staging/bin/winebuild /usr/bin/winebuild
sudo ln -s /opt/wine-staging/bin/winecfg /usr/bin/winecfg
sudo ln -s /opt/wine-staging/bin/wineconsole /usr/bin/wineconsole
sudo ln -s /opt/wine-staging/bin/winecpp /usr/bin/winecpp
sudo ln -s /opt/wine-staging/bin/winedbg /usr/bin/winedbg
sudo ln -s /opt/wine-staging/bin/winedump /usr/bin/winedump
sudo ln -s /opt/wine-staging/bin/winefile /usr/bin/winefile
sudo ln -s /opt/wine-staging/bin/wineg++ /usr/bin/wineg++
sudo ln -s /opt/wine-staging/bin/winegcc /usr/bin/winegcc
sudo ln -s /opt/wine-staging/bin/winemaker /usr/bin/winemaker
sudo ln -s /opt/wine-staging/bin/winemine /usr/bin/winemine
sudo ln -s /opt/wine-staging/bin/winepath /usr/bin/winepath
sudo ln -s /opt/wine-staging/bin/wine-preloader /usr/bin/wine-preloader
sudo ln -s /opt/wine-staging/bin/wineserver /usr/bin/wineserver
sudo ln -s /opt/wine-staging/bin/wmc /usr/bin/wmc
sudo ln -s /opt/wine-staging/bin/wrc /usr/bin/wrc

andrew.smart
Level 2
Level 2
Posts: 33
Joined: Thu Dec 15, 2016 3:08 am

Re: need wine-6.5 (Staging) .deb file (to revert to earlier version of winehq-staging on Ubuntu)

Post by andrew.smart » Tue Apr 27, 2021 6:05 pm

You can put winetricks at ~/bin/

Code: Select all

cd ~/bin/
wget https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks
chmod +x winetricks
I'd suggest using the WINE environmental variable instead of trying all those symbolic links. Point it at whichever wine you want to use, such as /opt/wine-staging/bin/wine or wine built from source. winetricks will use this environmental variable if it is defined. I don't know where I learned about this variable, maybe in the wiki somewhere. Useful when you have multiple versions of wine.

Code: Select all

export WINE=/opt/wine-staging/bin/wine
$WINE wineboot
winetricks
$WINE foobar.exe
$WINE regedit
$WINE msiexec
$WINE winecfg

jkfloris
Level 9
Level 9
Posts: 1472
Joined: Thu Aug 14, 2014 10:10 am

Re: need wine-6.5 (Staging) .deb file (to revert to earlier version of winehq-staging on Ubuntu)

Post by jkfloris » Wed Apr 28, 2021 12:52 pm

Or download and install the winehq-staging package

sponsor61
Level 2
Level 2
Posts: 48
Joined: Tue Apr 07, 2020 10:05 pm

Re: need wine-6.5 (Staging) .deb file (to revert to earlier version of winehq-staging on Ubuntu)

Post by sponsor61 » Wed Apr 28, 2021 1:14 pm

I don't have control over which wine version I get if my install has a dependency on winehq-staging.

I noticed this problem when two of the wine games in esports-for-engineers game suite lost mouse input because the winehq-staging had automatically changed my wine version to wine-6.6 (Staging), which has the mouse input bug.

This is not the fault of winehq-staging, of course, which is intended to be experimental. I need to arrange things so that when a user installs esports-for-engineers they get a version of wine which has been tested with the suite.

Post Reply