iZotope RX 7 Elements crash

Questions about Wine on Linux
Post Reply
forquare
Level 1
Level 1
Posts: 5
Joined: Mon May 04, 2020 11:47 am

iZotope RX 7 Elements crash

Post by forquare » Mon May 04, 2020 1:39 pm

Hello all,

I've recently migrated from an ageing iMac running macOS to Linux. I use Reaper to edit a podcast and back in February (before I knew I would be migrating) purchased iZotope RX 7 Elements at a discount.
RX Elements come in macOS and Windows variants, and I was using the native macOS variant when using macOS. Under Linux I am trying the Windows variant under Wine.

I've installed RX Elements without a problem in a fresh WINEPREFIX, I haven't used winetricks or installed anything else. When I try and run the RX 7 Audio Editor it crashes. I'm also struggling to activate it.

I've not used Windows properly in well over a decade, so I suspect some of my problems reading the output may stem from that.

Problems
  • Unable to activate software
    • Cannot authorise online
      • "An error occurred while contacting the authorization server. Please check your internet connection or clock Offline Authorization if you do not have an internet connection."
      • I closed the window after which in Windows would take me into the application stating I could use it as a demo, but under Wine it crashed - assuming the same crash as below.
      • See failed_online_authorisation.txt.xz for output
    • Cannot authorise offline
      • When trying "Offline Authorization" there is no code to copy into the website
      • I closed the window after which in Windows would take me into the application stating I could use it as a demo, but under Wine it crashed - assuming the same crash as below.
      • See failed_offline_authorisation.txt.xz for output
  • Unable to run (un-authorised) software
    • Run the application and "Continue" rather than "Authorize" -> crashed after pressing "Continue"
    • See crash.txt.xz for output
Environment
  • Ubuntu 20.04 (amd64)
  • Wine version: wine-5.5 (Ubuntu 5.5-3ubuntu1)
Logs
Each log file was generated using the following:

Code: Select all

> WINEDEBUG=warn+all wine .wine/drive_c/Program\ Files\ \(x86\)/iZotope/RX\ 7\ Audio\ Editor/win32/iZotope\ RX\ 7\ Audio\ Editor.exe > Downloads/log_name.txt 2>&1
> xz log_name.txt
Attachments
failed_offline_authorisation.txt.xz
Failed offline authorisation
(7.11 KiB) Downloaded 41 times
failed_online_authorisation.txt.xz
Failed online authorisation
(8.43 KiB) Downloaded 37 times
crash.txt.xz
Crash log
(5.11 KiB) Downloaded 37 times

forquare
Level 1
Level 1
Posts: 5
Joined: Mon May 04, 2020 11:47 am

Re: iZotope RX 7 Elements crash

Post by forquare » Mon May 04, 2020 2:36 pm

An additional piece of information I forgot to add to my OP is a screenshot of the Offline Authentication screen. You can see the textbox that aught to have a code in it is blank. Under Windows this has a UUID style code in it.
Attachments
offline_auth.png

saintjules
Newbie
Newbie
Posts: 2
Joined: Mon May 04, 2020 3:49 pm

Re: iZotope RX 7 Elements crash

Post by saintjules » Mon May 04, 2020 3:53 pm

Hi, I'm interested in this thread becausa I have a very similar problem.
I am using linvst + wine-staging and I'm trying to run Izotope Ozone Imager plugin. Good news for me is that it runs and functions perfectly in any DAW, but I have the same issue with authorization, no matter the method I get an error.
Any help would be appreciated!

jkfloris
Level 9
Level 9
Posts: 1475
Joined: Thu Aug 14, 2014 10:10 am

Re: iZotope RX 7 Elements crash

Post by jkfloris » Tue May 05, 2020 4:31 pm

I get the program running with wine-staging 5.7 and the winetricks tahoma and arial

forquare
Level 1
Level 1
Posts: 5
Joined: Mon May 04, 2020 11:47 am

Re: iZotope RX 7 Elements crash

Post by forquare » Thu May 07, 2020 8:16 am

Excellent, thank you jkfloris!

Wine version: wine-5.7 (Staging)

It seems I'm still unable to do an online authorisation, I get this output in my terminal (no debug on):

Code: Select all

GnuTLS error: The requested data were not available.
002f:err:wininet:HTTP_ParseDateAsAsctime unexpected weekday L"-1"
002f:err:wininet:HTTP_ParseDate unexpected date format L"-1"
GnuTLS error: The requested data were not available.
And the program tells me "The information provided by the authorization server is incorrect. Please contact technical support for assistance". But this is definitely a step in the right direction!

For Offline Authorisation I get a similar message:

Code: Select all

0031:err:wininet:HTTP_ParseDateAsAsctime unexpected weekday L"-1"
0031:err:wininet:HTTP_ParseDate unexpected date format L"-1"
GnuTLS error: The requested data were not available.
GnuTLS error: The requested data were not available.
With that being said, I am able to launch the un-authorised application and use it!.
Attachments
wine-staging_online_auth_fail.txt.xz
Logs for online auth failure.
(8.33 KiB) Downloaded 35 times

saintjules
Newbie
Newbie
Posts: 2
Joined: Mon May 04, 2020 3:49 pm

Re: iZotope RX 7 Elements crash

Post by saintjules » Fri May 08, 2020 2:30 am

forquare wrote:
Thu May 07, 2020 8:16 am
Excellent, thank you jkfloris!

Wine version: wine-5.7 (Staging)

It seems I'm still unable to do an online authorisation, I get this output in my terminal (no debug on):

Code: Select all

GnuTLS error: The requested data were not available.
002f:err:wininet:HTTP_ParseDateAsAsctime unexpected weekday L"-1"
002f:err:wininet:HTTP_ParseDate unexpected date format L"-1"
GnuTLS error: The requested data were not available.
And the program tells me "The information provided by the authorization server is incorrect. Please contact technical support for assistance". But this is definitely a step in the right direction!

For Offline Authorisation I get a similar message:

Code: Select all

0031:err:wininet:HTTP_ParseDateAsAsctime unexpected weekday L"-1"
0031:err:wininet:HTTP_ParseDate unexpected date format L"-1"
GnuTLS error: The requested data were not available.
GnuTLS error: The requested data were not available.
With that being said, I am able to launch the un-authorised application and use it!.
Looks like you are exactly in my situation now. LinVst has an extensive guide on how to troubleshoot common issues but it's not that easy, at least in my basic knowledge of Wine.
Guess there might be dlls to override, but I'm not sure which.

forquare
Level 1
Level 1
Posts: 5
Joined: Mon May 04, 2020 11:47 am

Re: iZotope RX 7 Elements crash

Post by forquare » Fri May 08, 2020 10:55 am

Removed my WINEPREFIX and created a new one using:
WINEARCH=win32 winetricks tahoma arial ie8

Now running through the installer and trying to authorise gets rid of these errors:

Code: Select all

0031:err:wininet:HTTP_ParseDateAsAsctime unexpected weekday L"-1"
0031:err:wininet:HTTP_ParseDate unexpected date format L"-1"
GnuTLS error: The requested data were not available.
GnuTLS error: The requested data were not available.
However it is still failing to authorise online or offline.
Attachments
wine-staging_online_auth_fail.txt.xz
Logs when trying to auth online
(9.99 KiB) Downloaded 37 times

forquare
Level 1
Level 1
Posts: 5
Joined: Mon May 04, 2020 11:47 am

Re: iZotope RX 7 Elements crash

Post by forquare » Fri May 08, 2020 11:56 am

saintjules wrote:
Fri May 08, 2020 2:30 am
Looks like you are exactly in my situation now. LinVst has an extensive guide on how to troubleshoot common issues but it's not that easy, at least in my basic knowledge of Wine.
Guess there might be dlls to override, but I'm not sure which.
Oh cool, I'll take a look when I have some more time :)

urbster1
Newbie
Newbie
Posts: 1
Joined: Fri Aug 14, 2020 9:37 am

Re: iZotope RX 7 Elements crash

Post by urbster1 » Fri Aug 14, 2020 10:31 am

I'm getting the same GnuTLS error trying to authorize Ozone 5 offline. Has anyone made any progress resolving this issue?

Warroza
Newbie
Newbie
Posts: 2
Joined: Sat Apr 17, 2021 11:55 am

Re: iZotope RX 7 Elements crash

Post by Warroza » Sun Apr 18, 2021 2:12 am

I have the same problem with iZotope RX 8 Elements with online and offline authorization on Linux Mint 20.1, Wine-Staging 6,6. Has anyone solve this problem?

Post Reply