Application could not be started

Questions about Wine on Linux
Post Reply
crhiggin
Level 1
Level 1
Posts: 7
Joined: Tue May 05, 2020 4:15 pm

Application could not be started

Post by crhiggin » Tue Mar 30, 2021 6:55 pm

I don't know if this is a script error or a bug. I get this error since 6.5 staging update today 3/30/2021.

Application could not be started, or no application associated with the specified file.
ShellExecuteEx failed: File not found.

wine --version
wine-6.5 (staging)
I get this everytime I try to launch Diablo 3 using the script I have been using for years:
env WINEPREFIX="/home/user/.wine" WINEARCH=win64 wine start /Unix "$DIABLO3/Diablo III.exe" -launch -uid myid@website.com

Using Kubuntu 20.04
cat /etc/issue
Ubuntu 20.04.2 LTS \n \l

dpkg -l|grep wine
ii wine-staging 6.5~focal-1 amd64
ii wine-staging-amd64 6.5~focal-1 amd64
ii wine-staging-i386:i386 6.5~focal-1 i386
ii winehq-staging 6.5~focal-1 amd64

I revert back to wine-6.4 (staging) and the script works.

spoon0042
Level 6
Level 6
Posts: 519
Joined: Thu Dec 24, 2009 11:00 am

Re: Application could not be started

Post by spoon0042 » Tue Mar 30, 2021 9:32 pm

Yeah, something broke in 6.5. Fix is in for 6.6 though.

https://bugs.winehq.org/show_bug.cgi?id=50867

crhiggin
Level 1
Level 1
Posts: 7
Joined: Tue May 05, 2020 4:15 pm

Re: Application could not be started

Post by crhiggin » Wed Mar 31, 2021 2:54 pm

OK thanks. I'll skip 6.5 then.

UrienRaven
Newbie
Newbie
Posts: 2
Joined: Sat Apr 10, 2021 11:33 am

Re: Application could not be started

Post by UrienRaven » Sat Apr 10, 2021 12:16 pm

I have question how to revert back to wine 6.4? I have problem with new version as well it stopped working with icon spinning for a while and then nothing also use Ubuntu 20.04.2 LTS

spoon0042
Level 6
Level 6
Posts: 519
Joined: Thu Dec 24, 2009 11:00 am

Re: Application could not be started

Post by spoon0042 » Mon Apr 12, 2021 1:00 pm

First you should, assuming you haven't already, try 6.6 which released Friday and may or may not fix things.

Failing that you can use apt to install older versions by specifying them like so:

Code: Select all

sudo apt install wine-devel=6.4~focal-1 wine-devel-i386=6.4~focal-1 wine-devel-amd64=6.4~focal-1
(add winehq-devel=6.4~focal-1 if you have that installed) ((and replace 'devel' with 'staging' if that's what you use)) (((if you do an 'apt upgrade' after this it will install the latest version unless you 'hold' the packages, you can look up how to do that)))

Codesound
Level 2
Level 2
Posts: 49
Joined: Sun Sep 01, 2019 7:03 am

Re: Application could not be started

Post by Codesound » Mon Apr 12, 2021 2:44 pm

spoon0042 wrote:
Mon Apr 12, 2021 1:00 pm
First you should, assuming you haven't already, try 6.6 which released Friday and may or may not fix things.

Failing that you can use apt to install older versions by specifying them like so:

Code: Select all

sudo apt install wine-devel=6.4~focal-1 wine-devel-i386=6.4~focal-1 wine-devel-amd64=6.4~focal-1
(add winehq-devel=6.4~focal-1 if you have that installed) ((and replace 'devel' with 'staging' if that's what you use)) (((if you do an 'apt upgrade' after this it will install the latest version unless you 'hold' the packages, you can look up how to do that)))

Linux MINT Cinnamom_x64
Hi,

I have same problems with the last two release of wine-staging: 6.5 AND 6.6. I remember that the wine-staging 6.4 works and I would like to turning back to this version. I write this code:

Code: Select all

sudo apt install wine-staging=6.4~focal-1 wine-staging-i386=6.4~focal-1 wine-staging-amd64=6.4~focal-1
but the response of terminal is:

Code: Select all

codesound@Codesound:~$ sudo apt install wine-staging=6.4~focal-1 wine-staging-i386=6.4~focal-1 wine-staging-amd64=6.4~focal-1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Version '6.4~focal-1' for 'wine-staging' was not found
E: Version '6.4~focal-1' for 'wine-staging-i386:i386' was not found
E: Version '6.4~focal-1' for 'wine-staging-amd64' was not found
what I wrong? Please help me.... I can't install any more software....

THANKS for now....

this is my old 'alert' with wine-staging 6.5
viewtopic.php?f=8&t=35141

spoon0042
Level 6
Level 6
Posts: 519
Joined: Thu Dec 24, 2009 11:00 am

Re: Application could not be started

Post by spoon0042 » Mon Apr 12, 2021 5:03 pm

I think 'focal' is the correct version for your Mint version, did you follow the instructions here to install? -> https://wiki.winehq.org/Ubuntu

In any case you can do a 'apt policy wine-staging | head -20' to check which versions apt knows about.

Codesound
Level 2
Level 2
Posts: 49
Joined: Sun Sep 01, 2019 7:03 am

Re: Application could not be started

Post by Codesound » Tue Apr 13, 2021 10:10 am

spoon0042 wrote:
Mon Apr 12, 2021 5:03 pm
I think 'focal' is the correct version for your Mint version, did you follow the instructions here to install? -> https://wiki.winehq.org/Ubuntu

In any case you can do a 'apt policy wine-staging | head -20' to check which versions apt knows about.
Hi,
Thanks.

the output of the command:

Code: Select all

sudo apt policy wine-staging | head -20
is:

Code: Select all

wine-staging:
  Installed: 6.6~bionic-1
  Candidate: 6.6~bionic-1
  Version table:
 *** 6.6~bionic-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
     6.5~bionic-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu bionic/main amd64 Packages
     6.4~bionic-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu bionic/main amd64 Packages
     6.3~bionic-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu bionic/main amd64 Packages
     6.2~bionic-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu bionic/main amd64 Packages
     6.1~bionic-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu bionic/main amd64 Packages
     6.0.0~bionic-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu bionic/main amd64 Packages
     6.0~rc6~bionic 500
I adapted your "downgrade wine-staging command" to:

Code: Select all

sudo apt install wine-staging=6.4~bionic-1 wine-staging-i386=6.4~bionic-1 wine-staging-amd64=6.4~bionic-1
and works---- but now I have wine 5.0 installed ...

Exists one command that install directly one specific wine-staging version; 6.4 for example?

THANKS AGAIN.....

spoon0042
Level 6
Level 6
Posts: 519
Joined: Thu Dec 24, 2009 11:00 am

Re: Application could not be started

Post by spoon0042 » Tue Apr 13, 2021 12:13 pm

You probably still have your distro's wine 5.0 packages installed. If you want you can remove those and install the winehq-staging=6.4~bionic-1 package to make staging the "default". As it is you'll find it in /opt/wine-staging.

crhiggin
Level 1
Level 1
Posts: 7
Joined: Tue May 05, 2020 4:15 pm

Re: Application could not be started

Post by crhiggin » Tue Apr 27, 2021 5:56 pm

So I skipped 6.5 (staging) then tried 6.6 (staging) but had the same error and had go go back to 6.4 (staging).
Tried 6.7 (staging) today and all is good. I looked through the change log but I have no idea what fixed it.

Thanks again for the great program!!!

Post Reply