Only partial sound

Questions about Wine on macOS.
Post Reply
Posts: 3
Joined: Thu Apr 28, 2011 2:16 pm

Only partial sound

Post by mrhat » Fri Feb 19, 2021 11:54 am


I'm using wine with Porting Kit on macos 11.21 to run City of Lost Haven/Mafia 1. It works fine, however refuses to play any ingame music whatsoever, while 'normal' sounds play without a problem.

Test Run log (err+all,fixme+all,fixme-esync, +coreaudio) has no audio related entries.

I've tried to disable/enable Software Mixing and EAX, no change. Game Log throws no errors. Game files are all present in their right places.

I've tried winetricks dsound and directmusic, no change.

How do I debug this properly? What test run arguments do I use?


Level 6
Level 6
Posts: 594
Joined: Mon Dec 25, 2017 12:11 pm

Re: Only partial sound

Post by Gcenx » Fri Feb 19, 2021 11:09 pm

You should be submitting a ticket from within PortingKit for these issues.

Upstream wine (32Bit) doesn’t support macOS Catalina and later.

Post Reply