Sniper Elite 4

Questions about Wine on Linux
WineChancellor
Level 2
Level 2
Posts: 49
Joined: Sun Nov 14, 2010 8:24 am

Re: Sniper Elite 4

Post by WineChancellor » Mon Jan 28, 2019 8:41 am

@Bob
You might want to try aptitude - since apt is completely hopeless at resolving package dependencies.

Code: Select all

sudo aptitude install vulkan-utils 
The following NEW packages will be installed:
  vulkan-tools{ab} vulkan-utils 
0 packages upgraded, 2 newly installed, 0 to remove and 23 not upgraded.
Need to get 77,4 kB of archives. After unpacking 670 kB will be used.
The following packages have unmet dependencies:
 vulkan-tools : Breaks: vulkan-utils (< 1.1.82.0+dfsg1-1) but 1.1.82.0+dfsg1-0ubuntu0.18.04.1~gpu1 is to be installed
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     vulkan-utils [Not Installed]                       

Accept this solution? [Y/n/q/?] Y 
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 23 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
                                         
lele@lele-All-Series:~$ vulkaninfo

Command 'vulkaninfo' not found, but can be installed with:

sudo apt install vulkan-utils
have you some idea?
Lele

WineChancellor
Level 2
Level 2
Posts: 49
Joined: Sun Nov 14, 2010 8:24 am

Re: Sniper Elite 4

Post by WineChancellor » Wed Jan 30, 2019 4:15 am

@Bob

hi i installed vulkan tools

At the moment i have enable secure boot on linux, but i have some problem to update to 415.27
Now?

Code: Select all

 glxinfo | egrep '^OpenGL'
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 970/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 415.25
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 415.25
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 415.25
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20

Code: Select all

lele@lele-All-Series:~$ vulkaninfo | egrep '^(GPU id|Vulkan)'
Vulkan Instance Version: 1.1.70
GPU id       : 0 (GeForce GTX 970)

User avatar
Bob Wya
Level 12
Level 12
Posts: 2777
Joined: Sat Oct 16, 2010 7:40 pm
Location: Cambridge
Contact:

Re: Sniper Elite 4

Post by Bob Wya » Wed Jan 30, 2019 9:18 am

WineChancellor wrote:

Code: Select all

lele@lele-All-Series:~$ vulkaninfo | egrep '^(GPU id|Vulkan)'
Vulkan Instance Version: 1.1.70
GPU id       : 0 (GeForce GTX 970)
I skipped Nvidia driver version 415.25 - so I can't say what the Vulkan support is like.
But you should note that Nvidia are tending to release a Vulkan Development driver.
Then they will slowly forward (trickle) port updates from this as they update their current Nvidia driver.

Currently I'm on Nvidia driver 415.27 and Vulkan Loader 1.1.97.0.

So I'm seeing:

Code: Select all

vulkaninfo | egrep '^(GPU id|Vulkan)'

Vulkan Instance Version: 1.1.97
GPU id       : 0 (GeForce GTX 970M)
GPU id       : 0 (GeForce GTX 970M)
Obviously you don't need to be that up-to-date to run DXVK games.
I think the Nvidia driver may actually only fully support the 1.1.84 Vulkan API, but with some Vulkan extensions.

I quickly find myself banging my head off the wall with Debian / Ubuntu package 'management'.
If you try to update a multilib package on Ubuntu...
apt / aptitude both fail unless you update both the 32-bit and the 64-bit versions of the package simultaneously...
This is really dumb! :shock:

Currently your issue is not really a Wine problem anyway, since we are talking about the native Linux Vulkan layer.
It's a Linux distribution packaging issue...

Hence why I use Gentoo day-to-day. Which happens to have the best multilib support of any Linux distribution, period.
So I'm probably not the best person to advise on the packaging issues you currently have.

Bob

WineChancellor
Level 2
Level 2
Posts: 49
Joined: Sun Nov 14, 2010 8:24 am

Re: Sniper Elite 4

Post by WineChancellor » Thu Jan 31, 2019 11:04 am

@bob

can you have council to improve perfomance of SE4, it seems work well but if i install dxvk xx the game goes to crash. Why?
Lele

User avatar
Bob Wya
Level 12
Level 12
Posts: 2777
Joined: Sat Oct 16, 2010 7:40 pm
Location: Cambridge
Contact:

Re: Sniper Elite 4

Post by Bob Wya » Thu Jan 31, 2019 11:59 am

WineChancellor wrote:@bob

can you have council to improve perfomance of SE4, it seems work well but if i install dxvk xx the game goes to crash. Why?
Lele
The first thing would be check for the following log files:

Code: Select all

d3d11.log
dxgi.log
which would be in the main Sniper Elite 4 game directory.

If these files exist, can you post them here?

If these DXVK files don't exist then Wine is probably not even able to access the Vulkan API.
So please post a Wine log with:

Code: Select all

export WINEDEBUG=+timestamp,+tid,+vulkan
wine ...
would help troubleshoot this.

Thanks
Bob

WineChancellor
Level 2
Level 2
Posts: 49
Joined: Sun Nov 14, 2010 8:24 am

Re: Sniper Elite 4

Post by WineChancellor » Wed Feb 06, 2019 7:28 am

@bob
Sorry, i'm not forgot of you but i have few time... i will come back soon

Post Reply