err:module:import_dll Library NDIS.SYS

Open forum for end-user questions about Wine. Before asking questions, check out the Wiki as a first step.
Forum Rules
Locked
td0g
Newbie
Newbie
Posts: 3
Joined: Wed Jan 09, 2019 10:11 am

err:module:import_dll Library NDIS.SYS

Post by td0g » Wed Jan 09, 2019 10:18 am

Hi everyone, I just installed 1:1.6.2-0ubuntu14.2 via the Ubuntu software center on Ubuntu 16.04.5 and then installed the latest Hikvision IVMS client. Now when I run winefile I get this error before I even try to start the ivms application:

err:module:import_dll Library NDIS.SYS (which is needed by L"C:\\Program Files\\iVMS-4200 Station\\iVMS-4200\\Drivers\\npf64.sys") not found

winefile runs but I can't get ivms-4200.exe to run.

Is this a library I can install via winetricks?

User avatar
dimesio
Moderator
Moderator
Posts: 12677
Joined: Tue Mar 25, 2008 10:30 pm

Re: err:module:import_dll Library NDIS.SYS

Post by dimesio » Wed Jan 09, 2019 12:09 pm

No; .sys files are hardware drivers, and Windows hardware drivers don't work in Wine.

td0g
Newbie
Newbie
Posts: 3
Joined: Wed Jan 09, 2019 10:11 am

Re: err:module:import_dll Library NDIS.SYS

Post by td0g » Wed Jan 09, 2019 1:52 pm

Is this a driver that the windows emulator should have in it? The app doesn't require any hardware to run that I'm aware of. I have it in a bare bones windows 7 VM at the moment.

User avatar
dimesio
Moderator
Moderator
Posts: 12677
Joined: Tue Mar 25, 2008 10:30 pm

Re: err:module:import_dll Library NDIS.SYS

Post by dimesio » Wed Jan 09, 2019 6:31 pm

Wine does not provide hardware drivers at all; hardware has to be working in the host system for Wine to use it.

As for your app supposedly not needing any hardware, according to https://us.hikvision.com/en/support-res ... t-software, it's software to control "DVRs, NVRs, IP cameras,encoders decoders, etc." That's certainly hardware. The app itself installs its own hardware drivers in /Program Files/iVMS-4200 Station/iVMS-4200/Drivers.

FYI, you should upgrade your Wine version if you are going to use it for anything else. 1.6.2 is over four years old and no longer supported. Use the WineHQ packages. https://wiki.winehq.org/Ubuntu

td0g
Newbie
Newbie
Posts: 3
Joined: Wed Jan 09, 2019 10:11 am

Re: err:module:import_dll Library NDIS.SYS

Post by td0g » Thu Jan 10, 2019 8:19 am

The software only interfaces with cameras and DVRs through web and RTSP streams, so I don't see why it would need drivers, but in any case I didn't know I had installed such an old version of Wine, the Ubuntu software centre strikes again. I'll try upgrading to the latest.

User avatar
Bob Wya
Level 12
Level 12
Posts: 2768
Joined: Sat Oct 16, 2010 7:40 pm
Location: Cambridge
Contact:

Re: err:module:import_dll Library NDIS.SYS

Post by Bob Wya » Tue Jan 15, 2019 8:12 am

@td0g

There is a similar problem with the most recent Wine Staging version (4.0-rc6).
Generally it's very hard to workaround Windows applications that require native drivers.
iVMS is clearly installing a driver, which it expects to work.
So in appears that you may be SOL.

The

Locked