Problems launching a windows application

Questions about Wine on Linux
Post Reply
mahakali
Newbie
Newbie
Posts: 2
Joined: Fri Oct 26, 2018 11:26 am

Problems launching a windows application

Post by mahakali » Fri Oct 26, 2018 11:40 am

Hi

I am running Debian Sid, wine 3.18-staging is installed. Trying to launch a windows software , used to set up plannings.
But it stops with following error :

Unhandled exception: page fault on read access to 0x00000090 in 32-bit code (0x7e430d07).
Register dump:
CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
EIP:7e430d07 ESP:222cfc50 EBP:222cfcb8 EFLAGS:00010206( R- -- I - -P- )
EAX:00000194 EBX:7e454000 ECX:222cfd54 EDX:0000000c
ESI:20351b58 EDI:00000000
Stack dump:
0x222cfc50: 00110000 20351618 222cfca8 7bc734b9
0x222cfc60: 20351618 7b63e000 00000000 00110064
0x222cfc70: 00110060 00000002 00110000 00000000
0x222cfc80: 000003cc f7f00000 222cfcb0 20250000
0x222cfc90: 20351b58 20351618 222cfcc0 00000195
0x222cfca0: 20351b58 20351618 7e430cfb 7e454000
Backtrace:
=>0 0x7e430d07 in winhttp (+0x10d07) (0x222cfcb8)
1 0x7e43b0b4 in winhttp (+0x1b0b3) (0x222cfdc8)
2 0x7e43b38c in winhttp (+0x1b38b) (0x222cfe48)
3 0x7e43b6c6 in winhttp (+0x1b6c5) (0x222cfe78)
4 0x7e432a22 in winhttp (+0x12a21) (0x222cfed8)
5 0x7bca8918 call_thread_func_wrapper+0xb() in ntdll (0x222cfeec)
6 0x7bcac030 in ntdll (+0x6c02f) (0x222cffdc)
7 0x7bca890a call_thread_exit_func+0x31() in ntdll (0x222cffec)
0x7e430d07: movl 0x90(%edi),%edx
The whole file is attached.

It seems to be a problem with winhttp which is indeed needed but I can't install it :

Code: Select all

 winetricks winhttp  

Using winetricks 20180815 - sha256sum: 29e664ec1e879271a33167bf367deaa188cbe803d44b540e692bd669c44a2804 with wine-3.18 (Staging) and WINEARCH=win32
Executing w_do_call winhttp
Executing load_winhttp
Executing cabextract -q -d /home/claude/.wine/dosdevices/c:/windows/temp/_winhttp -L -F i386/new/winhttp.dl_ /home/claude/.cache/winetricks/win2ksp4/W2KSP4_EN.EXE
Executing cabextract -q --directory=/home/claude/.wine/dosdevices/c:/windows/system32 /home/claude/.wine/dosdevices/c:/windows/temp/_winhttp/i386/new/winhttp.dl_
/home/claude/.wine/dosdevices/c:/windows/temp/_winhttp/i386/new/winhttp.dl_: no valid cabinets found
------------------------------------------------------
Note: command cabextract -q --directory=/home/claude/.wine/dosdevices/c:/windows/system32 /home/claude/.wine/dosdevices/c:/windows/temp/_winhttp/i386/new/winhttp.dl_ returned status 1. Aborting.


Any idea how to solve this ??

Thanks

mahakali
Newbie
Newbie
Posts: 2
Joined: Fri Oct 26, 2018 11:26 am

Re: Problems launching a windows application

Post by mahakali » Tue Oct 30, 2018 8:01 am

Hi,

So, no answers ... I will try it an other way. How to install

Code: Select all

winhttp
??
If I try

Code: Select all

winetricks winhttp  
i get following error message :
Using winetricks 20180815 - sha256sum: 29e664ec1e879271a33167bf367deaa188cbe803d44b540e692bd669c44a2804 with wine-3.18 (Staging) and WINEARCH=win32
Executing w_do_call winhttp
Executing load_winhttp
Executing cabextract -q -d /home/claude/.wine/dosdevices/c:/windows/temp/_winhttp -L -F i386/new/winhttp.dl_ /home/claude/.cache/winetricks/win2ksp4/W2KSP4_EN.EXE
Executing cabextract -q --directory=/home/claude/.wine/dosdevices/c:/windows/system32 /home/claude/.wine/dosdevices/c:/windows/temp/_winhttp/i386/new/winhttp.dl_
/home/claude/.wine/dosdevices/c:/windows/temp/_winhttp/i386/new/winhttp.dl_: no valid cabinets found
------------------------------------------------------
Note: command cabextract -q --directory=/home/claude/.wine/dosdevices/c:/windows/system32 /home/claude/.wine/dosdevices/c:/windows/temp/_winhttp/i386/new/winhttp.dl_ returned status 1. Aborting
Install winhhttp would certainly solve the problem.

Regards

jkfloris
Level 6
Level 6
Posts: 664
Joined: Thu Aug 14, 2014 10:10 am

Re: Problems launching a windows application

Post by jkfloris » Fri Nov 02, 2018 9:07 am


User avatar
DarkShadow44
Level 7
Level 7
Posts: 922
Joined: Tue Nov 22, 2016 5:39 pm

Re: Problems launching a windows application

Post by DarkShadow44 » Sun Nov 04, 2018 2:59 pm

If "winetricks winhttp" fixes the issue, make sure to report a bug if there's not already one.

jkfloris
Level 6
Level 6
Posts: 664
Joined: Thu Aug 14, 2014 10:10 am

Re: Problems launching a windows application

Post by jkfloris » Mon Nov 05, 2018 4:11 pm

A new Debian version will be available soon
https://bugs.debian.org/cgi-bin/bugrepo ... bug=913007

Post Reply