no administrator privileges in wine to install programs

Questions about Wine on Linux
Post Reply
_jos_
Newbie
Newbie
Posts: 3
Joined: Wed Jul 18, 2018 10:54 pm

no administrator privileges in wine to install programs

Post by _jos_ » Thu Jul 19, 2018 12:58 am

Hi All,

I have a strange error if i try to install some windows programs.

It's the canon digital photo professional full install of v4.8.30 or upgrade 3.15.0.

Both processes stop with the message

"Installation program of Digital Photo Professional requires administrator privileges".

The installation of dotnet45 and msxml3 via winetricks seems to work - I have to kill a bunch of hanging processes (mscorsvw.exe) after the finish-dialog.
So this installation must have administrator privileges in wine as expected.

wine ??, wine 10, wine 11, wine 12, fedora 28
windows versions 7 and 8.1.

Using win xp the installation fails with the message the (installation-) file would be corrupt.

Code: Select all

$ (export WINEARCH=win32; export WINEPREFIX=/mnt/wine/home/.wine32; wine /tmp/dppw3.15.0-updater.exe)
000b:fixme:winediag:start_process Wine Staging 3.12 is a testing version containing experimental patches.
000b:fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq.org.
001c:fixme:mountmgr:create_disk_device IoCreateDevice L"\\Device\\HarddiskVolume31" got c0000035
001c:fixme:mountmgr:create_disk_device IoCreateDevice L"\\Device\\HarddiskVolume31" got c0000035
001c:fixme:mountmgr:create_disk_device IoCreateDevice L"\\Device\\HarddiskVolume31" got c0000035
001c:fixme:mountmgr:create_disk_device IoCreateDevice L"\\Device\\HarddiskVolume31" got c0000035
001c:fixme:mountmgr:create_disk_device IoCreateDevice L"\\Device\\HarddiskVolume31" got c0000035
001c:fixme:mountmgr:create_disk_device IoCreateDevice L"\\Device\\HarddiskVolume31" got c0000035
0009:fixme:exec:SHELL_execute flags ignored: 0x00000100
0031:fixme:wtsapi:WTSQuerySessionInformationW Stub (nil) 0x00000001 5 0x33ed30 0x33ed24
With playonlinux together with winetricks I got it managed to install dpp-4.8 in a wine-2.0.3 prefix.
This seems to work as usual.

Does anybody have an idea what I am missing?

M.f.G.
Joerg

User avatar
dimesio
Moderator
Moderator
Posts: 12672
Joined: Tue Mar 25, 2008 10:30 pm

Re: no administrator privileges in wine to install programs

Post by dimesio » Thu Jul 19, 2018 6:37 am

_jos_ wrote:

Code: Select all

$ (export WINEARCH=win32; export WINEPREFIX=/mnt/wine/home/.wine32; wine /tmp/dppw3.15.0-updater.exe)
Have you tried running the installer from somewhere other than /tmp? This problem could be related to https://bugs.winehq.org/show_bug.cgi?id=36546.

_jos_
Newbie
Newbie
Posts: 3
Joined: Wed Jul 18, 2018 10:54 pm

Re: no administrator privileges in wine to install programs

Post by _jos_ » Thu Jul 19, 2018 11:32 pm

Hi dimesio,

thanks for your reply.
Have you tried running the installer from somewhere other than /tmp? This problem could be related to https://bugs.winehq.org/show_bug.cgi?id=36546.
To feel certain I tested it again with the same result.

After all the tests I feel the error message is uncorrect - also indicated by the working installation of dotnet and pwhe761.exe (minitool partition) as test without problems.

When I enabled the virtual desktop in winecfg and used a small size the installer failed with an 'unsupported size' message window. After correcting this the installer complained the missing admin privileges (same looking graphical message window).

So it must have the the privileges. It's confusing seeing the installation work with no problems in wine 2.0.3 (and some versions up I assume).

M.f.G.
Joerg

User avatar
dimesio
Moderator
Moderator
Posts: 12672
Joined: Tue Mar 25, 2008 10:30 pm

Re: no administrator privileges in wine to install programs

Post by dimesio » Fri Jul 20, 2018 6:29 am

So it must have the the privileges. It's confusing seeing the installation work with no problems in wine 2.0.3 (and some versions up I assume).
Yes, Wine runs with administrator privileges.

What I just noticed in your console output from 3.12 is that you tested wine-staging. Have you tested the development release for 3.12? The reason I ask is that wine-staging includes patches to implement UAC, and the problem could be related to that difference rather than the newer version.

If that's not the issue, the next step would be to run a regression test to identify the patch that broke it. https://wiki.winehq.org/Regression_Testing


_jos_
Newbie
Newbie
Posts: 3
Joined: Wed Jul 18, 2018 10:54 pm

Re: no administrator privileges in wine to install programs

Post by _jos_ » Sun Jul 22, 2018 10:20 pm

Hi,

thanks for your hints.

I've testet a bit (really hate try and error) and got this

... the UAC patch was inserted in wine 2.14 as I read.

Code: Select all

(install means the no privileges error)

2.0.3-staging	install works, prgram works
2.15-staging	install works, prgram works
2.22-staging	install works, prgram hangs at splash-screen (CPU 90%)
	!!! this is not a staging version !!! pol downloaded it as staging but it isnt
	winetricks install dotnet45 fails - dotnet40 is installed
	installing dpp4 works and installs its own dotnet45
	launching dpp4 hangs showing the splash-screen (cpu 90%)
3.0-staging	install works, prgram hangs at splash-screen (CPU 90%)
	!!! this is not a staging version !!! pol downloaded it as staging but it isnt
	winetricks install dotnet40 dotnet45 works
	launching dpp4 hangs showing the splash-screen (cpu 90%)
3.2-staging	install works, prgram hangs at splash-screen (CPU 90%)
	!!! this is not a staging version !!! pol downloaded it as staging but it isnt
	winetricks install dotnet45 fails - dotnet40 is installed
	installing dpp4 works and installs its own dotnet45
	launching dpp4 hangs showing the splash-screen (cpu 90%)
3.5 install	works, program fails because missing dotnet45
	winetricks install dotnet40 hangs after finish-dialog (does nothing)
		after ctrl-c it starts to install dotnet45 and produces many mscorsvw.exe processes
		after killall mscorsvw.exe the shell hangs.
		ctrl-c kills winetricks
		because of the broken dotnet40/45 install depending programs fail and
		dpp does not install its own dotnet
3.6 install	fails, dotnet45 is installed without problems
3.7 install	fails, dotnet40/45 installation problems like in 3.5
3.8	install	fails
	winetricks install dotnet45 fails - dotnet40 is installed
3.10-staging	install fails
3.12-staging	install fails (system)
3.12-staging_x64	install fails (system)
3.12	install fails
by the way I tested to compile wine (it did really good without problems) for further tests.

With the idea to test the install via runas I got a little unexpected result.

wine runas /trustlevel:0x20000 z:\\tmp\\p\\dppw4.8.30-installer.exe

ok, this shouldn't work

but this was a little surprising

wine runas /trustlevel:0x00000 z:\\tmp\\p\\dppw4.8.30-installer.exe

schouldn't it return an error for the wrong parameter?

code src wine-3.12-staging rpm (fedora 28)

in

wine-staging-3.12/patches/advapi32-Token_Integrity_Level/0001-advapi32-tests-E~token-integrity.patch

Code: Select all

+int wmain(int argc, WCHAR *argv[])
+{

	[...]

+    if (cmd.trustlevel && cmd.trustlevel != 0x20000)
+    {
+        output_message(STRING_UNHANDLED_TRUSTLEVEL, cmd.trustlevel);
+        return 1;
+    }

	[...]

+}
For the initial problem I get the impression the error could be in some registry settings.

M.f.G.
Joerg

jpvial
Newbie
Newbie
Posts: 1
Joined: Tue Jul 31, 2018 4:02 am

Re: no administrator privileges in wine to install programs

Post by jpvial » Tue Jul 31, 2018 4:11 am

I have exactly the same problem under linux for dpp-4.8.3
opensuse leap 15
wine 3-7

winetricks, dotnet45 and msxml3 installed without problem (but with hundreds, or more probably thousands
of warnings (mostly of the "fixme" style)

I am not at all a Wine expert, so I can't tell more

jpvial

lesebas
Newbie
Newbie
Posts: 3
Joined: Tue Jan 30, 2018 4:20 pm

Re: no administrator privileges in wine to install programs

Post by lesebas » Thu Jan 10, 2019 4:45 pm

Hi I've try to install v4.9 with wine 4.0rc4-1 (under playonlinux). I've exactly the same issue. Here is the log :

Code: Select all

[01/10/19 22:43:12] - Running wine- /home/sebastien/PlayOnLinux's virtual drives/DPP4.9/drive_c/windows/Canon_Inc_IC_OFI_TEMP_0/Data/setup.exe (Working directory : /home/Donnees/sebastien/.PlayOnLinux/wineprefix/DPP4.9/drive_c/windows/Canon_Inc_IC_OFI_TEMP_0/Data)
0012:fixme:reg:GetEnabledXStateFeatures 
0012:fixme:wer:WerSetFlags (2) stub!
0012:fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
0017:fixme:process:SetProcessShutdownParameters (00000380, 00000000): partial stub.
0017:fixme:ntdll:EtwEventRegister ({319dc449-ada5-50f7-428e-957db6791668}, 0x993720, 0x9e0320, 0x9e0338) stub.
0017:fixme:ntdll:EtwEventSetInformation (deadbeef, 2, 0x971b7d, 28) stub
0009:fixme:ntdll:EtwEventRegister ({5eec90ab-c022-44b2-a5dd-fd716a222a15}, 0x401123, 0x452550, 0x452568) stub.
0009:fixme:ntdll:EtwEventSetInformation (deadbeef, 2, 0x44ba48, 43) stub
0009:fixme:nls:GetThreadPreferredUILanguages 00000038, 0x33f9b0, 0x33f9c0 0x33f9b4
0009:fixme:nls:get_dummy_preferred_ui_language (0x38 0x33f9b0 0x33f9c0 0x33f9b4) returning a dummy value (current locale)
0030:fixme:ntdll:EtwEventRegister ({5eec90ab-c022-44b2-a5dd-fd716a222a15}, 0x401123, 0x5036f0, 0x503708) stub.
0030:fixme:ntdll:EtwEventSetInformation (deadbeef, 2, 0x4f0cf8, 43) stub
0030:fixme:nls:GetThreadPreferredUILanguages 00000038, 0x33f9dc, 0x33f9ec 0x33f9e0
0030:fixme:nls:get_dummy_preferred_ui_language (0x38 0x33f9dc 0x33f9ec 0x33f9e0) returning a dummy value (current locale)
0030:fixme:shell:InitNetworkAddressControl stub
0030:fixme:ntdll:EtwEventRegister ({5eec90ab-c022-44b2-a5dd-fd716a222a15}, 0x10001123, 0x100324b0, 0x100324c8) stub.
0030:fixme:ntdll:EtwEventSetInformation (deadbeef, 2, 0x1002e350, 43) stub
0031:fixme:ver:GetCurrentPackageId (0x84fe9c (nil)): stub
0030:err:module:load_builtin_dll failed to load .so lib for builtin L"l3codeca.acm": libmpg123.so.0: cannot open shared object file: No such file or directory
0030:fixme:ntdll:EtwEventRegister ({5eec90ab-c022-44b2-a5dd-fd716a222a15}, 0x861123, 0xa02f90, 0xa02fa8) stub.
0030:fixme:ntdll:EtwEventSetInformation (deadbeef, 2, 0x9eee48, 43) stub
0030:fixme:wtsapi:WTSQuerySessionInformationW Stub (nil) 0x00000001 5 0x33ecfc 0x33ecec
0030:fixme:win:EnumDisplayDevicesW ((null),0,0x33db04,0x00000000), stub!
0030:fixme:win:EnumDisplayDevicesW ((null),0,0x33db04,0x00000000), stub!
0030:fixme:ntdll:EtwEventUnregister (deadbeef) stub.
0030:fixme:ntdll:EtwEventUnregister (0) stub.
0030:fixme:ver:GetCurrentPackageId (0x33fe24 (nil)): stub
0030:fixme:ntdll:EtwEventUnregister (deadbeef) stub.
0030:fixme:ntdll:EtwEventUnregister (0) stub.
0009:fixme:ver:GetCurrentPackageId (0x33fe24 (nil)): stub
0017:fixme:service:QueryServiceConfig2W Level 6 not implemented
0017:fixme:service:QueryServiceConfig2W Level 6 not implemented
0017:fixme:service:QueryServiceConfig2W Level 6 not implemented
0017:fixme:service:QueryServiceConfig2W Level 6 not implemented
0017:fixme:service:QueryServiceConfig2W Level 6 not implemented
0012:fixme:ntdll:EtwEventUnregister (deadbeef) stub.

User avatar
dimesio
Moderator
Moderator
Posts: 12672
Joined: Tue Mar 25, 2008 10:30 pm

Re: no administrator privileges in wine to install programs

Post by dimesio » Thu Jan 10, 2019 5:22 pm

lesebas wrote:Hi I've try to install v4.9 with wine 4.0rc4-1 (under playonlinux).
PlayOnLinux is not supported here.

As for the problem this thread is about, the relevant bug is still open. The bug is marked STAGED, so you should try wine-staging if you haven't already.

Post Reply