Running very basic Turbo Transfer server app

Questions about Wine on macOS.
Post Reply
mywinehqid
Newbie
Newbie
Posts: 1
Joined: Wed Apr 21, 2021 4:09 am

Running very basic Turbo Transfer server app

Post by mywinehqid » Wed Apr 21, 2021 4:42 am

Hi everyone,

I've run quite a few things with Wine along the years but my troubleshooting knowledge is still somewhat limited. Trying to run a very basic 560kb app called Turbo Transfer (for direct p2p transfers across the web) published here.

I realise it probably relies on a couple of windows functions that enables its server and other connection features, but I am not familiar enough with extra wine options as to figure out which ones I need.

This is the log when launching the program:

Code: Select all

darwin@pc-32 ~ % wine64 tt.exe 
0009:fixme:ntdll:EtwRegisterTraceGuidsW (0x140065a58, 0x0, {f7b697a3-4db5-4d3b-be71-c4d284e6592f}, 7, 0x1400ae9c0, (null), (null), 0x1400b7500): stub
0009:fixme:ntdll:EtwRegisterTraceGuidsW   register trace class {72b14a7d-704c-423e-92f8-7e6d64bcb92a}
0009:fixme:ntdll:EtwRegisterTraceGuidsW   register trace class {e2091f8a-1e0a-4731-84a2-0dd57c8a5261}
(more of the same)
0009:fixme:heap:GetNumaHighestNodeNumber semi-stub: 000000000021EEB0
002e:fixme:ver:GetCurrentPackageId (0x268fd90 0x0): stub
002f:fixme:winsock:set_dont_fragment IP_DONTFRAGMENT for IPv4 not supported in this platform
After selecting the Remote Upload button, or initiating a Select File transfer I get this:

Code: Select all

002f:fixme:hnetcfg:upnpnat_get_StaticPortMappingCollection 0000000001087C40, 0000000002B0FC90
Does anyone know how I should configure Wine to make this work?

To ease my trial and error I've tried installing a couple winetricks through Wineskin, before I move and do the same from the command line. So far I've installed the following:

Code: Select all

urlmon
vcrun6sp6
winhttp
wininet
wininet_win2k
Doing so, the Wineskin log is as follows:

Code: Select all

001d:err:plugplay:process_IOService_Device object 0x4203
001d:err:plugplay:process_IOService_Device Unable to create plug in interface for USB deviceobject 0x550b
001d:err:plugplay:process_IOService_Device object 0xa91b
0009:fixme:ntdll:EtwRegisterTraceGuidsW (...): stub
0009:fixme:ntdll:EtwRegisterTraceGuidsW   register trace class {72b14a7d-704c-423e-92f8-7e6d64bcb92a}
(more of the same)
0009:fixme:process:GetNumaHighestNodeNumber (0x23eeb0): semi-stub
002d:fixme:ver:GetCurrentPackageId (0xbbfd90 0x0): stub
002d:fixme:ntdll:EtwRegisterTraceGuidsA (...): stub
002d:fixme:ntdll:EtwRegisterTraceGuidsA (...): stub
002d:fixme:ntdll:EtwEventRegister (...) stub.
002d:fixme:ntdll:EtwEventActivityIdControl 0x1, 0xbbe9d0: stub
002d:fixme:shell:SHQueueUserWorkItem Unsupported arguments
002d:fixme:ras:RasEnumEntriesW (...),stub!
002a:fixme:ras:RasConnectionNotificationW (...),stub!
002d:fixme:winsock:WSALookupServiceBeginW (...) Stub!
002d:fixme:shell:SHQueueUserWorkItem Unsupported arguments
002a:fixme:ras:RasConnectionNotificationW (...),stub!
002d:fixme:ras:RasEnumEntriesW (...),stub!
002d:fixme:winsock:set_dont_fragment IP_DONTFRAGMENT for IPv4 not supported in this platform
002d:fixme:ntdll:server_ioctl_file Unsupported ioctl 9800012c (device=9800 access=0 func=4b method=0)
002d:fixme:winsock:server_ioctl_sock Unsupported ioctl 9800012c (device=9800 access=0 func=4b method=0)
002d:fixme:winsock:WSAIoctl unsupported WS_IOCTL cmd (SIO_SET_COMPATIBILITY_MODE)
002f:fixme:hnetcfg:upnpnat_get_StaticPortMappingCollection 00000000000C82F0, 0000000000D0FC90

002f:fixme:shell:SHQueueUserWorkItem Unsupported arguments
002f:fixme:ras:RasEnumEntriesW (...),stub!
002a:fixme:ras:RasConnectionNotificationW (...),stub!
(last 3 lines repeat several times)
Both seem to run into the same problem. Your help would be much appreciated!

Post Reply