Unusual Fuchsia Color Around Bitmap Sprites

Questions about Wine on macOS.
Post Reply
Moonwave
Level 2
Level 2
Posts: 12
Joined: Mon Jan 20, 2020 3:12 pm

Unusual Fuchsia Color Around Bitmap Sprites

Post by Moonwave » Tue Oct 13, 2020 11:59 pm

I am running into a graphical bug while attempting to play a game called Fairyland Online.

Image

Wherever there is a sprite with transparency, the sprite shows up with a strange fuchsia/pink color.

I see some similar bugs on Bugzilla:
https://bugs.winehq.org/show_bug.cgi?id=20391
https://bugs.winehq.org/show_bug.cgi?id=26221
https://bugs.winehq.org/show_bug.cgi?id=39014 - most useful but still doesn't provide exact solution
https://bugs.winehq.org/show_bug.cgi?id=38547

Is this a bug that could possibly be fixed with applying certain winetricks? Has anyone encountered this bug before on a different program? Let me know if you have any ideas on how to fix this graphical bug.

After doing some research. It might be due to the game requiring DirectX 8. I know Wine has DX9, but I have heard that it might not be fully compatible with DX8 games. It could also be due to OpenGL.

Gcenx
Level 6
Level 6
Posts: 515
Joined: Mon Dec 25, 2017 12:11 pm

Re: Unusual Fuchsia Color Around Bitmap Sprites

Post by Gcenx » Wed Oct 14, 2020 11:53 am

What version of macOS are you running?

What version of wine is being used?

Also provide terminal output

Moonwave
Level 2
Level 2
Posts: 12
Joined: Mon Jan 20, 2020 3:12 pm

Re: Unusual Fuchsia Color Around Bitmap Sprites

Post by Moonwave » Wed Oct 14, 2020 12:52 pm

Gcenx wrote:
Wed Oct 14, 2020 11:53 am
What version of macOS are you running?

What version of wine is being used?

Also provide terminal output
I am running on Mac OS Mojave. I have tested on multiple versions of Wine, all with the same result. Current build is with WS9Wine5.6.

Here's an output from terminal after running the game for a minute:

Code: Select all

0026:fixme:ntdll:server_ioctl_file Unsupported ioctl 24000 (device=2 access=1 func=0 method=0)
0009:fixme:x11drv:X11DRV_desktop_SetCurrentMode Cannot change screen BPP from 32 to 16
0009:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
0009:fixme:ddraw:DirectDrawEnumerateExA flags 0x00000004 not handled
0009:fixme:ddraw:ddraw7_Initialize Ignoring guid {aeb2cdd4-6e41-43ea-941c-8361cc760781}.
0009:fixme:coreaudio:ca_channel_layout_to_channel_mask Unhandled channel 0xffffffff
0009:fixme:ddraw:ddraw7_WaitForVerticalBlank iface 0143C2A0, flags 0x1, event 00000000 stub!
0009:fixme:keyboard:X11DRV_ActivateKeyboardLayout 0x4090409, 0000: semi-stub!
0009:fixme:winsock:set_dont_fragment IP_DONTFRAGMENT for IPv4 not supported in this platform

Gcenx
Level 6
Level 6
Posts: 515
Joined: Mon Dec 25, 2017 12:11 pm

Re: Unusual Fuchsia Color Around Bitmap Sprites

Post by Gcenx » Thu Oct 15, 2020 9:22 am

So your using my fork of Wineskin along with the Winehq wine5.6.

Not sure why your using X11 display driver you really should use macDriver.

If madDriver doesn’t work try changing to a staging engine that might resolve the issue.

Also officially that games servers were taken offline I’m assuming your playing on a private server?

Moonwave
Level 2
Level 2
Posts: 12
Joined: Mon Jan 20, 2020 3:12 pm

Re: Unusual Fuchsia Color Around Bitmap Sprites

Post by Moonwave » Thu Oct 15, 2020 11:52 am

Gcenx wrote:
Thu Oct 15, 2020 9:22 am
So your using my fork of Wineskin along with the Winehq wine5.6.

Not sure why your using X11 display driver you really should use macDriver.

If madDriver doesn’t work try changing to a staging engine that might resolve the issue.

Also officially that games servers were taken offline I’m assuming your playing on a private server?
Yes, it's a private server. I have seen people get this bug on the official servers too. I tried Mac driver and got the same result. I just tried staging and got the same result too (fuchsia/pink sprite blocks). Here is the output:

Code: Select all

000b:fixme:winediag:start_process Wine Staging 5.5 is a testing version containing experimental patches.
000b:fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq.org.
0009:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
0009:fixme:ddraw:DirectDrawEnumerateExA flags 0x00000004 not handled
0009:fixme:ddraw:ddraw7_Initialize Ignoring guid {aeb2cdd4-6e41-43ea-941c-8361cc760781}.
0009:fixme:coreaudio:ca_channel_layout_to_channel_mask Unhandled channel 0xffffffff
0009:fixme:ddraw:ddraw7_WaitForVerticalBlank iface 01319980, flags 0x1, event 00000000 stub!
0009:fixme:winsock:set_dont_fragment IP_DONTFRAGMENT for IPv4 not supported in this platform
Could it possibly be an issue with DirectDraw or DirectX?

Moonwave
Level 2
Level 2
Posts: 12
Joined: Mon Jan 20, 2020 3:12 pm

Re: Unusual Fuchsia Color Around Bitmap Sprites

Post by Moonwave » Thu Oct 15, 2020 4:29 pm

Gcenx wrote:
Thu Oct 15, 2020 9:22 am
Also officially that games servers were taken offline I’m assuming your playing on a private server?
If you want to try seeing if you can run the game for yourself, here is the link:
http://www.mediafire.com/file/zf1c67988 ... IJ9L5TPH4

Just run Fairyland.exe - when you get to the login, you can type any username and password you want to get into the game.

Gcenx
Level 6
Level 6
Posts: 515
Joined: Mon Dec 25, 2017 12:11 pm

Re: Unusual Fuchsia Color Around Bitmap Sprites

Post by Gcenx » Fri Oct 16, 2020 8:22 am

I’m getting the issue even using the very latest wine-devel-5.19 seems this will require a bugzilla for this to be resolved

Moonwave
Level 2
Level 2
Posts: 12
Joined: Mon Jan 20, 2020 3:12 pm

Re: Unusual Fuchsia Color Around Bitmap Sprites

Post by Moonwave » Fri Oct 16, 2020 3:27 pm

I ended up getting it to work. All I had to do is change Fullscreen from 0 to 1 in sys.ini inside the FairyLand folder.

Post Reply