Only title bar appears for Forte Agent

Questions about Wine on macOS.
Post Reply
deKay
Newbie
Newbie
Posts: 3
Joined: Wed May 20, 2020 3:13 am

Only title bar appears for Forte Agent

Post by deKay » Wed May 20, 2020 3:28 am

Hi there,

For many years now I've been running Forte Agent (v1.93) under various flavours of wine on my Macs (including WineBottler and PlayOnMac), but for a while now I've just been using "plain" wine. Sometimes, when I run Agent, all that opens is a title bar:
Screenshot 2020-05-20 at 09.17.51.png
This has happened on every version of wine I've used, but is rare and usually a reboot of the Mac fixes it, and if that doesn't, deleting ~/.wine does. However, it happened again a couple of weeks ago and nothing I try has resolved it.

Things I've tried:

Rebooting
Deleting ~/.wine
Uninstalling and reinstalling wine
Upgrading wine to v5 (from v4)
Upgrading xquartz to 2.7.11
Running winecfg and trying various compatibility options (I'd always run Agent as a Windows 7 app but I've tried that and others)
Running Agent as a different OSX user (it does the same thing)
Copying the Agent folder to an actual PC and running it to make sure it's not broken (it works fine)

Other exes I've tested - for example 3D Space Cadet Pinball - work fine.

When run from a command line, I get these errors:
/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.200.3/Common/ChunkCompression.cpp:49: Error: unsupported compressor 8
/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.200.3/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Library/AppExceptions.bundle/Exceptions.plist'
0009:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.

but I seem to recall I've always had these and it has worked anyway.

I'm using Mojave 10.14.6, and wine and xquartz were both installed from a pkg (not homebrew).

Any suggestions?

Gcenx
Level 6
Level 6
Posts: 515
Joined: Mon Dec 25, 2017 12:11 pm

Re: Only title bar appears for Forte Agent

Post by Gcenx » Wed May 20, 2020 8:46 am

deKay wrote:
Wed May 20, 2020 3:28 am
Hi there,

For many years now I've been running Forte Agent (v1.93) under various flavours of wine on my Macs (including WineBottler and PlayOnMac), but for a while now I've just been using "plain" wine. Sometimes, when I run Agent, all that opens is a title bar:
Screenshot 2020-05-20 at 09.17.51.png
This has happened on every version of wine I've used, but is rare and usually a reboot of the Mac fixes it, and if that doesn't, deleting ~/.wine does. However, it happened again a couple of weeks ago and nothing I try has resolved it.

Things I've tried:

Rebooting
Deleting ~/.wine
Uninstalling and reinstalling wine
Upgrading wine to v5 (from v4)
Upgrading xquartz to 2.7.11
Running winecfg and trying various compatibility options (I'd always run Agent as a Windows 7 app but I've tried that and others)
Running Agent as a different OSX user (it does the same thing)
Copying the Agent folder to an actual PC and running it to make sure it's not broken (it works fine)

Other exes I've tested - for example 3D Space Cadet Pinball - work fine.

When run from a command line, I get these errors:
/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.200.3/Common/ChunkCompression.cpp:49: Error: unsupported compressor 8
/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.200.3/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Library/AppExceptions.bundle/Exceptions.plist'
0009:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.

but I seem to recall I've always had these and it has worked anyway.

I'm using Mojave 10.14.6, and wine and xquartz were both installed from a pkg (not homebrew).

Any suggestions?
Do you actually remember what wine version ran this software correctly each launch?
Don’t use PlayOnMac/Winebottler/Wineskin etc for this as test results from these won’t be accepted for bug reports.

You can ignore

Code: Select all

/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.200.3/Common/ChunkCompression.cpp:49: Error: unsupported compressor 8
/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.200.3/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Library/AppExceptions.bundle/Exceptions.plist'
This isn’t a wine issue, it’s something screwy with Apples cpp headers that only affects 32Bit applications.


This section on macOS is resolved by having samba3 or greater installed and available in PATH

Code: Select all

0009:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
Installing the pkg via brew or manually makes little difference, all the wine-* cask formulas does differently is also adding symlinks for wine binaries into /usr/local/bin causing wine command to be available using a standard terminal session.

You might want to test again once Wine-5.9 packages are available as some initialization bugs were resolved within upstream recently and will land in Wine-5.9 it’s possible that could resolve your issue.

deKay
Newbie
Newbie
Posts: 3
Joined: Wed May 20, 2020 3:13 am

Re: Only title bar appears for Forte Agent

Post by deKay » Wed May 20, 2020 9:36 am

Every version of wine I have used in the past, starting with 1.something and most recently 4.0.2, has almost always worked. It was rare this would happen.

I upgraded from that to 5.0 this week to try to fix the problem, it didn't.

I no longer have any other variety of wine like PlayOnMac on my computer.

It's just strange that it stopped working without any changes to my system (no updates, no new software) and the usual fixes did nothing.

Thanks for the reply. If it doesn't magically sort itself I'll try 5.9 when that's available. In the meantime, are there any other files lurking anywhere (like ~/.wine) which might need removing? Some sort of config-for-this-app file?

deKay
Newbie
Newbie
Posts: 3
Joined: Wed May 20, 2020 3:13 am

Re: Only title bar appears for Forte Agent

Post by deKay » Tue May 26, 2020 3:21 am

Well, without doing anything since my last post, but trying to launch Agent every day, today it worked.

No updates, no reboots, no file deletions, nothing. Yesterday it didn't work, today it did.

Post Reply