Inno Setup Runtime Error

Questions about Wine on macOS.
Post Reply
Dominus
Level 1
Level 1
Posts: 9
Joined: Sun Nov 15, 2009 4:19 pm

Inno Setup Runtime Error

Post by Dominus » Sun Apr 26, 2020 4:33 pm

I am part of Exult (http://exult.sf.net) and our installer for Windows is an Inno Setup that loads an external dll (which only depends on msvcrt.dll). This used to work but doesn't for a while now. In my testing this seems to be a regression in Wine.
It works with Crossover 18 (based on Wine 3.14) but stopped working with Crossover 18.1 (also based on Wine 3.14). I also today tried with Wine version (4.0.3) supplied by macports and right now building the very tip of wine's git.
Unfortunately my machine I can still test this is a very weak MacMini so bisecting is likely to take forever (my main machine is on macOS 10.15, so there is a problem)
Does anyone have an idea when it went to hell?

An older topic (viewtopic.php?f=8&t=29640&p=112726&hili ... up#p112726) seems to point at https://bugs.winehq.org/show_bug.cgi?id=43940 but that was resolved.

terminal output of running the installer in Wine 4.0.3

Code: Select all

wine /Users/buildbot/Downloads/Exultwin32.exe 
0009:fixme:process:SetProcessDEPPolicy (1): stub
002c:fixme:process:SetProcessDEPPolicy (1): stub
002c:fixme:win:DisableProcessWindowsGhosting : stub
002c:fixme:graphics:ShutdownBlockReasonDestroy (0x10082): stub
002c:fixme:graphics:ShutdownBlockReasonCreate (0x10082, L"Installing"): stub
002c:fixme:graphics:ShutdownBlockReasonDestroy (0x10082): stub
I'll report on the latest git, as soon as that finishes to compile :(

Gcenx
Level 6
Level 6
Posts: 528
Joined: Mon Dec 25, 2017 12:11 pm

Re: Inno Setup Runtime Error

Post by Gcenx » Sun Apr 26, 2020 6:55 pm

Could you link to the installer your having issues with, as I downloaded a couple and they installed just fine using my build of wine-staging-5.7

Yeah Ryan on macports seems to be resistant to upgrading the wine Portfile to recent versions, I ended up just maintaining my own Portfiles to cover this, including building on Mojave (using a patch and 10.13SDK) and also building wine64 on Catalina

Dominus
Level 1
Level 1
Posts: 9
Joined: Sun Nov 15, 2009 4:19 pm

Re: Inno Setup Runtime Error

Post by Dominus » Mon Apr 27, 2020 7:37 am

Thanks much appreciated if you could try it out. I'm having problems getting Wine to build in 32bit, I used to be able to but for some reasons it builds parts in 32bit and others in 64bit. I'll figure it out eventually :)

One that fails is http://exult.sourceforge.net/snapshots/Exultwin32.exe and also our latest release http://prdownloads.sourceforge.net/exul ... -win32.exe

Gcenx
Level 6
Level 6
Posts: 528
Joined: Mon Dec 25, 2017 12:11 pm

Re: Inno Setup Runtime Error

Post by Gcenx » Mon Apr 27, 2020 8:53 am

It fails in both of these installers complaining about execonfig.dll not being found but I did find it within the listed location, setting it to native/builtin also doesn’t help.

Tested it in wine-crossover-19.0.1, same problem.

Seem you might wanna create a bug report for the issue if one doesn’t already exist.

Wine now requires mingw to be installed to compile correctly, clang fails to build PE binaries correctly so it’s pretty much a hard requirement now.

You can find my Portfiles here macports-wine, it contains wine-stable/wine-devel/wine-staging/wine-crossover Portfiles that install the latest version of wine for the selected branch and will install most of the required dependencies bar gstreamer plug-ins those can be installed by using the +ffmpeg flag when installing that will also enforce FAudio to wma audio support.

If your running Mojave on the Mac mini use the provided patch and place a 10.13 SDK in the location mentioned, now you can install wine-stable/wine-devel/wine-staging/wine-crossover with wine & wine64, on Catalina based systems it will only build wine64 for obvious reasons.

Dominus
Level 1
Level 1
Posts: 9
Joined: Sun Nov 15, 2009 4:19 pm

Re: Inno Setup Runtime Error

Post by Dominus » Mon Apr 27, 2020 10:25 am

Thank you for confirming, you are right it's now time to file a bug report.

I'll take a look at your portfiles, much easier when everything is neatly listed in a portfile :)

https://bugs.winehq.org/show_bug.cgi?id=49033

Gcenx
Level 6
Level 6
Posts: 528
Joined: Mon Dec 25, 2017 12:11 pm

Re: Inno Setup Runtime Error

Post by Gcenx » Mon Apr 27, 2020 11:39 am

Just an FYI not all Ports default to +universal and Mingw if called in that manner will fail to compile.

If I’m free after work today I’ll add another Portfile that just installs what’s required to compile wine from source.

Post Reply