Having problems getting Wine to work on High Sierra 10.13.6

Questions about Wine on macOS.
Post Reply
BiggusDickus
Newbie
Newbie
Posts: 2
Joined: Sat Mar 21, 2020 10:28 pm

Having problems getting Wine to work on High Sierra 10.13.6

Post by BiggusDickus » Sat Mar 21, 2020 10:32 pm

I downloaded the latest (5.4) staging version of Wine and XQuartz and installed both packages. When I launch the wine app and run the command winecfg the wine mono installer shows up on dock but there is no window or a gui to be found. I left it run for an hour or so but it just hangs there and nothing more than the following prints out in terminal:

Code: Select all

wine: created the configuration directory '/Users/.../.wine'
0009:fixme:esync:do_esync eventfd not supported on this platform.
000b:fixme:esync:do_esync eventfd not supported on this platform.
000b:fixme:winediag:__wine_start_process Wine Staging 5.4 is a testing version containing experimental patches.
000b:fixme:winediag:__wine_start_process Please mention your exact version when filing bug reports on winehq.org.
000d:fixme:esync:do_esync eventfd not supported on this platform.
0010:fixme:esync:do_esync eventfd not supported on this platform.
0012:fixme:esync:do_esync eventfd not supported on this platform.
0014:fixme:esync:do_esync eventfd not supported on this platform.
0014:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
0014:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
0014:err:ole:get_local_server_stream Failed: 80004002
0012:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
0012:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
0012:err:ole:get_local_server_stream Failed: 80004002
0017:fixme:esync:do_esync eventfd not supported on this platform.
I have absolutely zero experience on the subject so any pointers would be welcome.

BiggusDickus
Newbie
Newbie
Posts: 2
Joined: Sat Mar 21, 2020 10:28 pm

Re: Having problems getting Wine to work on High Sierra 10.13.6

Post by BiggusDickus » Mon Mar 23, 2020 11:09 am

So I managed to install it properly this time running it on safe mode. When I get back to normal boot though and launch wine, the processes do show up on dock but the windows they open do not appear. Nothing happens when I click the processes on dock. Any ideas on what could be preventing them to show up on normal boot?

jerryfrit
Newbie
Newbie
Posts: 2
Joined: Mon Apr 27, 2020 12:59 pm

Re: Having problems getting Wine to work on High Sierra 10.13.6

Post by jerryfrit » Mon Apr 27, 2020 1:21 pm

I am in a similar situation. I cannot get Wine 5-stable to work at all on various older Mac VMs (my host machine is running Catalina.) Upon doing 'WINEARCH=win32 winecfg' I get (partial looping output:

Code: Select all

BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.200.3/Common/ChunkCompression.cpp:49: Error: unsupported compressor 8
/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.200.3/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/Exceptions.plist'
My installation method of choice is Homebrew but this persists with a manual download. The workaround has turned out to be instead downloading and installing 4.03; after symlinking a few things into /usr/local/bin, I can then proceed with Homebrew to install winetricks (needed to install several DLLs that the desired application needs.)

So while I may offer this workaround to Pontius' good fwend in Wome :-), I have a more basic question: Is "anyone" getting Wine 5 to work on Mac? And what, if anything, did you do special. And would my using a Fusion VM make any difference?

Gcenx
Level 5
Level 5
Posts: 460
Joined: Mon Dec 25, 2017 12:11 pm

Re: Having problems getting Wine to work on High Sierra 10.13.6

Post by Gcenx » Mon Apr 27, 2020 5:07 pm

The BuildRoot error can be ignored I always get that for WineHQ compiles when using “wine” not “wine64”

What exactly isn’t working?
I have Wine-5.0 and above working on Mojave and wine64 portion working on Catalina.

Exactly what version of macOS were you running within VMWare Fusion? As I’ve had success testing my compiles on a 10.8 VM.

Mostly sticking to using my compile of wine-crossover-19.0.1 on Catalina so I can run my old 32Bit games like Red Alert 2 and Total Annihilation and Diablo 2 LOD

jerryfrit
Newbie
Newbie
Posts: 2
Joined: Mon Apr 27, 2020 12:59 pm

Re: Having problems getting Wine to work on High Sierra 10.13.6

Post by jerryfrit » Tue May 05, 2020 1:53 pm

I simple can’t get past “winecfg” on ANY VM running Mojave or less (my VM “farm” has each down to Yosemite.) I just get a couple of “wine-preloader” icons in the Dock, which just sit there.

Current Fusion on Catalina host.

Gcenx
Level 5
Level 5
Posts: 460
Joined: Mon Dec 25, 2017 12:11 pm

Re: Having problems getting Wine to work on High Sierra 10.13.6

Post by Gcenx » Wed May 06, 2020 8:51 am

As long as the needed dylibs are available in /opt/X11/lib if you ran rpath during make wine/wine64 will pickup the required dylibs and use them.

If you didn’t run rpath then you need to use

Code: Select all

export DYLD_FALLBACK_LIBRARY_PATH=/opt/X11/lib
This is needed as homebrew doesn’t provide universal libraries outside of XQuartz cask, only wine64 can use brew provided dylibs wine can’t

The alternative is to bundle the needed dylibs if your attempting to move wine from one system to another, place the needed dylibs into /lib and symlink then into /lib64

Post Reply