Dialog Box: Unable to Select Files

Questions about Wine on macOS.
Post Reply
markdflores
Newbie
Newbie
Posts: 2
Joined: Tue Mar 10, 2020 7:42 pm

Dialog Box: Unable to Select Files

Post by markdflores » Tue Mar 10, 2020 8:07 pm

Hey,

Currently have a OSX 10.14.6, wine-5.0.

Background: Computer crashed, so i started new with Mojave. installed wine via homebrew. I prefer to start fresh on the computer rather than upload my time machine.

Program: VTMS, is some fancy software developed by a university I work with. The program appears to work. All the bells and whistles. the only thing I am unable to do is open up a file. The dialog box opens but I am unable to select any files.

I attached an image of my problem. Unfortunately, I was unable to upload a small debug.txt file.

NOTE: I have opened up text editor and it does not have the same problem.

I hope it is a relatively easy fix or command...

Thanks
Attachments
dialogbox_problem.png
dialogbox

Gcenx
Level 5
Level 5
Posts: 468
Joined: Mon Dec 25, 2017 12:11 pm

Re: Dialog Box: Unable to Select Files

Post by Gcenx » Wed Mar 11, 2020 8:22 am

This one again, this issue only occurs within Winehq builds (possibly due to the 10.8 SDK being used for builds?)

You’d need to build wine from source or grab a pre-build from some somewhere like Wine-5.0 that should work for you as I’d moved Phoenicis-winebuild over to using the 10.13SDK to match my own setup.

markdflores
Newbie
Newbie
Posts: 2
Joined: Tue Mar 10, 2020 7:42 pm

Re: Dialog Box: Unable to Select Files

Post by markdflores » Tue Mar 17, 2020 2:48 pm

It appears that I have the 10.14 SDK. I have no idea to downgrade to a legacy SDK..

I have been able to successfully build wine... wine and wine64. I still have the same problem unfortunately.

I'm currently attempted to look at older SDK files if it is necessary. The stuff behind most of this stuff is confusing.

Gcenx
Level 5
Level 5
Posts: 468
Joined: Mon Dec 25, 2017 12:11 pm

Re: Dialog Box: Unable to Select Files

Post by Gcenx » Wed Mar 18, 2020 2:22 pm

markdflores wrote:
Tue Mar 17, 2020 2:48 pm
It appears that I have the 10.14 SDK. I have no idea to downgrade to a legacy SDK..

I have been able to successfully build wine... wine and wine64. I still have the same problem unfortunately.

I'm currently attempted to look at older SDK files if it is necessary. The stuff behind most of this stuff is confusing.
If you google “GitHub OS X SDK” and select the first link.

Then you pass

Code: Select all

 -isysroot/path/to/SDK/MacOSX10.13.sdk/
Replace “/path/to/SDK accordingly

However I don’t have any clue on your build environment you could be missing required build dependencies, while I did slightly update the macOS section recently I didn’t fully update it until macports accepts at least the mingw-binutils pull-request I sent in to fix a build issue.


You also didn’t say if the prebuilt wine-5.0 I linked to worked for you or not, that would be good to know as I’m involved in maintaining the Darwin size of that builder.

Lastly giving some terminal output might also be hardly as it’s possible some winetricks verbs might resolve it.

Post Reply