Wine 4.0.3 Stable not opening

Questions about Wine on macOS.
Post Reply
markwozere
Level 2
Level 2
Posts: 13
Joined: Fri Dec 16, 2016 11:19 am

Wine 4.0.3 Stable not opening

Post by markwozere » Sat Dec 14, 2019 8:01 am

My MacBook updated with the new operating system and my version of Wine stable I had installed (3.0.4) no longer runs so I downloaded 4.0.3 as the most recent stable download showing on the WineHQ site and every time I try and open the installer I receive this message:-

"winehq-stable-4.0.3.pkg” can’t be opened because Apple cannot check it for malicious software"

Any ideas how I can get round this?

FYI, I am a bit of a Wine novice so will need an idiots guide as help!

Thanks all.

Gcenx
Level 5
Level 5
Posts: 468
Joined: Mon Dec 25, 2017 12:11 pm

Re: Wine 4.0.3 Stable not opening

Post by Gcenx » Sat Dec 14, 2019 9:24 am

The reason for this is the pkg is unsigned.

You can allow unsigned applications by launching terminal and entering

Code: Select all

sudo spctl --master-disable
Now you can launch unsigned applications bundles.

Moved the already downloaded pkg installer to trash, now download it again then move it from downloads to your desktop then launch while holding “Option” on the menu select “Open” you should be asked if your sure you want to open application from unidentified developer, give it permission and it will launch the installer.

markwozere
Level 2
Level 2
Posts: 13
Joined: Fri Dec 16, 2016 11:19 am

Re: Wine 4.0.3 Stable not opening

Post by markwozere » Sat Dec 14, 2019 10:32 am

Thanks, that worked.

However, it seems this version isn't compatible with the new Catalina OS on Mac.

Any idea when a new version will be brought out which is compatible?

Gcenx
Level 5
Level 5
Posts: 468
Joined: Mon Dec 25, 2017 12:11 pm

Re: Wine 4.0.3 Stable not opening

Post by Gcenx » Sat Dec 14, 2019 11:04 am

markwozere wrote:
Sat Dec 14, 2019 10:32 am
Thanks, that worked.

However, it seems this version isn't compatible with the new Catalina OS on Mac.

Any idea when a new version will be brought out which is compatible?
Oh your on Catalina, yeah only wine64 works on that right now and CrossOver19.

You can wait until CodeWeavers upstream the wine32on65 patch sets (sometime within the Wine-5.x to Wine-6.0 lifetime with luck) or just purchase CrossOver19

markwozere
Level 2
Level 2
Posts: 13
Joined: Fri Dec 16, 2016 11:19 am

Re: Wine 4.0.3 Stable not opening

Post by markwozere » Fri Jan 24, 2020 12:49 pm

I have seen that the new Wine 5.0 has been released.

Is this compatible with Catalina?

Gcenx
Level 5
Level 5
Posts: 468
Joined: Mon Dec 25, 2017 12:11 pm

Re: Wine 4.0.3 Stable not opening

Post by Gcenx » Fri Jan 24, 2020 2:33 pm

No, CodeWeavers will work on CrossOver-20 before you see anything compatible with macOS Catalina.

- You can purchase CrossOver and use that today.
- Compile CrossOver-Wine and disable SIP (needed to set LDT for 32Bit code execution)
- Wait, they will announce when you can use Winehq releases on macOS Catalina

Post Reply