CaesarIV wine runtime error

Questions about Wine on macOS.
Post Reply
Alex1431
Newbie
Newbie
Posts: 1
Joined: Sat Jun 22, 2019 2:16 pm
Location: FR

CaesarIV wine runtime error

Post by Alex1431 » Sat Jun 22, 2019 4:03 pm

Hi everybody, this is my first post on the forum.

I just discovered wine and the potential of such great tools, and clearly I'm a newbie, but I really want to use it as well, so forgive me if I miss something, during my explanations.

MacOS 10.12.6 Sierra. Porting Kit 2.9, Wine 4.0.1,Caesar IV ??

So, here is my problem, I've got this old game that I bought legaly online, and as we know this game never existed for MacOs .

I follow a protocol on a video, for install Caesar IV and at the final point of the wine process, I have a error message says that my product cannot be install on a anterior version of windows 2000, or ME and NT 4. After that many messages like "Runtime error at..." " invalid Opcode" "Out of global vars range" and I don't even know what's that mean. I tried to open wine terminal, checked winecfg and put windows xp or 7 on, see if that work, absolutely not. I tried to reinstall, wine 4.0.1, I have also Wineskyn winery 1.7, I also tried to reinstall Porting kit but always the same results.

If someone have any idea, I really be enjoyed to share with you on that situation.

Gcenx
Level 5
Level 5
Posts: 294
Joined: Mon Dec 25, 2017 12:11 pm

Re: CaesarIV wine runtime error

Post by Gcenx » Sat Jun 22, 2019 11:16 pm

Let me give you the Winehq response, Third party utilities are not supported here.

Since your using PortingKit post on their own forms so PaulTheTall can look into fixing the issues your having with the ports.

The official Wineskin project hasn't been updated in years, PortingKit is now using Unofficial Wineskin as the base for wine wrapper based ports.
If you want a working and updated version of "Wineskin Winery" grab mine unpackage "Unofficial.Wineskin.Winery.zip" also unlike the original release I use Winehq releases so Wine-2.0 to the current Wine-4.11 releases. For Wineskin related support you might want to try posting on PortingTeam

Maximara
Level 1
Level 1
Posts: 5
Joined: Wed Jun 26, 2019 8:01 am

Re: CaesarIV wine runtime error

Post by Maximara » Wed Jun 26, 2019 5:16 pm

I have found running straight Wine (using the pkg version because may efforts to compile generally don't work) is a more satisfactory experience. Other options just add a layer of uncertainty (which is why they are not supported here)

1) Install Wine with a pkg file.
2) Configure your MacOS to have Wine open .exe files.
3) It if is an installer let it run (and hopefully that works).
4) Find the drive_c folder (spotlight is the best option for this).
5) Click and hold the mouse button that brings up the menu with the Open With... option.
6) If you did step 1 correctly Wine should be the default. If not and it is not on the short list select other and choose wine
7) Either the program runs or it produces errors. I have found that some programs require you quit Wine and then reopen the program and it runs.

Post Reply