.exe install shield dont finish

Questions about Wine on macOS.
Post Reply
Schebi
Newbie
Newbie
Posts: 3
Joined: Fri May 24, 2019 9:07 am

.exe install shield dont finish

Post by Schebi » Fri May 24, 2019 9:25 am

Hello,

I'm new in forum and also at using wine.
I have an older macbook pro with ElCapitan and want to run Creo-Elements-Modellingsoftware.

Now i installed xquartz and wine 4.0, downloaded the .exe and doubleclicked on it.
The .exe will start the installshield.
After that a window appears that it stopped without full installation and i have to finish with start the installshield a second time.

Nothing happens, always the same window and i dont know what is my failure.

Thanks for helping me!
Regards from Austria,
Schebi

Gcenx
Level 5
Level 5
Posts: 275
Joined: Mon Dec 25, 2017 12:11 pm

Re: .exe install shield dont finish

Post by Gcenx » Sat May 25, 2019 11:25 am

First the current Wine-Stable is 4.0.1

Second don’t launch via double clicking and expect it to work, you need to launch the “Wine Stable” application, then a new terminal window will open, now type;

Code: Select all

wine /path/to/my/program.exe
An actual real example on my system would be;

Code: Select all

wine /users/gcenx/downloads/setup.exe
Now while your trying to run the installer it will give you a lot of information, now when it crashes you wan to copy all the information from Terminal into a text document and attach here so we can look over it and possibly offer advice on how to get the application working.

Just double clicking won’t give any debut information meaning nobody. An even try to help you, unless they are famialiwr with the application already.

Schebi
Newbie
Newbie
Posts: 3
Joined: Fri May 24, 2019 9:07 am

Re: .exe install shield dont finish

Post by Schebi » Sat May 25, 2019 11:50 am

Hello Gcenx,

thanks for your answer, but at trying this, the same problem comes out.

Gernots-MBP:~ Schebi$ wine /Users/Schebi/Downloads/ModelingPE__setup_DE.exe
0009:fixme:ole:CoInitializeSecurity (0x32ee48,-1,0x0,0x0,6,2,0x0,8192,0x0) - stub!
0009:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
002a:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
0035:fixme:vbscript:parser_lex '_' not followed by newline
0035:fixme:vbscript:parse_script parser failed around L"\", \"5129\", \"6153\", _\r\n \"7177\", \"8201\", \"9225\", \"10249\", \"11273\"\r\n svInstallLang = \"english\"\r\n svLanguageID = \"1033\"\r\n\r\n Case \"1034\", \"2058\", \"3082\", \"4106\", \"5130\", \"6154\", \"7178\", \"8202\", \"9226\", _\r\n \"10250\", \"11"...
002a:err:msi:ITERATE_Actions Execution halted, action L"ExportProperties" returned 1603
Gernots-MBP:~ Schebi$

And that's it. Nothing happens.

Schebi
Newbie
Newbie
Posts: 3
Joined: Fri May 24, 2019 9:07 am

Re: .exe install shield dont finish

Post by Schebi » Mon May 27, 2019 12:50 pm

I don't know what is the problem.
I only want to run this software.

Can somebody help me please?

jkfloris
Level 6
Level 6
Posts: 624
Joined: Thu Aug 14, 2014 10:10 am

Re: .exe install shield dont finish

Post by jkfloris » Mon May 27, 2019 4:50 pm

On Debian Linux I get the same error, but I can get to the activation window with:
- Wine 4.9
- 32-bit Wineprefix
- winetricks dotnet20sp2 wsh57

Gcenx
Level 5
Level 5
Posts: 275
Joined: Mon Dec 25, 2017 12:11 pm

Re: .exe install shield dont finish

Post by Gcenx » Wed May 29, 2019 9:23 am

Schebi wrote:I don't know what is the problem.
I only want to run this software.

Can somebody help me please?
I’m not sure I was going to say so what @jkfloris said but it didn’t work for them so I’m not sure without testing it myself.

jkfloris wrote:On Debian Linux I get the same error, but I can get to the activation window with:
- Wine 4.9
- 32-bit Wineprefix
- winetricks dotnet20sp2 wsh57
I would have thought what’s you have done would have gotten it working strange

Post Reply