WineHQ
Wine Forums

Board index » WineHQ » Wine Help » macOS




 Page 1 of 1 [ 6 posts ] 



 
Author Message
 Post subject: Winetricks under macOS
 Post Posted: Mon May 06, 2019 9:10 am 
Offline
Newbie
Newbie

Joined: Mon May 06, 2019 9:01 am
Posts: 4
I've got a program (Estlcam) working with Wine on Ubuntu using nothing more that Winetricks dotnet40. I'm having a lot of trouble getting the same to work on macOS.

Estlcam seems to install, but crashes when I try and run it. The workaround of installing Winetricks dotnet40 also fails and I'm a bit stuck. I installed Winetricks using homebrew and that seemed to go well.


Top 
 Post Posted: Mon May 06, 2019 8:51 pm 
Offline
Level 4
Level 4

Joined: Mon Dec 25, 2017 12:11 pm
Posts: 214
SX-70 wrote:
I've got a program (Estlcam) working with Wine on Ubuntu using nothing more that Winetricks dotnet40. I'm having a lot of trouble getting the same to work on macOS.

Estlcam seems to install, but crashes when I try and run it. The workaround of installing Winetricks dotnet40 also fails and I'm a bit stuck. I installed Winetricks using homebrew and that seemed to go well.


Winetricks from homebrew works just fine, but that wine version are you running on macOS?

I hope you didn't install wine via homebrew as that's missing features that even the winehq builds come with and those I consider lacking in features.

I'm having no issues with winetricks -q dotnet46 so dotnet40 shouldn't be an issue on your end.
Im running Mojave with Wine-Staging-4.7


Top 
 Post Posted: Mon May 06, 2019 9:59 pm 
Offline
Newbie
Newbie

Joined: Mon May 06, 2019 9:01 am
Posts: 4
I installed the macOS package of WineHQ, so I'm good on that front. I'll try the install string you used and go from there.


Top 
 Post Posted: Thu May 09, 2019 4:15 pm 
Offline
Newbie
Newbie

Joined: Mon May 06, 2019 9:01 am
Posts: 4
Some progress, I have dotnet40 installed, but it looks like the Estlcam install isn't good. The .exe is in the Program Files folder but when I try and run it there are a number of "fixme" and unknown compression lines, followed by a straight up "the program's not there" message.

Craighs-MacBook-Pro:Program Files xxxxxxxxx$ wine Estlcam11.exe
0012:fixme:wer:WerSetFlags (2) stub!
0012:fixme:heap:RtlSetHeapInformation 0x0 1 0x0 0 stub
0019:fixme:process:SetProcessShutdownParameters (00000380, 00000000): partial stub.
0019:fixme:ntdll:EtwEventRegister ({319dc449-ada5-50f7-428e-957db6791668}, 0x991925, 0x9ddbd0, 0x9ddbe8) stub.
0019:fixme:ntdll:EtwEventSetInformation (deadbeef, 2, 0x972f3d, 28) stub
/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.200.3/Common/ChunkCompression.cpp:49: Error: unsupported compressor 8
/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.200.3/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/Exceptions.plist'
/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.200.3/Common/ChunkCompression.cpp:49: Error: unsupported compressor 8
/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.200.3/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Library/AppExceptions.bundle/Exceptions.plist'
0014:err:display:macdrv_ChangeDisplaySettingsEx No matching mode found 1680x1050x32 @60!
/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.200.3/Common/ChunkCompression.cpp:49: Error: unsupported compressor 8
/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.200.3/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/Exceptions.plist'
/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.200.3/Common/ChunkCompression.cpp:49: Error: unsupported compressor 8
/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.200.3/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Library/AppExceptions.bundle/Exceptions.plist'
wine: cannot find L"C:\\windows\\system32\\Estlcam11.exe"
xxxxxxxx-MacBook-Pro:Program Files xxxxxxxxxxx$ 0012:fixme:ntdll:EtwEventUnregister (deadbeef) stub.


Top 
 Post Posted: Thu May 09, 2019 7:08 pm 
Offline
Level 4
Level 4

Joined: Mon Dec 25, 2017 12:11 pm
Posts: 214
SX-70 wrote:
Some progress, I have dotnet40 installed, but it looks like the Estlcam install isn't good. The .exe is in the Program Files folder but when I try and run it there are a number of "fixme" and unknown compression lines, followed by a straight up "the program's not there" message.


Here is the only parts we need to care about
Code:
Craighs-MacBook-Pro:Program Files xxxxxxxxx$ wine Estlcam11.exe
0012:fixme:wer:WerSetFlags (2) stub!
0012:fixme:heap:RtlSetHeapInformation 0x0 1 0x0 0 stub
0019:fixme:process:SetProcessShutdownParameters (00000380, 00000000): partial stub.
0019:fixme:ntdll:EtwEventRegister ({319dc449-ada5-50f7-428e-957db6791668}, 0x991925, 0x9ddbd0, 0x9ddbe8) stub.
0019:fixme:ntdll:EtwEventSetInformation (deadbeef, 2, 0x972f3d, 28) stub
0014:err:display:macdrv_ChangeDisplaySettingsEx No matching mode found 1680x1050x32 @60!
wine: cannot find L"C:\\windows\\system32\\Estlcam11.exe"
xxxxxxxx-MacBook-Pro:Program Files xxxxxxxxxxx$ 0012:fixme:ntdll:EtwEventUnregister (deadbeef) stub.


From what I can see your not within the correct folder when trying to launch "Estlcam11.exe"

See this message;
Code:
wine: cannot find L"C:\\windows\\system32\\Estlcam11.exe"

wine to trying to load your game/program from "C:\\windows\\system32\\"

If your running a 64Bit prefix your program unless its 64Bit would be installed into
C:\Program Files (x86)\ < for 32Bit within a 64Bit prefix
C:\Program Files\ < For 64Bit or a 32Bit only prefix.


Top 
 Post Posted: Thu May 09, 2019 7:29 pm 
Offline
Newbie
Newbie

Joined: Mon May 06, 2019 9:01 am
Posts: 4
The path I'm running from is .wine/drive_c/Program Files and the Estlcam.exe is in that folder. On my Ubuntu install Estlcam.exe is in the Program Files (x86) folder along with its uninstaller.

I think the best thing to do is reinstall Elstcam on the Mac. The install that is there now went really quickly (compared to Ubuntu) and I assume it's stuffed up.


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 6 posts ] 




Board index » WineHQ » Wine Help » macOS


Who is online

Users browsing this forum: Google [Bot] and 3 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: