Wine v2.0.4 won't open; errors

Questions about Wine on macOS.
Post Reply
The_SamminAter
Level 2
Level 2
Posts: 38
Joined: Sun Sep 09, 2018 6:16 pm
Location: Earth

Wine v2.0.4 won't open; errors

Post by The_SamminAter » Tue Apr 16, 2019 7:26 pm

Whenever I try to open anything (I'm using Resource Hacker as an example here) with Wine Stable v2.0.4, Wine launches and then quits.
When I try to open any application w/ terminal, I get this:

Code: Select all

$ wine /Applications/Resource\ Hacker/ResourceHacker.exe 
wine client error:0: version mismatch 547/524.
Your wine binary was not upgraded correctly,
or you have an older one somewhere in your PATH.
Or maybe the wrong wineserver is still running?
I just installed Wine Stable 2.0.4, after deleting it to try and fix this problem

With Wine Devel v4.0-rc2, I get a similar error:

Code: Select all

$ wine /Applications/Resource\ Hacker/ResourceHacker.exe 
wine client error:0: version mismatch 547/571.
Your wineserver binary was not upgraded correctly,
or you have an older one somewhere in your PATH.
Or maybe the wrong wineserver is still running?
Only Wine Stable 3.0 currently works.

How can I use Wine Stable v2.0.4 again?

Also, what are the differences between v2, v3, and v4? I've noticed that v2 is often faster with games (Grand Theft Auto IV for example), which is why I still use it.

Edit:
I'm now using Wine Stable v4.0 instead of Wine Devel v4.0

Gcenx
Level 5
Level 5
Posts: 295
Joined: Mon Dec 25, 2017 12:11 pm

Re: Wine v2.0.4 won't open; errors

Post by Gcenx » Wed Apr 17, 2019 1:05 pm

It says within the error that you have another wine version within PATH, did you ever also install wine via homebrew/macports/flick or some other package manager?

The_SamminAter
Level 2
Level 2
Posts: 38
Joined: Sun Sep 09, 2018 6:16 pm
Location: Earth

Re: Wine v2.0.4 won't open; errors

Post by The_SamminAter » Wed Apr 17, 2019 1:19 pm

Gcenx wrote:It says within the error that you have another wine version within PATH, did you ever also install wine via homebrew/macports/flick or some other package manager?
Nope, and I also have no idea what PATH is

Gcenx
Level 5
Level 5
Posts: 295
Joined: Mon Dec 25, 2017 12:11 pm

Re: Wine v2.0.4 won't open; errors

Post by Gcenx » Thu Apr 18, 2019 9:00 am

The_SamminAter wrote:
Gcenx wrote:It says within the error that you have another wine version within PATH, did you ever also install wine via homebrew/macports/flick or some other package manager?
Nope, and I also have no idea what PATH is
First try rebooting your Mac as you could still have wineserver processes open from a version of wine you removed.

PATH is a environment verbal, in a clean terminal window you can launch what’s within the current folder and also what’s listed under PATH.


From terminal you can do “echo $PATH” that will show what’s accessible from terminal regardless of the current folder.
The “Wine Stable.app” and other versions when launched set “PATH” to ensure all the parts of “wine” are accessible from the launched terminal process.
Within the macOS wiki I gave an example to configure PATH so “wine” is a usable command without needing to launch “Wine Stable.app” each time but instead works directly from “terminal”
The thing with PATH is if you have multiple copies of wine within it it can cause problems, so only one should be enabled at a time.

Post Reply