Some MIDI commands don't work correctly on most programs

Questions about Wine on macOS.
Post Reply
speedydtm
Newbie
Newbie
Posts: 2
Joined: Sat Apr 13, 2019 11:01 am

Some MIDI commands don't work correctly on most programs

Post by speedydtm » Sat Apr 13, 2019 11:10 am

Hi,

I'm trying to run a few games and emulators that use MIDI output on macOS (I'm on 10.14.4 Mojave) and I'm running into a very bizarre issue - seemingly most commands work fine, like Note On/Off, SysEx, etc, but not Bank Select or Program Changes. I've gotten them to work in one program, Sekaiju, but the three others I tried (qzDOOM, Neko Project II fmgen, XM6 Type-G) don't work.

I tried to see if it was maybe something with my audio interfaces but it's not - watching the activity being sent to my MIDI interfaces via a program called MIDI Monitor shows no Program/Bank changes are being sent. Am I just missing something simple?

Thank you

speedydtm
Newbie
Newbie
Posts: 2
Joined: Sat Apr 13, 2019 11:01 am

Re: Some MIDI commands don't work correctly on most programs

Post by speedydtm » Mon Jan 13, 2020 10:31 pm

Hi again!

Bumping this thread because I found out what was wrong and wanted to mention it to anyone else who may have the same issue. The problem has to do with particular MIDI interfaces in WINE - not sure why but class compliant devices like the Roland UM series and SD-90, and Yamaha USB MIDI devices like the Motif ES8 and MU1000 are fine, but some specialty drivers like the old M-Audio MIDISport ones don't work. x_x

User avatar
DarkShadow44
Level 8
Level 8
Posts: 1057
Joined: Tue Nov 22, 2016 5:39 pm

Re: Some MIDI commands don't work correctly on most programs

Post by DarkShadow44 » Thu Jan 16, 2020 5:31 pm

Are you talking about something in WINE or in macOS? I don't quite understand where the problem lies.

Post Reply