WineHQ
Wine Forums

Board index » WineHQ » Wine Help » macOS




 Page 1 of 1 [ 2 posts ] 



 
Author Message
 Post Posted: Wed Dec 26, 2018 5:06 pm 
Offline
Newbie
Newbie

Joined: Wed Dec 26, 2018 4:45 pm
Posts: 1
Hey together,
I´ve got a question regarding the mounting of ISO files on macOs connected to the usage of Wine.

Description:
I´m trying to get an old chess game to work on my macBook pro (13 inches, Sierra version 10.12.6). The game is written for Windows so I installed WineBottler and Wine in order to be able to run it. The installation worked well and I have a .exe-file that I can execute in Wine and that should open the program. My problem is that the program asks for the original CD as soon as I try to ope it. To address this problem I created an ISO file for the CD. Even if I set the pointer of d:: in the Wine configurations to the directory where the ISO file is located, however, it seems that Wine cannot recognise it and the error keeps appearing. I also tried to set the pointer of d:: to the subdirectory of /Volumes where the disk appears after connecting it to the laptop using an external driver. This did not work either.
I read on some forums that I would need to "mount" the ISO file in order to make it readable for Wine. This mounting is what I am concerned about know. First I do not understand what is actually meant by "mounting" in this case. Second I don´t know how to achieve it in a way that works for me.

What I already know/have tried:
I read instructions on how to address this problem on Ubuntu from here: https://askubuntu.com/questions/55275/h ... ve-in-wine
where the most important hint is to run

mount -o loop -t iso 9660 <path/to/iso> <dir/for/mounted/iso>

in a Terminal. This failed on my machine with the error message:

mount: exec /Library/Filesystems/iso9660.fs/Contents/Resources/mount_iso9660 for /media/wincd: No such file or directory

I am 100% sure though that the directory exists actually. Following this problem I tried to install "loop" as a kernel extension as it seemed not to be present on my machine but this didn't work either. The installation failed because some permission was denied even though I ran it as admin with sudo.
After that I searched for mounting an ISO image on macOs. I found out that CDs in an external driver are usually automatically mounted and appear on the Desktop and appear in in /Volumes directory. This was no help, however, because setting the driver path in the Wine configurations to /Volumes/<iso name> did not solve the problem. I further read that Wine would need read/write access what is not possible to be granted to any subdirectory of /Volumes (I have it as user but it is not possible to grant in to group, not even with sudo) and the only hints I found about mounting the iso file to a given place included the mount-command on the Terminal. I also tried to set the advanced settings of the Wine driver-pointer to "CD-ROM" without any outcome.

Note: I have not installed Wine as a command line application so I am not able to run any wine-commands in my Terminal. I´m not sure whether or not this has something to do with the problem.

Help is very appreciated.
Merry Christmas


Top 
 Post Posted: Thu Dec 27, 2018 1:18 pm 
Offline
Level 3
Level 3

Joined: Mon Dec 25, 2017 12:11 pm
Posts: 85
Your using Winebottler version of wine not an offical winehq wine version. For support here install XQuartz then an offical winehq wine version.

Trying to mount the iso using a guide for Ubuntu is not a good idea, just double click the iso to mount it then from the wine.app Terminal launch “wine winecfg” that will pickup the mounted iso as CD-ROM drive for you.


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 2 posts ] 




Board index » WineHQ » Wine Help » macOS


Who is online

Users browsing this forum: No registered users and 6 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron