when using a program i keep getting this error message ...

Questions about Wine on macOS.
Post Reply
concept
Newbie
Newbie
Posts: 1
Joined: Fri Dec 07, 2018 11:22 pm

when using a program i keep getting this error message ...

Post by concept » Fri Dec 07, 2018 11:44 pm

Hi, I'm not very tech savvy, I'm mentioning this upfront so anyone who decides to help can better understand how to explain this to me.

I'm on a mac running Mojave, and i installed wine hq devel 3.21, and before i could run it, i had to install quartz, i did so, and rebooted and tried to install the main program i plan on using which is called subtitle edit, and got messages telling me that i needed a couple of things gecko and i think something called mono. i apologize for not being clearer, but i didn't write this down when doing it. after those things were installed i was able to install subtitle edit.

My problem is that there are functions on this particular program that involve downloading things from the internet. for instance, if i open a subtitle in a language other than English, i can use google translate to translate it, but when it tries to access google, or download a video player for the application, it says, "Error secure channel failure (the authentication or decryption has failed"

i tried googling this error message and saw a post that was way over my head, saying that mono doesn't know how to trust certain things, so it denies everything. in that post they suggested various methods, that were again, way over my head, about how to trick your computer into saying yes to it all the time, and then another guy said this isn't good for your security.

basically in a nutshell, the program i want to use is largely unusable, because it's not allowed to download things it needs to function properly.

does anyone know why this is happening, and how to correct this?

does anyone know if I'd be better off using wine bottler and then maybe mono wouldn't be in the equation? and then this problem might not exist?

any help would be greatly appreciated.

thanks in advance,

jkfloris
Level 6
Level 6
Posts: 658
Joined: Thu Aug 14, 2014 10:10 am

Re: when using a program i keep getting this error message .

Post by jkfloris » Fri Dec 21, 2018 6:15 pm

You don't need wine to run this program. If you download the "portable version" [1] you can use mono [2] to run this program.

Code: Select all

mono SubtitleEdit.exe
[1] https://github.com/SubtitleEdit/subtitleedit/releases
[2] https://www.mono-project.com/download/s ... wnload-mac

Post Reply