WineHQ
Wine Forums

Board index » WineHQ » Wine Help » macOS




 Page 1 of 1 [ 6 posts ] 



 
Author Message
 Post Posted: Tue Nov 06, 2018 1:48 pm 
Offline
Newbie
Newbie

Joined: Tue Nov 06, 2018 1:34 pm
Posts: 4
Hello

Yesterday I installed a game called Capitalism Lab and everything runs well, except that there is a problem with refreshing the screen.
The screen keeps with the old image until the cursor cross the affected area… This video explains everything: https://youtu.be/vU1xHM20dp0

May be this is related with drivers?
Anyone knows how to fix it?


Top 
 Post Posted: Wed Nov 07, 2018 7:46 am 
Offline
Level 12
Level 12
User avatar

Joined: Sat Oct 16, 2010 7:40 pm
Posts: 2337
Location: Cambridge
@ipozow

Make sure your Wine version isn't years out-of-date... (Yes this can happen... Really!!)
See: WineHQ Download.

Please can you post a terminal log, with something like:
Code:
export WINEDEBUG=+timestamp,+tid,+wgl
wine start ... &>~/wine_log.txt

(fixing the path for your game executable obviously!)

If posting terminal logs, inline, in a forum post...
Then please use the forum Code tags:
Code:
...
to delimit blocks of terminal commands and output.

Please also post the terminal command you used to launch the game and indicate what directory you are running this command from:
Code:
pwd


See: Wine User's Guide: 3 Using Wine.

The output from:
Code:
glxinfo | egrep '^[[:alpha:]]'

- would also be quite useful.

Also the Capitalism Lab Support FAQ indicates that Capitalism Lab has a Windows XP mode.

So you might want to setup a custom 32-bit WINEPREFIX (if you are using a 64-bit Linux OS) for your game, e.g. something like:
Code:
export WINEPREFIX="${HOME}/.wine32"
WINEARCH=win32 wineboot -u
winetricks winxp

Then install your game to this new 32-bit WINEPREFIX.

Thanks
Bob


Top 
 Post Posted: Wed Nov 07, 2018 9:17 am 
Offline
Newbie
Newbie

Joined: Tue Nov 06, 2018 1:34 pm
Posts: 4
I am using Wine Devel, so I think that is updated.
Also I tried first with CrossOver and it's the same issue.
Also tried with Wine 3.19 but using PlayOnMac, and it's the same. With this and CrossOver one I selected to simulate Windows XP and nothing. I installed it in as 32 bit and nothing changed.

To open the game I just right clicked the executable -> open with -> wine Devel

The output from:
Code:
glxinfo | egrep '^[[:alpha:]]'

Code:
name of display: /private/tmp/com.apple.launchd.JY4yhA2Lx3/org.macosforge.xquartz:0
display: /private/tmp/com.apple.launchd.JY4yhA2Lx3/org.macosforge.xquartz:0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
client glx extensions:
GLX version: 1.4
GLX extensions:
OpenGL vendor string: Intel Inc.
OpenGL renderer string: Intel(R) Iris(TM) Plus Graphics 640
OpenGL version string: 2.1 INTEL-12.2.17
OpenGL shading language version string: 1.20
OpenGL extensions:


This didn't work for me:
Bob Wya wrote:
Please can you post a terminal log, with something like:
Code:
export WINEDEBUG=+timestamp,+tid,+wgl
wine start ... &>~/wine_log.txt

(fixing the path for your game executable obviously!)


Top 
 Post Posted: Wed Nov 07, 2018 4:51 pm 
Offline
Level 3
Level 3

Joined: Mon Dec 25, 2017 12:11 pm
Posts: 59
ipozow wrote:
I am using Wine Devel, so I think that is updated.
Also I tried first with CrossOver and it's the same issue.
Also tried with Wine 3.19 but using PlayOnMac, and it's the same. With this and CrossOver one I selected to simulate Windows XP and nothing. I installed it in as 32 bit and nothing changed.

To open the game I just right clicked the executable -> open with -> wine Devel

The output from:
Code:
glxinfo | egrep '^[[:alpha:]]'

Code:
name of display: /private/tmp/com.apple.launchd.JY4yhA2Lx3/org.macosforge.xquartz:0
display: /private/tmp/com.apple.launchd.JY4yhA2Lx3/org.macosforge.xquartz:0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
client glx extensions:
GLX version: 1.4
GLX extensions:
OpenGL vendor string: Intel Inc.
OpenGL renderer string: Intel(R) Iris(TM) Plus Graphics 640
OpenGL version string: 2.1 INTEL-12.2.17
OpenGL shading language version string: 1.20
OpenGL extensions:


This didn't work for me:
Bob Wya wrote:
Please can you post a terminal log, with something like:
Code:
export WINEDEBUG=+timestamp,+tid,+wgl
wine start ... &>~/wine_log.txt

(fixing the path for your game executable obviously!)


You tried that command from the terminal that’s launched when you run Wine-Devel.app?


Top 
 Post Posted: Wed Nov 07, 2018 5:07 pm 
Offline
Newbie
Newbie

Joined: Tue Nov 06, 2018 1:34 pm
Posts: 4
Thanks

Code:
48360.420:006f:fixme:ntdll:find_reg_tz_info Can't find matching timezone information in the registry for -03, bias 240, std (d/m/y): 13/05/2018, dlt (d/m/y): 12/08/2018
48360.557:006f:fixme:exec:SHELL_execute flags ignored: 0x00000100
48360.642:0071:fixme:ntdll:find_reg_tz_info Can't find matching timezone information in the registry for -03, bias 240, std (d/m/y): 13/05/2018, dlt (d/m/y): 12/08/2018
48360.929:0071:fixme:nstc:NSTC2_fnSetControlStyle2 mask & style (0x00000004) contains unsupported style(s): 0x00000004
48360.954:0071:fixme:shell:IShellBrowser_fnSendControlMsg stub, 0x14b918 (2, 1026, a003, 0, 0x33f52c)
48360.954:0071:fixme:shell:IShellBrowser_fnSendControlMsg stub, 0x14b918 (2, 1026, a004, 1, 0x33f52c)
48360.954:0071:fixme:shell:IShellBrowser_fnSendControlMsg stub, 0x14b918 (2, 1025, a003, 1, 0x33f52c)
48360.954:0071:fixme:shell:IShellBrowser_fnSendControlMsg stub, 0x14b918 (2, 1025, a004, 1, 0x33f52c)
48364.800:0071:fixme:shell:IShellBrowser_fnOnViewWindowActive stub, 0x14b918 (0x605570)
48366.652:0071:fixme:exec:SHELL_execute flags ignored: 0x0000000c
48366.773:0074:fixme:ntdll:find_reg_tz_info Can't find matching timezone information in the registry for -03, bias 240, std (d/m/y): 13/05/2018, dlt (d/m/y): 12/08/2018
48454.919:0071:fixme:shell:IShellBrowser_fnOnViewWindowActive stub, 0x14b918 (0x605570)
48465.749:0071:fixme:shell:IShellBrowser_fnOnViewWindowActive stub, 0x14b918 (0x605570)
48465.935:0071:fixme:exec:SHELL_execute flags ignored: 0x0000000c
48466.225:00a8:fixme:ntdll:find_reg_tz_info Can't find matching timezone information in the registry for -03, bias 240, std (d/m/y): 13/05/2018, dlt (d/m/y): 12/08/2018
48485.801:0071:fixme:shell:IShellBrowser_fnSendControlMsg stub, 0x14b918 (2, 1026, a003, 0, 0x33d4ec)
48485.801:0071:fixme:shell:IShellBrowser_fnSendControlMsg stub, 0x14b918 (2, 1026, a004, 1, 0x33d4ec)
48485.801:0071:fixme:shell:IShellBrowser_fnSendControlMsg stub, 0x14b918 (2, 1025, a003, 1, 0x33d4ec)
48485.801:0071:fixme:shell:IShellBrowser_fnSendControlMsg stub, 0x14b918 (2, 1025, a004, 1, 0x33d4ec)
48486.893:0071:fixme:shell:IShellBrowser_fnOnViewWindowActive stub, 0x14b918 (0x60e470)
48487.967:0071:fixme:shell:IShellBrowser_fnSendControlMsg stub, 0x14b918 (2, 1026, a003, 0, 0x33e09c)
48487.967:0071:fixme:shell:IShellBrowser_fnSendControlMsg stub, 0x14b918 (2, 1026, a004, 1, 0x33e09c)
48487.967:0071:fixme:shell:IShellBrowser_fnSendControlMsg stub, 0x14b918 (2, 1025, a003, 1, 0x33e09c)
48487.967:0071:fixme:shell:IShellBrowser_fnSendControlMsg stub, 0x14b918 (2, 1025, a004, 1, 0x33e09c)
48489.245:0071:fixme:shell:IShellBrowser_fnOnViewWindowActive stub, 0x14b918 (0x60dd98)
48490.246:0071:fixme:exec:SHELL_execute flags ignored: 0x0000000c
48490.550:00aa:fixme:ntdll:find_reg_tz_info Can't find matching timezone information in the registry for -03, bias 240, std (d/m/y): 13/05/2018, dlt (d/m/y): 12/08/2018
48493.962:0071:fixme:shell:IShellBrowser_fnOnViewWindowActive stub, 0x14b918 (0x60dd98)
48495.684:0071:err:shell:ICommDlgBrowser3_fnOnDefaultCommand Failed to get IDataObject.
48496.379:0071:err:shell:ICommDlgBrowser3_fnOnDefaultCommand Failed to get IDataObject.
48499.713:0071:fixme:exec:SHELL_execute flags ignored: 0x0000000c
48500.131:00ac:fixme:ntdll:find_reg_tz_info Can't find matching timezone information in the registry for -03, bias 240, std (d/m/y): 13/05/2018, dlt (d/m/y): 12/08/2018
48561.827:00a8:fixme:bidi:resolveImplicit assert failed: pcls[i] < 5
48561.827:00a8:fixme:bidi:resolveImplicit assert failed: pcls[i] < 5
(48561.828:00a8:fixme:bidi:resolveImplicit assert failed: pcls[i] < 5) this millions of times until making the file 150MB


Top 
 Post Posted: Sun Nov 11, 2018 7:36 am 
Offline
Newbie
Newbie

Joined: Tue Nov 06, 2018 1:34 pm
Posts: 4
Seems like is a known bug: https://bugs.winehq.org/show_bug.cgi?id=42148


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 6 posts ] 




Board index » WineHQ » Wine Help » macOS


Who is online

Users browsing this forum: No registered users and 7 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: