WineHQ
Wine Forums

Board index » WineHQ » Wine Help » macOS




 Page 1 of 1 [ 7 posts ] 



 
Author Message
 Post Posted: Sat Oct 20, 2018 6:53 am 
Offline
Newbie
Newbie

Joined: Sat Oct 20, 2018 6:28 am
Posts: 4
Hi all

On my iMac (macOS 10.13.6) I have been using an old wine (1.6) with a rather old BoincTask on my Mac : it was working but often freezing, using loads of CPU even when not open in forefront (BoincTask can only remain in systray).

I have successfully installed wine 3.0.3 latest stable version, I could install successfully BoincTask 1.7.8 latest stable version, at the end of the installation I would use the "run" checkbox and it ran just fine (only an ugly system font is used and I could not improve that but it worked).

I worked several days and I had to reboot, and then impossible to restart it again : I open the wine terminal, I go into the installation path

cd /Volumes/Macintosh\ HD/Users/jerome/.wine/drive_c/Program\ Files/eFMer/BoincTasks_1.7.8/

and then I run it

wine boinctasks64.exe

I get loads of output in the terminal :

Quote:
0034:fixme:nls:GetThreadPreferredUILanguages 00000034, 0x227754, 0x2277d0 0x227750
0034:fixme:nls:get_dummy_preferred_ui_language (0x34 0x227754 0x2277d0 0x227750) returning a dummy value (current locale)
iMac-Famile-Cadet:BoincTasks_1.7.8 jerome$ 0036:fixme:nls:GetThreadPreferredUILanguages 00000034, 0x237754, 0x2377d0 0x237750
0036:fixme:nls:get_dummy_preferred_ui_language (0x34 0x237754 0x2377d0 0x237750) returning a dummy value (current locale)
0038:fixme:winsock:set_dont_fragment IP_DONTFRAGMENT for IPv4 not supported in this platform
004c:fixme:winsock:WS_getsockopt WS_SO_CONNECT_TIME - faking results
0036:fixme:wtsapi:WTSRegisterSessionNotification Stub 0x103bc 0x00000000
0036:fixme:ieframe:PersistStreamInit_InitNew (0x699bb60)
0036:fixme:msg:ChangeWindowMessageFilter c096 00000001
0036:fixme:wininet:InternetSetOptionExA Flags 00000000 ignored
0036:fixme:wininet:InternetSetOptionExA Flags 00000000 ignored
0036:fixme:wininet:InternetSetOptionW Option 4 STUB
0036:fixme:wininet:InternetSetOptionExA Flags 00000000 ignored
0036:fixme:wininet:InternetSetOptionW INTERNET_OPTION_CONNECT_RETRIES 1
iMac-Famile-Cadet:BoincTasks_1.7.8 jerome$ 0036:fixme:ieframe:navigate_url Unsupported args (Flags 0x23eb70 {VT_I4: 0}; TargetFrameName 0x23eb20 {VT_BSTR: (null)})
iMac-Famile-Cadet:BoincTasks_1.7.8 jerome$ 0036:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
0036:fixme:dwmapi:DwmIsCompositionEnabled 0x6dbd1518
014b:fixme:iphlpapi:NotifyIpInterfaceChange (family 0, callback 0x69ebd3de, context 0xd16300, init_notify 0, handle 0x14ffa40): stub
0036:fixme:msctf:ThreadMgrSource_AdviseSink (0x6966a50) Unhandled Sink: {71c6e74e-0f28-11d8-a82a-00065b84435c}
54[c8c750]: TSF: 0x1831a30 TSFStaticSink::Init() FAILED to install ITfInputProcessorProfileActivationSink (0x80004001)
54[c8c750]: TSF: TSFTextStore::Initialize() FAILED to initialize TSFStaticSink instance
0036:fixme:imm:ImmGetDescriptionW (0x40c, 0x0, 0): semi stub
0036:fixme:imm:ImmGetDescriptionW (0x40c, 0x1831a98, 9): semi stub
0036:fixme:imm:ImmGetOpenStatus (0x6967ae0): semi-stub
0036:fixme:imm:ImmReleaseContext (0x20158, 0x6967ae0): stub
0036:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
0036:fixme:ieframe:BrowserService_GetTravelLog 0x6969a00 0x238c20
0036:fixme:ieframe:ClientSite_GetContainer (0x699bca8)->(0x238cc8)
0036:fixme:ieframe:ClientSite_GetContainer (0x699bca8)->(0x23d1b8)
0036:fixme:win:EnumDisplayDevicesW ((null),0,0x23c280,0x00000000), stub!
0036:fixme:ieframe:DocHostUIHandler_GetDropTarget (0x699bca8)
0036:fixme:mshtml:OleInPlaceActiveObject_TranslateAccelerator (0x9781900)->(0x66da8)
0017:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 2d1400 (device=2d access=0 func=500 method=0)
0017:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 2d1400 (device=2d access=0 func=500 method=0)
0017:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 2d1400 (device=2d access=0 func=500 method=0)
0036:fixme:ntdll:EtwRegisterTraceGuidsW (0x69cdb070, 0x57a8330, {509962e0-406b-46f4-99ba-5a009f8d2225}, 3, 0x57a8510, (null), (null), 0x57a8370): stub
0036:fixme:ntdll:EtwRegisterTraceGuidsW register trace class {a3da04e0-57d7-482a-a1c1-61da5f95bacb}
0036:fixme:ntdll:EtwRegisterTraceGuidsW register trace class {917b96b1-ecad-4dab-a760-8d49027748ae}
0036:fixme:ntdll:EtwRegisterTraceGuidsW register trace class {26d1e091-0ae7-4f49-a554-4214445c505c}
0036:fixme:ieframe:PropertyNotifySink_OnChanged unimplemented dispid 1005


And then it seems to have been started (I get the icon in systray) but when I click it it starts to open the main window I see the window upper part of the frame display and then that's it, nothing and the app is not accessible, and then it's frozen, the win64 process eats a stable 64% of one CPU core and nothing more happens I am forced to kill the wine process that is not responding anymore.

Any clue of what may happen ? where can I find some more tech info (log ?) in order to know why it's not running anymore when it has been running perfectly for several days ?

Or is this not the proper way to run it ? (via the wine terminal ?) (I never used that with my old wine for the old version of BT, I have a kind of shortcut but I realize just now it is actually a .app file, it's a small app that launches BT and and I can't remember how I did that, it's been several years I use it that way)

Thanks for your help.


Top 
 Post Posted: Sat Oct 20, 2018 7:44 am 
Offline
Moderator
Moderator
User avatar

Joined: Tue Mar 25, 2008 10:30 pm
Posts: 12360
Quote:
iMac-Famile-Cadet:BoincTasks_1.7.8 jerome$ 0036:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.

I don't know if that's the cause of this problem, but it is something you need to fix.
Quote:
(I never used that with my old wine for the old version of BT, I have a kind of shortcut but I realize just now it is actually a .app file, it's a small app that launches BT and and I can't remember how I did that, it's been several years I use it that way)

Sounds like you were using Wineskin, which is not supported here. Wineskin wrappers can contain various workarounds for issues, such as dll overrides or even patched versions of Wine. Basically you need to figure out what if any workarounds were in that wrapper and reproduce them. IMO, the wrapper probably included winbind, so installing that is where I'd start.


Top 
 Post Posted: Sun Oct 21, 2018 8:30 am 
Offline
Newbie
Newbie

Joined: Sat Oct 20, 2018 6:28 am
Posts: 4
I don't know about Wineskin, I used to use PlayOnMac at some point, maybe it's the one I used to my old version ?

The point is maybe I don't try to run it the way I should ? it it good to manually enter

cd /Volumes/Macintosh\ HD/Users/jerome/.wine/drive_c/Program\ Files/eFMer/BoincTasks_1.7.8/

.wine being a hidden directory (why it is hidden ?) to try to run directly the .exe file from a terminal ?

Isn't there any other "official" way to run apps than this with wine ?

How could you explain that I may have "any kind" of miss-installation issue (what is winbind and why would I need it ?) if it first ran OK for several days, when I accepted the "run now" checkbox after install was finished ?

Thanks


Top 
 Post Posted: Wed Oct 24, 2018 6:59 pm 
Offline
Level 3
Level 3

Joined: Mon Dec 25, 2017 12:11 pm
Posts: 59
dimesio wrote:
Quote:
iMac-Famile-Cadet:BoincTasks_1.7.8 jerome$ 0036:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.

I don't know if that's the cause of this problem, but it is something you need to fix.
Quote:
(I never used that with my old wine for the old version of BT, I have a kind of shortcut but I realize just now it is actually a .app file, it's a small app that launches BT and and I can't remember how I did that, it's been several years I use it that way)

Sounds like you were using Wineskin, which is not supported here. Wineskin wrappers can contain various workarounds for issues, such as dll overrides or even patched versions of Wine. Basically you need to figure out what if any workarounds were in that wrapper and reproduce them. IMO, the wrapper probably included winbind, so installing that is where I'd start.


Definitely not a ntlm_auth issue I also installed it into a clean prefix and it just worked using the wine-staging-3.18 from winehq. (and since the official builds don't by default pickup macports installations I know its fine)

Also Official Wineskin does not include ntlm_auth but Winebottler definitely does, I also don't see it included on PlayOnMac.

The only way to get ntlm_auth is not winbinds on macOS its by installing SAMBA3.


JeromeC wrote:
I don't know about Wineskin, I used to use PlayOnMac at some point, maybe it's the one I used to my old version ?

The point is maybe I don't try to run it the way I should ? it it good to manually enter

cd /Volumes/Macintosh\ HD/Users/jerome/.wine/drive_c/Program\ Files/eFMer/BoincTasks_1.7.8/

.wine being a hidden directory (why it is hidden ?) to try to run directly the .exe file from a terminal ?

Isn't there any other "official" way to run apps than this with wine ?

How could you explain that I may have "any kind" of miss-installation issue (what is winbind and why would I need it ?) if it first ran OK for several days, when I accepted the "run now" checkbox after install was finished ?

Thanks


I downloaded it myself and ran it without issue, I would suspect that your wineprefix got corrupted.


Top 
 Post Posted: Wed Oct 24, 2018 11:37 pm 
Offline
Newbie
Newbie

Joined: Sat Oct 20, 2018 6:28 am
Posts: 4
You are right it must have been winebottler ! (I said "several years" :) )

So I need to install a "samba3" thing ? How should I do this ?

And then the way I des ribe how I launch BT is... normal ?


Top 
 Post Posted: Thu Oct 25, 2018 1:06 pm 
Offline
Level 3
Level 3

Joined: Mon Dec 25, 2017 12:11 pm
Posts: 59
JeromeC wrote:
You are right it must have been winebottler ! (I said "several years" :) )

So I need to install a "samba3" thing ? How should I do this ?

And then the way I des ribe how I launch BT is... normal ?


If you want to install samab3 you need to install macports then use that to build and install samba3.

Yes that’s the standard way to launch applications with wine, you could also use the official guide to making a launcher


Top 
 Post Posted: Mon Nov 05, 2018 3:47 pm 
Offline
Newbie
Newbie

Joined: Sat Oct 20, 2018 6:28 am
Posts: 4
Hi

I was able to install MacPorts, then I try the command
Code:
sudo port install samba3

And I get this :
Quote:
---> Computing dependencies for samba3
The following dependencies will be installed:
gettext
libiconv
ncurses
popt
readline
zlib
Continue? [Y/n]: y
---> Fetching archive for ncurses
---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from https://packages.macports.org/ncurses
---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from http://lil.fr.packages.macports.org/ncurses
---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from http://mse.uk.packages.macports.org/sit ... rg/ncurses
---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from http://nue.de.packages.macports.org/ncurses
---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from http://fco.it.packages.macports.org/mir ... es/ncurses
---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from http://ywg.ca.packages.macports.org/mir ... es/ncurses
---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from http://sea.us.packages.macports.org/mac ... es/ncurses
---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from http://jnb.za.packages.macports.org/packages/ncurses
---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from http://kmq.jp.packages.macports.org/ncurses
---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from https://pek.cn.packages.macports.org/ma ... es/ncurses
---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from http://nou.nc.packages.macports.org/pub ... rg/ncurses
---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from http://jog.id.packages.macports.org/mac ... es/ncurses
---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from https://sha.cn.packages.macports.org/ma ... es/ncurses
Error: Failed to archivefetch ncurses: version @6.1_0: Failed to connect to sha.cn.packages.macports.org port 443: Connection refused
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_ncurses/ncurses/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port samba3 failed

The log they mention contains this :
Quote:
version:1
:debug:sysinfo macOS 10.13 (darwin/17.7.0) arch i386
:debug:sysinfo MacPorts 2.5.4
:debug:sysinfo Xcode 10.0
:debug:sysinfo SDK 10.13
:debug:sysinfo MACOSX_DEPLOYMENT_TARGET: 10.13
:debug:main Attempting ln -sf /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_ncurses/ncurses/work /opt/local/var/macports/sources/rsync.macports.org/macports/release/tarballs/ports/devel/ncurses/work
:debug:main dropping privileges: euid changed to 508, egid changed to 501.
:debug:main Executing org.macports.main (ncurses)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:archivefetch archivefetch phase started at Sun Nov 4 21:04:52 CET 2018
:msg:archivefetch ---> Fetching archive for ncurses
:debug:archivefetch Executing org.macports.archivefetch (ncurses)
:debug:archivefetch elevating privileges for archivefetch: euid changed to 0, egid changed to 0.
:debug:archivefetch dropping privileges: euid changed to 508, egid changed to 501.
:info:archivefetch ---> ncurses-6.1_0.darwin_17.x86_64.tbz2 doesn't seem to exist in /opt/local/var/macports/incoming/verified
:msg:archivefetch ---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from https://packages.macports.org/ncurses
:debug:archivefetch Fetching archive failed: LibreSSL SSL_connect: SSL_ERROR_SYSCALL in connection to packages.macports.org:443
:msg:archivefetch ---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from http://lil.fr.packages.macports.org/ncurses
:debug:archivefetch Fetching archive failed: The requested URL returned error: 403 OK
:msg:archivefetch ---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from http://mse.uk.packages.macports.org/sit ... rg/ncurses
:debug:archivefetch Fetching archive failed: The requested URL returned error: 403 OK
:msg:archivefetch ---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from http://nue.de.packages.macports.org/ncurses
:debug:archivefetch Fetching archive failed: The requested URL returned error: 403 OK
:msg:archivefetch ---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from http://fco.it.packages.macports.org/mir ... es/ncurses
:debug:archivefetch Fetching archive failed: The requested URL returned error: 403 OK
:msg:archivefetch ---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from http://ywg.ca.packages.macports.org/mir ... es/ncurses
:debug:archivefetch Fetching archive failed: The requested URL returned error: 403 OK
:msg:archivefetch ---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from http://sea.us.packages.macports.org/mac ... es/ncurses
:debug:archivefetch Fetching archive failed: The requested URL returned error: 403 OK
:msg:archivefetch ---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from http://jnb.za.packages.macports.org/packages/ncurses
:debug:archivefetch Fetching archive failed: The requested URL returned error: 403 OK
:msg:archivefetch ---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from http://kmq.jp.packages.macports.org/ncurses
:debug:archivefetch Fetching archive failed: The requested URL returned error: 403 OK
:msg:archivefetch ---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from https://pek.cn.packages.macports.org/ma ... es/ncurses
:debug:archivefetch Fetching archive failed: LibreSSL SSL_connect: SSL_ERROR_SYSCALL in connection to pek.cn.packages.macports.org:443
:msg:archivefetch ---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from http://nou.nc.packages.macports.org/pub ... rg/ncurses
:debug:archivefetch Fetching archive failed: The requested URL returned error: 403 OK
:msg:archivefetch ---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from http://jog.id.packages.macports.org/mac ... es/ncurses
:debug:archivefetch Fetching archive failed: The requested URL returned error: 403 OK
:msg:archivefetch ---> Attempting to fetch ncurses-6.1_0.darwin_17.x86_64.tbz2 from https://sha.cn.packages.macports.org/ma ... es/ncurses
:debug:archivefetch Fetching archive failed: Failed to connect to sha.cn.packages.macports.org port 443: Connection refused
:error:archivefetch Failed to archivefetch ncurses: version @6.1_0: Failed to connect to sha.cn.packages.macports.org port 443: Connection refused
:debug:archivefetch Error code: NONE
:debug:archivefetch Backtrace: version @6.1_0: Failed to connect to sha.cn.packages.macports.org port 443: Connection refused
:debug:archivefetch while executing
:debug:archivefetch "error [msgcat::mc "version @[option version]_[option revision][option portvariants]: %s" $lastError]"
:debug:archivefetch (procedure "portarchivefetch::fetchfiles" line 142)
:debug:archivefetch invoked from within
:debug:archivefetch "portarchivefetch::fetchfiles"
:debug:archivefetch (procedure "portarchivefetch::archivefetch_main" line 5)
:debug:archivefetch invoked from within
:debug:archivefetch "$procedure $targetname"
:error:archivefetch See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_ncurses/ncurses/main.log for details.

I tried with "samba4" (I saw it exists) but same problem.


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 7 posts ] 




Board index » WineHQ » Wine Help » macOS


Who is online

Users browsing this forum: No registered users and 6 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: