WineHQ
Wine Forums

Board index » WineHQ » Wine Help » macOS




 Page 1 of 1 [ 5 posts ] 



 
Author Message
 Post Posted: Sat Sep 22, 2018 7:15 am 
Offline
Newbie
Newbie

Joined: Sat Sep 22, 2018 4:18 am
Posts: 3
Hello! For the past week I've been trying to install Need For Speed Carbon on my Mac mini, which is running OS X 10.13.6 High Sierra. I jumped through hoops to get the right .exe from a site that didn't look too sketchy. I can get to the end of the installation process with both Wine and Wineskin, however I get the same error: When I tick the box to install DirectX, the installer runs into an error and fails. I assume there is a way to circumvent this using Winetricks, however I need help doing so.

It may be useful to you that I've accidentally downloaded the demo during my search and also gotten it to run perfectly.

Thanks in advance! :)


Top 
 Post Posted: Sun Sep 23, 2018 4:42 am 
Offline
Newbie
Newbie

Joined: Sat Sep 22, 2018 4:18 am
Posts: 3
Update: I overcame the DirectX problem, but the file that gets installed on my desktop ends in .desktop and I can't open it. I tried changing it to .exe to no avail.


Top 
 Post Posted: Sun Sep 23, 2018 11:21 am 
Offline
Level 2
Level 2

Joined: Mon Jul 31, 2017 3:55 am
Posts: 24
The exe is installed in "Program Files" or "Program Files (x86)" on the c-drive of your wine prefix. The file on your desktop is only a shortcut, that only works on Linux as far as I know, but under "Exec" it contains the command you need to start the exe.


Top 
 Post Posted: Sun Sep 23, 2018 12:43 pm 
Offline
Newbie
Newbie

Joined: Sat Sep 22, 2018 4:18 am
Posts: 3
Thanks, I found the exe. The problem now is that when I actually start the game, it hangs on a black screen. The only thing visible is an immovable cursor (which I can identify as the game's cursor) on the top left. I force quit and for some reason, the debugger seems to load the crash report forever.


Top 
 Post Posted: Mon Oct 01, 2018 11:17 am 
Offline
Level 2
Level 2

Joined: Mon Jul 31, 2017 3:55 am
Posts: 24
That's strange. Can you try to start the game by using the command line and then paste the output here, using code-tags? That might help to find the problem.


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 5 posts ] 




Board index » WineHQ » Wine Help » macOS


Who is online

Users browsing this forum: No registered users and 5 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: