Istebrak PotraitStudio no longer working

Questions about Wine on macOS.
Post Reply
Blue_Seas
Newbie
Newbie
Posts: 1
Joined: Tue Nov 14, 2017 12:40 pm

Istebrak PotraitStudio no longer working

Post by Blue_Seas » Tue Dec 19, 2017 5:20 pm

Hi, I got an old version of portraitstudio, a lighting engine, to run on wine. I downloaded the updated version and it now will no longer work. I get to the splash screen, then when I try to launch the program it closes. Any idea what I can do?

Here is the log while it loads, which has a few fixme commands

Code: Select all

fixme:heap:RtlSetHeapInformation 0x0 1 0x0 0 stub
fixme:system:SetProcessDPIAware stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x33f4a0,0x00000000), stub!
fixme:win:EnumDisplayDevicesW (L"\\\\.\\DISPLAY1",0,0x33f4a0,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),1,0x33f4a0,0x00000000), stub!
fixme:imm:ImmReleaseContext (0x100a0, 0x155608): stub
fixme:win:EnumDisplayDevicesW ((null),0,0x33f580,0x00000000), stub!
fixme:dxgi:DXGID3D10CreateDevice Ignoring flags 0x1.
fixme:dxgi:dxgi_check_feature_level_support Ignoring adapter type.
fixme:winediag:dxgi_check_feature_level_support None of the requested D3D feature levels is supported on this GPU with the current shader backend.
fixme:win:EnumDisplayDevicesW ((null),0,0x33f700,0x00000000), stub!
fixme:d3d:wined3d_check_device_format_conversion wined3d 0x15a840, adapter_idx 0, device_type WINED3D_DEVICE_TYPE_HAL, src_format WINED3DFMT_B8G8R8X8_UNORM, dst_format WINED3DFMT_B8G8R8X8_UNORM stub!
fixme:d3d:wined3d_check_device_format_conversion wined3d 0x15a840, adapter_idx 0, device_type WINED3D_DEVICE_TYPE_HAL, src_format WINED3DFMT_B8G8R8A8_UNORM, dst_format WINED3DFMT_B8G8R8X8_UNORM stub!
fixme:d3d:wined3d_check_device_format_conversion wined3d 0x15a840, adapter_idx 0, device_type WINED3D_DEVICE_TYPE_HAL, src_format WINED3DFMT_B8G8R8X8_UNORM, dst_format WINED3DFMT_B8G8R8X8_UNORM stub!
fixme:d3d:wined3d_check_device_format_conversion wined3d 0x15a840, adapter_idx 0, device_type WINED3D_DEVICE_TYPE_HAL, src_format WINED3DFMT_B10G10R10A2_UNORM, dst_format WINED3DFMT_B8G8R8X8_UNORM stub!
fixme:d3d:wined3d_check_device_format_conversion wined3d 0x15a840, adapter_idx 0, device_type WINED3D_DEVICE_TYPE_HAL, src_format WINED3DFMT_B5G6R5_UNORM, dst_format WINED3DFMT_B8G8R8X8_UNORM stub!
fixme:d3d:wined3d_check_device_format_conversion wined3d 0x15a840, adapter_idx 0, device_type WINED3D_DEVICE_TYPE_HAL, src_format WINED3DFMT_B5G5R5A1_UNORM, dst_format WINED3DFMT_B8G8R8X8_UNORM stub!
fixme:d3d:wined3d_check_device_format_conversion wined3d 0x15a840, adapter_idx 0, device_type WINED3D_DEVICE_TYPE_HAL, src_format WINED3DFMT_B5G5R5X1_UNORM, dst_format WINED3DFMT_B8G8R8X8_UNORM stub!
fixme:d3d:wined3d_check_device_format_conversion wined3d 0x15a840, adapter_idx 0, device_type WINED3D_DEVICE_TYPE_HAL, src_format WINED3DFMT_B8G8R8A8_UNORM, dst_format WINED3DFMT_B5G6R5_UNORM stub!
fixme:d3d:wined3d_check_device_format_conversion wined3d 0x15a840, adapter_idx 0, device_type WINED3D_DEVICE_TYPE_HAL, src_format WINED3DFMT_B8G8R8X8_UNORM, dst_format WINED3DFMT_B5G6R5_UNORM stub!
fixme:d3d:wined3d_check_device_format_conversion wined3d 0x15a840, adapter_idx 0, device_type WINED3D_DEVICE_TYPE_HAL, src_format WINED3DFMT_B10G10R10A2_UNORM, dst_format WINED3DFMT_B5G6R5_UNORM stub!
fixme:d3d:wined3d_check_device_format_conversion wined3d 0x15a840, adapter_idx 0, device_type WINED3D_DEVICE_TYPE_HAL, src_format WINED3DFMT_B5G6R5_UNORM, dst_format WINED3DFMT_B5G6R5_UNORM stub!
fixme:d3d:wined3d_check_device_format_conversion wined3d 0x15a840, adapter_idx 0, device_type WINED3D_DEVICE_TYPE_HAL, src_format WINED3DFMT_B5G5R5A1_UNORM, dst_format WINED3DFMT_B5G6R5_UNORM stub!
fixme:d3d:wined3d_check_device_format_conversion wined3d 0x15a840, adapter_idx 0, device_type WINED3D_DEVICE_TYPE_HAL, src_format WINED3DFMT_B5G5R5X1_UNORM, dst_format WINED3DFMT_B5G6R5_UNORM stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x33f070,0x00000000), stub!
fixme:d3d:debug_d3dformat Unrecognized 0xffffffff WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0xffffffff) in the format lookup table.
fixme:d3d:debug_d3dformat Unrecognized 0xffffffff WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0xffffffff) in the format lookup table.
fixme:d3d:debug_d3dformat Unrecognized 0xffffffff WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0xffffffff) in the format lookup table.
fixme:d3d:debug_d3dformat Unrecognized 0xffffffff WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0xffffffff) in the format lookup table.
fixme:d3d:debug_d3dformat Unrecognized 0xffffffff WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0xffffffff) in the format lookup table.
fixme:d3d:debug_d3dformat Unrecognized 0xffffffff WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0xffffffff) in the format lookup table.
fixme:d3d:debug_d3dformat Unrecognized 0x36314644 (as fourcc: DF16) WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0x36314644) in the format lookup table.
fixme:d3d:debug_d3dformat Unrecognized 0x434f5441 (as fourcc: ATOC) WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0x434f5441) in the format lookup table.
fixme:avrt:AvSetMmThreadCharacteristicsW (L"Audio",0x773f628): stub
fixme:win:RegisterRawInputDevices Unhandled flags 0x100 for device 0.
fixme:win:RegisterDeviceNotificationW (hwnd=0x100a0, filter=0x33fcac,flags=0x00000004) returns a fake device notification handle!
fixme:win:RegisterRawInputDevices Unhandled flags 0x100 for device 0.
fixme:win:UnregisterDeviceNotification (handle=0xcafeaffe), STUB!
fixme:win:RegisterDeviceNotificationW (hwnd=0x100a0, filter=0x33fca4,flags=0x00000004) returns a fake device notification handle!
fixme:win:RegisterTouchWindow (0x100a0 00000000): stub
fixme:winsock:set_dont_fragment IP_DONTFRAGMENT for IPv4 not supported in this platform
fixme:winsock:set_dont_fragment IP_DONTFRAGMENT for IPv6 not supported in this platform
and here's the log once that opens, and I try to launch the actual program

Code: Select all

fixme:exec:SHELL_execute flags ignored: 0x00004100
err:process:create_process L"C:\\users\\Ali\\Local Settings\\Application Data\\PortraitStudio\\PortraitStudio.exe" not supported on this installation (x86_64 binary)
err:process:create_process L"C:\\users\\Ali\\Local Settings\\Application Data\\PortraitStudio\\PortraitStudio.exe" not supported on this installation (x86_64 binary)
fixme:win:UnregisterDeviceNotification (handle=0xcafeaffe), STUB!
What do I do here?

Post Reply